hplip contextual menu is wrongly placed

Bug #1714191 reported by Jean-Baptiste Lallement on 2017-08-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-appindicator (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Tested on wayland

Test Case
1. Install hplib-gui and run hp-systray
  -> An icon is displayed in the icon bar
2. Click anywhere on the top panel (eg center of the panel)
3. Double-click on the HP icon to display the contextual menu

Expected result
The menu is displayed below the icon aligned on the left with it

Actual result
The contextual menu is displayed somewhere far on the left.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell-extension-appindicator 17.10
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Aug 31 10:22:08 2017
Dependencies:

InstallationDate: Installed on 2013-09-03 (1457 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
PackageArchitecture: all
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell-extension-appindicator
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in gnome-shell-extension-appindicator (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-appindicator (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-appindicator - 28-1

---------------
gnome-shell-extension-appindicator (28-1) experimental; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * New upstream release
  * indicatorStatusIcon: Ignore indicators with no menus, monitoring changes
    (LP: #1714504)
  * appIndicator: Retry getting a valid menu path (LP: #1714504)
  * dbusMenu: Ignore error on invalid return in AboutToShow
  * appIndicator: Update icon actor size on scale factor change (LP: #1730071)
  * dbusMenu: add isReady property when the menu is available on bus
  * indicatorStatusIcon: Don't support activation if we have a menu
    (LP: #1714191, LP: #1716056)
  * d/p/metadata-use-appindicator-namespace-and-naming.patch:
    - refresh and reduce diff with upstream

 -- Matteo F. Vescovi <email address hidden> Tue, 09 Apr 2019 22:28:45 +0200

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers