icons from qt applications disappear after screen lock/sleep

Bug #1712866 reported by Rachel Greenham on 2017-08-24
132
This bug affects 33 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-appindicator (Ubuntu)
High
Marco Trevisan (Treviño)
Artful
Undecided
Unassigned
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

Indicators of some Qt apps are not showing after unlocking the screen or shell restart.

[Test case]

- Login to 17.10
- launch dropbox (if not already launched)
- Launch telegram (snap version or without libappindicator support)
- Observe icons in taskbar
- Lock screen with Super+L
- Unlock screen
- Icons should still be there

[Possible regressions]

Icons that should be hidden could be visible instead

The fix doesn't apply to snapped applications

In the Ubuntu Xorg session, with the Ubuntu Appindicator extension enabled, the tray icons for QT apps (in my case, both owncloud-client from the Ubuntu repos and enpass, from their own repo) show up after first logging in. But once the screen has been left idle long enough to be put to sleep, and is then woken up (I don't actually have screen *lock* enabled, but it still goes comes back to the clock screen and a further gesture is needed to scroll that up to get the desktop), then the icons for those QT apps are gone. Non-QT apps (eg: in my case hexchat, from the ubuntu repos) remain.

For a while and due to inattention it seemed more random than that, but I'm fairly sure now it's just the display sleep/wake thing that kills it.

The applications are still running in the background (so for instance enpass is still available via the browser extension), and can be seen in the process list. It's just the icons that have disappeared. If I then kill those apps (from the commandline with 'kill [pid]' because there's no other interface to do it from) and relaunch them, they reappear back in the appindicator area.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell-extension-appindicator 17.10
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.6-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Aug 24 17:12:43 2017
Dependencies:

InstallationDate: Installed on 2017-07-30 (24 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
PackageArchitecture: all
SourcePackage: gnome-shell-extension-appindicator
UpgradeStatus: Upgraded to artful on 2017-08-22 (2 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-appindicator (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High

Additional observations (now someone's taken notice ;-) and I'm reminded of it myself):

It affects Wayland sessions too. Not xorg-specific.

Affects suspend/resume cycle too, not just display-sleep.

It may not affect all QT apps. For instance, since reporting this bug I've switched from Owncloud to Nextcloud, and nextcloud-client seems not to be affected, although, like the owncloud-client, its icon is half-size on HiDPI but that probably should be a separate bug.

This is something more related to Qt actually as it seems that these apps doesn't send the proper informations to us when they want to register an indicator.

This can be fixed at our level with a workaround by the way... I get this mostly in dropbox though, and not in the apps you mentioned.

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: Confirmed → In Progress
bagl0312 (bagl0312) wrote :

Hello,
I am affected by the same problem with ubuntu 17.10 (wayland session).
The following icons disappear after resuming/unlocking the screen: telegram, dropbox

Is it possible to install/try the modified version of gnome-shell-extension-appindicator ?

description: updated

Hello Rachel, or anyone else affected,

Accepted gnome-shell-extension-appindicator into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-appindicator/17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell-extension-appindicator (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
JaSauders (jasauders) wrote :

Thank you, developers, for your time regarding this issue. I'd like to chime in with my experiences following the proposed patch. Full disclosure: I did not enable proposed. I just downloaded the .deb generated for the appindicator-17.10.2.deb package and installed it. Afterwards, I rebooted and began to tinker.

The appindicator seems to "mostly work", at least with the apps I tested. These apps were Telegram, Quassel-Client, Nextcloud-Client, Dropbox, and VLC.

Quassel, Nextcloud, and VLC work fine. They come back each time (so far in my testing) when unlocking the screen. This success is true for both typical locks/unlocks along with suspend/resume. The only thing worth noting about this behavior is that the order of the icons seems to change every time. It's almost as if they are ordered by their response speed upon the session unlocking again. It varies, it's not a big deal, but I think it's worth noting, however they *do* come back -- that's an improvement for sure.

The story changes with Telegram and Dropbox. With ease I can trigger the disappearance of the Telegram tray icon. One suspicious thing worth noting here is the Telegram tray icon is very undersized. This is entirely speculation, but is it possible Telegram is excluded from this patch working because of this undersized icon issue? I recall seeing a bug report regarding very small icons in the appindicator tray...

Dropbox failed to come back approximately 3/4 of the time. On some tests, Dropbox did come back, but an easy majority of the time Dropbox was no where to be found upon resuming. I can confirm via system monitor that Dropbox is still indeed running, though.

If there are other patches in proposed that might help with this, then I apologize ahead of time regarding the fact that I simply downloaded the appindicator.17.10.2.deb package from launchpad. Otherwise, while there's some definite improvements, perhaps this behavior is the sign of a lingering issue.

Again, thank you devs, for your time and hard work. :)

JaSauders (jasauders) wrote :

Er, it might be possible to ignore my prior post (couldn't find a means to edit it). Originally I installed the .deb via Gnome Software, but I later (after already posting my experience with the update, of course) checked the version of the package via dpkg -l. It indicated I was on 17.10.1... not .2.

This time I installed the package via dpkg -l. After verifying it was 17.10.2 via dpkg -l I tested again, specifically with Dropbox and Telegram since they were issues before, and they seem to be holding on when resuming from lock screen. I can't instigate them to disappear now.

Apologies about that. I'll continue testing, but so far, so good.

Thanks. :)

I definitely have 17.10.2 installed, from proposed.

On my Xorg system: In fact since this bug was first reported, things have actually gotten worse, in that these days these icons hardly ever appear *at all* from the original login, let alone disappearing after a screen lock. 17.10.2 hasn't fixed this, but OTOH this wasn't precisely the bug you were trying to fix. But as things stand, as usual, my nextcloud and enpass icons are not showing up at all so persistence through a screen lock is untestable. (Also I still have the problem of gnome-shell crashing during screen lock, so it would be hard to test anyway. But that too is the subject of other bug reports.)

"hardly ever"? Sometimes, occasionally, they show up, and I don't know what's different about those days. Not today, apparently.

This appears to be an Xorg thing. On my wayland machine they do show up on login, and the disappear after screen lock, as originally described. I'll enable proposed on that machine and test over the weekend.

bagl0312 (bagl0312) wrote :

Hi Rachel,
did you try to install the package sni-qt ?

sudo apt install sni-qt

this worked for me with some icons

i have sni-qt installed already, i believe as a result of following an earlier hint to the same effect. It didn't actually have any discernible effect for me. (In fact, I wonder if I should remove it...)

bagl0312 (bagl0312) wrote :

I tested the version 17.10.2 proposed of gnome-shell-extension-appindicator (installing the .deb package) under wayland.
It seems to work, i.e. the icons of telegram, dropbox and other services I am using do not disappear anymore after lock/unlock

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-appindicator - 17.10.2

---------------
gnome-shell-extension-appindicator (17.10.2) artful; urgency=medium

  * Fix icons from qt applications disappearing after screen lock/sleep.
    Thanks Marco (LP: #1712866)

 -- Didier Roche <email address hidden> Mon, 23 Oct 2017 10:15:12 +0200

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: In Progress → Fix Released
Adolfo Jayme (fitojb) on 2017-10-27
affects: qt → hundredpapercuts
no longer affects: hundredpapercuts

Confirmed on my Wayland system: after a short lock-screen test, both my qt indicators, enpass and nextcloud-client, survive the lock period. With respect to another comment above, both of these are the wrong size, the nextcloud one being half its proper size, and the enpass one being the correct width now, but actually double it's proper *height*, or at least stretched vertically to fill the height of the top bar. Which I mention in order to say that despite these size issues their *presence* on the bar after a screen lock still appears to be fixed.

Will let it sleep for longer in case that produces different results. (It does with respect to gnome shell crashing bugs, so it seems worth testing.)

(confirmed stays fixed after a longer sleep (actual suspend) too.

just as an aside, relating to comments #13 and #14... removing sni-qt *did* help. I have my appindicators back in xorg.

... and they survive at least a short screen lock too. Sorry for the multiple posts. Everyone ignore when anyone says to install sni-qt to fix qt app indicator issues. it doesn't, it makes things worse! :-)

bagl0312 (bagl0312) wrote :

Hi Rachel,
in my case install the sni-qt package is needed to show some indicators (like for example insync).
It has not side effects for me...
Apparently it depends on the single applications

Jeremy Bicha (jbicha) wrote :

I am marking this bug as verified since there are several reports that the proposed version fixes the screen lock bug.

Please file bugs for the remaining issues.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-appindicator - 17.10.2

---------------
gnome-shell-extension-appindicator (17.10.2) artful; urgency=medium

  * Fix icons from qt applications disappearing after screen lock/sleep.
    Thanks Marco (LP: #1712866)

 -- Didier Roche <email address hidden> Mon, 23 Oct 2017 10:15:12 +0200

Changed in gnome-shell-extension-appindicator (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell-extension-appindicator has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

no longer affects: qt
Changed in qtbase-opensource-src (Ubuntu):
status: New → Fix Released
Rumen (rzaprianov) wrote :

I use 18.04 / login session Xorg and had the same issue. Got help from the IRC channel.

Workaround for me which actually works:

Alt+F2

Type "r" without the quotes

Hit "Enter"

The icons appears!

Regards all.

Rumen

This bug is marked as "fix released", but I still see this problem in bionic as of today. is this a regression?

tags: added: bionic
Mihai (redstar2k) wrote :

I can confirm this happening to me in 18.04 Bionic.
The icons disappear after lock/sleep.
Restarting with Alt+F2 + r makes them reappear.

FWIW I have *not* seen this since upgrading to Bionic. It was probably fixed sooner, when they said it was, but at some point I gave up on Artful because of various gnome-shell problems including this, went back to Mac, and tried again with a fresh Bionic install, where they almost all seem to have been fixed.

Darkalex (darkalex) wrote :

Happened to me recently.
Update & Reboot fixed this issue.

This happening to me in 18.04 Bionic: the icons disappear after lock/sleep and do not appear on login.
Restarting with Alt+F2 + r makes them reappear.

Confirmed on Ubuntu 18.04 (clear installation).

Confirmed on two Ubuntu 18.04 workstations (upgraded from 16.04). One of them did not have the problem until today.

rojer (rojer9) wrote :

yes, this still happens in Bionic.

does not happen if i login with Wayland session (but wayland is buggy in different ways, so not really a solution).

Snaker (snaker.me) wrote :

Confirmed on clean Ubuntu 18.04 installation, GNOME 3.28.2.

Now I'm testing the following fix, looks work:
1. Update everything with Software Updater.
2. Install GNOME tweaks (if not installed).
3. Open Tweaks -> Extensions, set Ubuntu appindicators ON.

Snaker (snaker.me) wrote :

Sometimes appindicators workaround doesn't work and icons disappear again, but noticeably less often.

jidckii (jidckii) wrote :
Yan Li (yanli) wrote :

Also seeing this problem with 18.10 Cosmic. The offending Qt application is the VirtualBox from Ubuntu repo.

tags: added: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers