Multimedia keys are disabled

Bug #995185 reported by BenginM on 2012-05-05
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
TJ

Bug Description

Salutation , Sary here ..

mohd@mohd-SATELLITE-M100:~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

This a Toshiba Satellite M-100 .. a friend mechaine I have just installed Ubuntu for him , but the Multimedia keys dosn't work at all.

I have tried to folllow few steps mentioned in this wiki https://help.ubuntu.com/community/MultimediaKeys

the page seems to be out of date , but anyhow i did followed ...

1st of

# The link to acerhk is Forbidden .. i don't even know what this package for!

# KeyTouch package is missing , or replaced .

# Going to a real console and pressing the mutlimedia keys dosn't show an output .

# Assigning X keysyms .. xev shows

KeyRelease event, serial 29, synthetic NO, window 0x3800001,
    root 0x14f, subw 0x0, time 4927691, (962,430), root:(963,486),
    state 0x0, keycode 36 (keysym 0xff0d, Return), same_screen YES,
" XLookupString gives 1 bytes: (0d) "
    XFilterEvent returns: False

PropertyNotify event, serial 32, synthetic NO, window 0x3800001,
    atom 0x15e (_NET_WM_STATE), time 4927729, state PropertyNewValue

FocusOut event, serial 32, synthetic NO, window 0x3800001,
    mode NotifyNormal, detail NotifyNonlinear

PropertyNotify event, serial 32, synthetic NO, window 0x3800001,
    atom 0x15e (_NET_WM_STATE), time 4935308, state PropertyNewValue

# i haven't yet looked at kern.log or syslog .

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sat May 5 20:36:18 2012
InstallationMedia: Sabily-small 11.04 "Badr" - i386 (20110505)
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to precise on 2012-04-30 (5 days ago)

BenginM (sary) wrote :
BenginM (sary) wrote :

mohd@mohd-SATELLITE-M100:~$ uname -a
Linux mohd-SATELLITE-M100 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 i686 i386 GNU/Linux
mohd@mohd-SATELLITE-M100:~$ lsmod | grep toshiba
toshiba_bluetooth 12711 0
mohd@mohd-SATELLITE-M100:~$ modprobe toshiba
FATAL: Module toshiba not found.
mohd@mohd-SATELLITE-M100:~$ modprobe toshiba_acpi
WARNING: Error inserting sparse_keymap (/lib/modules/3.2.0-24-generic/kernel/drivers/input/sparse-keymap.ko): Operation not permitted
FATAL: Error inserting toshiba_acpi (/lib/modules/3.2.0-24-generic/kernel/drivers/platform/x86/toshiba_acpi.ko): Operation not permitted
mohd@mohd-SATELLITE-M100:~$ dmesg |grep toshiba
[ 28.488161] toshiba_bluetooth: Detected Toshiba ACPI Bluetooth device - installing RFKill handler
[ 28.494486] toshiba_bluetooth: Re-enabling Toshiba Bluetooth
mohd@mohd-SATELLITE-M100:~$

BenginM (sary) on 2012-05-06
summary: - Mutlimedia keys Disabled
+ Mutlimedia keys are disabled
summary: - Mutlimedia keys are disabled
+ Multimedia keys are disabled
Thomas Ward (teward) wrote :

This is not a bug, however seems to be a request for support.

You should go to the IRC for support, or post on ubuntuforums.org or askubuntu.com about this, in order to get support for this issue.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Invalid
BenginM (sary) wrote :

This is mohammed saleem , am logged in from sary's account .. i would like to upload logs in text files that sary had collected on my home folder will upload them as attachment i don't know how to upload them all it once!

BenginM (sary) wrote :
BenginM (sary) wrote :
BenginM (sary) wrote :
BenginM (sary) wrote :

I would also like to note that this The Toshiba Satellite M-100 have a multimedia/function keys on the primary keyboard and they are located in front of the hardware power switch .

 see the picture http://www.notebookreview.com/assets/11009.jpg

TJ (tj) wrote :

Mohammed, sorry I took so long to move on this after our discussion on IRC. My earlier research on your behalf indicates this is a regression since earlier releases of Ubuntu have supported the multimedia keys on the Satellite M-100.

I'm assigning this issue to myself and will log my findings about what support should be there, which version added it and if there is any reason for the regression.

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → In Progress
importance: Undecided → Medium
assignee: nobody → TJ (intuitivenipple)
TJ (tj) wrote :

From the provided dmesg log:

TOSHIBA SATELLITE M100/HAQAA

input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3

input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/LNXVIDEO:00/input/input4

input: PS/2 Mouse as /devices/platform/i8042/serio4/input/input5
input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio4/input/input6

[ 10.526236] lm90 2-004c: Register 0x4 read failed (-6)
[ 10.526239] lm90 2-004c: Failed to read convrate register!
[ 10.530233] lm90 2-004c: Register 0x3 read failed (-6)
[ 10.530235] lm90 2-004c: Initialization failed!

input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8

atkbd serio0: Unknown key pressed (translated set 2, code 0x9b on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e01b <keycode>' to make it known.
atkbd serio0: Unknown key released (translated set 2, code 0x9b on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e01b <keycode>' to make it known.
atkbd serio0: Unknown key pressed (translated set 2, code 0x9b on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e01b <keycode>' to make it known.
atkbd serio0: Unknown key released (translated set 2, code 0x9b on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e01b <keycode>' to make it known.

atkbd serio0: Unknown key released (translated set 2, code 0xe0 on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e060 <keycode>' to make it known.

TJ (tj) wrote :

Could you do a test and document the results?

Boot the laptop from a cold start and then press and release each of the media keys in turn. Write down the keys and the order you press them in.

Then attach the /var/log/dmesg file along with the ordered list of keys you pressed.

This will allow me to correlate the key-scan codes with the keys you pressed and compare against the engineering manual for the M100.

TJ (tj) wrote :

I forgot to ask. Please also report the model number and any other codes printed on the label on the base of the M100 so we can identify the exact variation.

BenginM (sary) wrote :

Salutation TJ , Sary here .. thank you for your kind interest on the subject matter .. Muhammad left his laptop with me for a week or so now .. i'll turn it on and get back to you with the dmesg log .

BenginM (sary) wrote :

Okay , so the Model from the back sticker is : Toshiba Satellite M-100-222 , MODEL No : PSMA1E-0NV024AR .

SERIAL No : Z6717852G

BenginM (sary) wrote :

There are 6 Multimedia keys , during boot i pressed each starting with the first 1 from the left ( The Browser Key )

BenginM (sary) wrote :

bear with me Tj , trying to attach the file .. but am getting Bad Request

Your browser sent a request that this server could not understand.

BenginM (sary) wrote :

i would like to mention that i have tried to use toshset as you suggest to him .. but i get the same result as reported in these bugs :

https://bugs.launchpad.net/ubuntu/+source/toshset/+bug/181374

https://bugs.launchpad.net/ubuntu/+source/toshset/+bug/644898

BenginM (sary) wrote :
BenginM (sary) wrote :

Strange .. i don't see similar output in the last dmesg log to your log posted in #10 .

TJ (tj) wrote :

Hi Sary, thanks for the prompt response.

The first thing I notice is the kernel version you just used is different to the original dmesg:

Original:

[ 0.000000] Linux version 3.2.0-23-generic (buildd@crested) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu4) ) #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 (Ubuntu 3.2.0-23.36-generic 3.2.14)
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=daeaa295-5990-4302-a175-fe2559526049 ro quiet splash vt.handoff=7

Now:

[ 0.000000] Linux version 3.0.0-19-generic (buildd@vernadsky) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #33-Ubuntu SMP Thu Apr 19 19:05:57 UTC 2012 (Ubuntu 3.0.0-19.33-generic 3.0.27)
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-19-generic root=UUID=710b9731-f503-4f39-8891-b8292e060a73 ro quiet splash vt.handoff=7

This looks to be a two different installations. The original one was using 12.04 Precise, this later one looks to be using 11.10 Oneiric. Is the PC set up for multiple boots into different releases?

Second thought regarding dmesg. dmesg used to only capture the initial boot messages which were switched to /var/log/kern.log once the system got going. That has changed with 12.04 so that might explain why - if you're using 11.10 Oneiric now - you don't see the key-scan codes reported in dmesg.

To find all occurrences try this:

grep -n 'setkeycodes' /var/log/*

You may need to prefix that command with 'sudo' if some files aren't accessible to your user account.

BenginM (sary) wrote :
Download full text (10.6 KiB)

mohd@m1:~$ sudo grep -n 'setkeycodes' /var/log/*
[sudo] password for mohd:
/var/log/auth.log:4:May 25 15:54:08 m1 sudo: mohd : TTY=pts/1 ; PWD=/home/mohd ; USER=root ; COMMAND=/bin/grep -n setkeycodes /var/log/alternatives.log /var/log/apt /var/log/auth.log /var/log/auth.log.1 /var/log/autokey-daemon.log.old /var/log/boot /var/log/boot.log /var/log/bootstrap.log /var/log/btmp /var/log/clamav /var/log/ConsoleKit /var/log/cups /var/log/dist-upgrade /var/log/dmesg /var/log/dmesg.0 /var/log/dmesg.1.gz /var/log/dmesg.2.gz /var/log/dmesg.3.gz /var/log/dmesg.4.gz /var/log/dpkg.log /var/log/faillog /var/log/fontconfig.log /var/log/fsck /var/log/gdm /var/log/installer /var/log/jockey.log /var/log/jockey.log.1 /var/log/kern.log /var/log/kern.log.1 /var/log/lastlog /var/log/lightdm /var/log/mail.err /var/log/mail.log /var/log/nanny.log /var/log/news /var/log/pm-powersave.log /var/log/pycentral.log /var/log/samba /var/log/speech-dispatcher /var/log/syslog /var/log/syslog.1 /var/log/syslog.2.gz /var/log/syslog.3.gz /var/log/udev /var/log/ufw.log /var/log/unattended-upgrade
/var/log/kern.log:5:May 25 14:26:00 m1 kernel: [ 666.815541] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:7:May 25 14:26:00 m1 kernel: [ 667.012533] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:9:May 25 14:26:00 m1 kernel: [ 667.116254] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:11:May 25 14:26:00 m1 kernel: [ 667.166930] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:13:May 25 14:26:00 m1 kernel: [ 667.210411] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:15:May 25 14:26:00 m1 kernel: [ 667.282322] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:17:May 25 14:26:00 m1 kernel: [ 667.387678] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:19:May 25 14:26:00 m1 kernel: [ 667.425363] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:21:May 25 14:26:00 m1 kernel: [ 667.520228] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:23:May 25 14:26:00 m1 kernel: [ 667.569090] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:25:May 25 14:26:01 m1 kernel: [ 667.639208] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:27:May 25 14:26:01 m1 kernel: [ 667.701829] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:29:May 25 14:26:01 m1 kernel: [ 667.798364] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:31:May 25 14:26:01 m1 kernel: [ 667.827987] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:33:May 25 14:26:01 m1 kernel: [ 667.932845] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:35:May 25 14:26:01 m1 kernel: [ 667.964165] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
/var/log/kern.log:37:May 25 14:26:01 m1 kernel: [ 668.062816] atkbd seri...

BenginM (sary) wrote :

TJ , Good thinking .. i forgot to mentioned that i wen back to 11.10 because he want to use Sabily , which still did not released 12.04 .. i could upgrade to Precise if that would make any difference .

BenginM (sary) wrote :

I must address this , the fan on this machine spins so loud unstoppable .. all i can think of is the BIOS ! , but thats another issue to deal with.

BenginM (sary) wrote :

@James , thank you for your interest on watching this issue ..

and TJ ..

this doesn't seem as a real bug in Ubuntu .. or does it ! and if so is it assigned against the proper Package / Tool / utility / .. etc.

TJ (tj) wrote :

Sary. If Ubuntu is not supporting the standard features of the PC then it is a bug. We know that the Linux kernel is passing the key-codes so now its my job to figure out what the fix is and which package that applies to.

If I need to change the package this bug is assigned to I will do that. For now you need do nothing except respond to any requests I might make to test possible solutions or to do further diagnostics.

BenginM (sary) wrote :

Thanks , that cleared things .. Noted.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers