power : gnome-settings-daemon crashed with SIGSEGV in gnome_rr_screen_get_dpms_mode

Bug #971353 reported by j2snowden on 2012-04-02
294
This bug affects 80 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Unassigned

Bug Description

spontaneous crash at startup

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
CasperVersion: 1.312
Date: Mon Apr 2 12:11:23 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
LiveMediaBuild: Xubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANGUAGE=
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
Title: [power]: gnome-settings-daemon crashed with SIGSEGV in gnome_rr_screen_get_dpms_mode()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

j2snowden (m8r-didia8) wrote :

This crash has the same stack trace characteristics as bug #956824. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/971353

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

I've subscribed Pedro Villavicencio

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/971353

tags: added: localized-iso
tags: added: quantal
Fabio Marconi (fabiomarconi) wrote :
description: updated
description: updated
apimanpaul (ptalbot) wrote :

bug I D doesn't fix it

tags: added: running-unity
Sasa Paporovic (melchiaros) wrote :

This also affects Quantal Ubuntu12.10 64bit on system start. System updated to 18.7.2012 - today.

It happends on a HP 655 Laptop which is relative new hardware, also with dedicated AMD HD 7000 series graphic.

Pedro Nunes (nunes-p89) wrote :

Subscribed..
It happens with my system

AMD Phenom II X4 945
2X2GB DDR III 1333mhz
Asus M4A785TD-M Evo
Gigabyte HD 7850 OC version

Software: Ubuntu 12.04, Kernel 3.2.0.20, 32bits/64bits (problem happens in both)

When I start Ubuntu its all ok
I open firefox, go to youtube, play a video, and firefox crash
Close session, ubuntu crash, the login screen appears to choose the user, but i cant do anything.
Anything that may use some 3d acceleration like changing workspace, crashes

This is a very serious problem, since i need to use windows to work in my desktop

Thanks

Michael Terry (mterry) on 2012-09-04
Changed in gnome-settings-daemon (Ubuntu Quantal):
assignee: nobody → Michael Terry (mterry)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu Precise):
status: New → Confirmed
Michael Terry (mterry) wrote :

OK, I think I know why this is happening, though I can't reproduce myself. I have uploaded gnome-settings-daemon 3.4.2-0ubuntu12 to quantal-proposed. I'd really appreciate testing by those that get this crash. I'm confident, but not certain I've got the right fix.

[Gory details if you happen to know the code] The idletime signals are firing after the power manager is stopped. idletime is a singleton that hands out references to itself every time it is 'created'. And stop() is expecting a mere unref() to disconnect the signals. But it doesn't if idletime has been reffed more times. So this patch manually disconnect the signals we set up.

Para Siva (psivaa) wrote :

This occurred again when quantal-desktop-amd64+mac.iso of 20120905.2 during a live session. Just tried to do some settings change during the live session, such as changing the keyboard layout, timezone change. If it does not occur leave it for some time and this would occur.

ALSO, reported a couple of bugs before for amd64+mac with the crash files but made invalid due to uncompatible symbol files. So may be that need to be looked at as well for live sessions not containing the correct symbol files.
Thanks

Para Siva (psivaa) wrote :

The same again during the live session on amd64 hardware. 20120905.2

Michael Terry (mterry) wrote :

This doesn't seem reliably reproducable, so I'm just going to mark this Fix Released and see if it still gets reported.

gnome-settings-daemon (3.4.2-0ubuntu12) quantal-proposed; urgency=low

  * debian/patches/bugzilla_segfault_dpms.patch:
    - Update to cover another way to get the same segfault. (LP: #971353)

Changed in gnome-settings-daemon (Ubuntu Quantal):
assignee: Michael Terry (mterry) → nobody
status: Confirmed → Fix Released
Changed in gnome-settings-daemon:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.