[power]: gnome-settings-daemon crashed with SIGSEGV in engine_get_icon_priv()

Bug #969535 reported by Andy Hill on 2012-03-30
294
This bug affects 42 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Critical
gnome-settings-daemon (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

on login

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu1
Architecture: amd64
Date: Fri Mar 30 19:38:25 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
 SHELL=/bin/false
 PATH=(custom, no user)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
Title: [power]: gnome-settings-daemon crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Andy Hill (neoshades) wrote :
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: [power]: gnome-settings-daemon crashed with SIGSEGV in
- g_main_context_dispatch()
+ engine_get_icon_priv()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
tags: added: bugpattern-needed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/969535

tags: added: iso-testing
Nathaniel W. Turner (nturner) wrote :

This is not just an occasional crash for me; gnome-settings-daemon *always* segfaults on startup. I mention this because I suspect this is not the case for everyone using unity-2d (otherwise the bug heat would be higher). So if anyone is working on this but having trouble reproducing the problem, let me know. I don't have time to debug this right now, nor am I familiar with the code, but I'll be happy to test patches and provide debug logs or whatever.

Nathaniel W. Turner (nturner) wrote :

Just in case it's helpful, here's the output of "gnome-settings-daemon --debug".

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue with that version?

gnome-settings-daemon (3.4.0-0ubuntu4) precise; urgency=low

  * debian/patches/disconnect_from_up_client.patch:
    - Disconnect any signals from a UpClient object before we unref it.
      UpClients are ref-counted singletons and may stay around after
      unref, so we have to be explicit. LP: #965487

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Incomplete
Nathaniel W. Turner (nturner) wrote :

@seb128, just to be clear, are you asking me to downgrade to 3.4.0-0ubuntu4 from 3.4.0-0ubuntu7 where this still reproduces?

Nathaniel W. Turner (nturner) wrote :

Setting back to Confirmed, as this still reproduces with the latest gnome-settings-daemon (3.4.1-0ubuntu1), which I think is what Sebastien meant.

For what it's worth, I tried creating a fresh user account to see if the problem was related to some odd user configuration settings; however, the problem still reproduces for a freshly created user.

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Hey Mike, that seems a bit similar to the issue you fixed recently, could you look at it as well when you have some time?

Changed in gnome-settings-daemon (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
iain MacDonnell (dseven) wrote :

FWIW, I'm also seeing this, using GNOME classic with Precise updated on 2012-04-22. I have a triple-head Xinerama config, in case that makes any difference...

Nathaniel W. Turner (nturner) wrote :

I thought I had mentioned it in this bug, but I guess I hadn't --- I also have a triple-head Xinerama config (on an Nvidia Quadro NVS 450).

Also, since it may not be clear to those who are not experiencing this bug, when gnome-settings-daemon crashes at startup, it means that most apps (Thunderbird, Firefox, Chrome, etc.) are totally unthemed, and many desktop-wide settings (such as font size adjustments, etc.) are not applied at all. In other words, the desktop looks like crap and is hard to use.

If this isn't fixed for the Precise release, it might be a good idea to have a prominent item in the release notes discouraging folks with nontrivial multi-head setups from upgrading...

Sebastien Bacher (seb128) wrote :

@Nathaniel: you are sure you are getting the same issue? Does it happen at every login for you? Could you add your .xsession-errors to the bug? The bug there is one in the power manager code, it's weird that the screen configuration impacts on it...

Michael Terry (mterry) wrote :

This bug and bug 868928 look very similar. The device array has been free'd and null'd, but the code continues. Looking into why.

Michael Terry (mterry) wrote :

NM, this is different from bug 868928. I think I see how this could happen. Basically, the power manager sets itself up on dbus, but only can properly receive property-get requests for part of the time (while the manager is start()'ed but not stop()'d).

Michael Terry (mterry) on 2012-04-25
Changed in gnome-settings-daemon (Ubuntu Precise):
status: Confirmed → Fix Committed

I would just like to mention that I am experiencing exactly the same effect as Nathaniel and also have Xinerama config.

Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → Fix Released
Jess Morecroft (jess-t) wrote :

Eagerly awaiting the patch for this to be released for Precise. We installed the LTS obviously without knowledge of this bug and now our four monitor Quadro NVS 420 driven displays are virtually useless. As Nathaniel mentioned above, with Xinerama setting applied the daemon crashes and consequently "the desktop looks like crap and is hard to use". Running with just two screens in the interim.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.1-0ubuntu2

---------------
gnome-settings-daemon (3.4.1-0ubuntu2) quantal; urgency=low

  * debian/patches/power-check-null-devices.patch:
    - NULL-guard the return value of up_client_get_devices.
      LP: #868928
  * debian/patches/power-ignore-bad-dbus-requests.patch:
    - If we get a DBus request while the manager isn't active, ignore it.
      LP: #969535
 -- Michael Terry <email address hidden> Tue, 01 May 2012 09:12:02 -0700

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Michael Terry (mterry) wrote :

Just uploaded a fix for this to quantal and precise-proposed.

Matt Zuba (matt-mattzuba) wrote :

Thanks Michael, I tested the patch and at least I'm not getting crashes anymore, however the only thing I noticed a bit 'off', and I'm not sure if this is my settings, or something else, but when I use nVidia Twinview, the HUD in Unity is transparent, when using Xinerama, it's a black background. Related?

Michael Terry (mterry) wrote :

Matt, thanks for testing! I doubt that HUD issue is related to this specific bug. I'd suggest filing a new bug. But glad that the crash is fixed!

Nathaniel W. Turner (nturner) wrote :

I don't see 3.4.1-0ubuntu2 in precise-proposed, but I did a build from the source package for quantal and can also confirm that with Michael's fix, the problem no longer reproduces. Nice!

Hello Andy, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
iain MacDonnell (dseven) wrote :

Fix seems to be working for me (so-far). Note that the new version is 3.4.1-0ubuntu1.1, not 3.4.1-0ubuntu2 as suggested above - spent a few mins scratching my head over that one, before I found the changelog.

I'm going to miss the retro 1990's Motif look :)

Thanks!

    ~iain

Michael Terry (mterry) wrote :

Thanks, Iain! Yeah, the ubuntu2 version you saw go by was for quantal. The update for 12.04 was ubuntu1.1, as you found out. :)

tags: added: verification-done
removed: verification-needed
Jess Morecroft (jess-t) wrote :

Thanks Michael! That fix works for us. Our desktop is back to 4 monitor goodness.

One annoying thing that is persisting however is we are unable to open "Displays" .... keep getting a "could not get screen information, randr extension is not present" error .... which prevents us from configuring sticky edges etc. I doubt this is related to this bug though.

John Schroeder (jschroed) wrote :

The fix is working well. No more crashes and back to a normal desktop. The workaround for configuring displays (sticky edges and launcher placement) was to turn off xinerama and make the changes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.1-0ubuntu1.1

---------------
gnome-settings-daemon (3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/power-check-null-devices.patch:
    - NULL-guard the return value of up_client_get_devices.
      LP: #868928
  * debian/patches/power-ignore-bad-dbus-requests.patch:
    - If we get a DBus request while the manager isn't active, ignore it.
      LP: #969535
 -- Michael Terry <email address hidden> Tue, 01 May 2012 09:30:20 -0700

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.