[power]: gnome-settings-daemon crashed with SIGSEGV in engine_update_composite_device()

Bug #965487 reported by RedSingularity on 2012-03-26
564
This bug affects 89 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Happens while in a live session. Easily reproducible. Boot a live session and choose to install ubuntu. Wait a few seconds and the message will come up.

ProblemType: CrashDistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CasperVersion: 1.312
Date: Mon Mar 26 16:44:10 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120325)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvReason: reading NULL VMASignal: 11SourcePackage: gnome-settings-daemon
Title: [power]: gnome-settings-daemon crashed with SIGSEGV in g_cclosure_marshal_VOID__OBJECTv()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

RedSingularity (redsingularity) wrote :
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/965487

tags: added: iso-testing
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
description: updated
description: updated
Erick Brunzell (lbsolost) wrote :

I'm making some assumptions here. First bug 962458 may not be a true duplicate of this bug. Second bug 962926 was reported as a duplicate of bug 962458 but I have serious doubts if that was correct. Regardless please look at bug 962926 for apport collected info, and bug 962458 for my comments.

What I'm seeing is that if I just let the i386 20120327.1 Ubuntu iso boot past the non-interactive boot screen to the point that Try Ubuntu or Install Ubuntu appear, and then select Try Ubuntu, when the live DE comes up a language notification appears in the top panel/menu bar and apport reports an error. Please see the screenshot in comment #7 at bug 962458.

But if I boot the same live image and press a key when the non-interactive screen appears so the actual boot menu will appear, then press Enter to select the default English language, and then select Try Ubuntu from that boot menu no language notification appears in the menu bar, and no error is reported by apport.

I seriously doubt that bug 962458 is a true duplicate of what I'm seeing because it's described as happening after a parted crash.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
summary: [power]: gnome-settings-daemon crashed with SIGSEGV in
- g_cclosure_marshal_VOID__OBJECTv()
+ engine_update_composite_device()
Sebastien Bacher (seb128) wrote :

stracktrace starts with

#0 engine_update_composite_device (manager=0x8854800,
    original_device=0x8854a28) at gsd-power-manager.c:848
        i = 0
        percentage = 0
        energy = 0
        energy_full = 0
        energy_rate = 0
        energy_total = 0
        energy_full_total = 0
        energy_rate_total = 0
        time_to_empty = 0
        time_to_full = 0
        battery_devices = 0
        is_charging = 0
        is_discharging = 0
        is_fully_charged = 1
        array = 0x0
        device = <optimized out>
        state = <optimized out>
        kind = <optimized out>
        original_kind = <optimized out>

tags: removed: need-i386-retrace
Peter Hurley (phurley) wrote :

@RedSingularity,

As I expected and noted, this bug is *not* a duplicate of bug# 962458, as confirmed by the completed i386 stack backtrace. This bug dies in engine_update_composite_device, whereas the amd64 stack backtrace for bug# 962458 indicates that crash @ engine_get_icon_priv.

In the future, please don't assume that two bugs are related because they crash in the same binary.

RedSingularity (redsingularity) wrote :

@Peter

I must have read through it too fast. Sorry about that.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Sebastien Bacher (seb128) wrote :

Could one of your report the bug to GNOME?

@Sebastien

Took care of it.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Thanks, if you need a stacktrace you can install gnome-settings-daemon-dbgsym on the liveCD before reporting the bug (with the glib dbg package as well if you have space)

tags: added: need-i386-retrace
tags: removed: need-i386-retrace

I managed to get a proper stacktrace from it.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in gnome-settings-daemon:
status: Incomplete → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/965487

tags: added: localized-iso
Jeff (jeffsf) wrote :

Occurs "every" time I start a session under tightvncserver, fully-patched Precise Beta2, AMD64 variant

Hi Jeff, please check "fully-patched" means g-s-d 3.4.0 If not, please evaluate update (and advise if changed).
I've done my best to trial with tightvnc, but 'no banana' ;(. (No connection despite telnet-able, so no session.) (Was running server on 12.04b2 side.)

Michael Terry (mterry) wrote :

I've got a patch for this. Working on it.

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Triaged → In Progress
Michael Terry (mterry) wrote :

See https://bugzilla.gnome.org/show_bug.cgi?id=673007#c17 for explanation of why this happens and the fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.0-0ubuntu4

---------------
gnome-settings-daemon (3.4.0-0ubuntu4) precise; urgency=low

  * debian/patches/disconnect_from_up_client.patch:
    - Disconnect any signals from a UpClient object before we unref it.
      UpClients are ref-counted singletons and may stay around after
      unref, so we have to be explicit. LP: #965487
 -- Michael Terry <email address hidden> Mon, 09 Apr 2012 12:45:13 -0400

Changed in gnome-settings-daemon (Ubuntu Precise):
status: In Progress → Fix Released
Changed in gnome-settings-daemon:
status: New → Fix Released
To post a comment you must log in.