duplicated battery icon in gnome-classic (notification area)

Bug #965279 reported by Lucazade on 2012-03-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

If I add the notification-area applet in gnome-classic panel there is
an extra battery icon beside the stock indicator-power.

If I disable the power plugin in dconf settings-daemon the extra useless battery
is no more present. So it seems due to gnome-settings-daemon.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Mon Mar 26 13:40:33 2012
SourcePackage: gnome-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, how do you start your session? Could you do "echo $XDG_CURRENT_DESKTOP" and copy the result here?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

$ echo $XDG_CURRENT_DESKTOP
GNOME

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

ok, that's because we use indicator-power, the status icon will be disabled for all sessions in the next upload

Whoopie (whoopie79) wrote :

I have updated the 60_unity_hide_status_icon.patch to also hide the battery status icon when GNOME classic is used.

Please find attached a debdiff.

Whoopie (whoopie79) wrote :

Oh, Sebastien was too fast.

The attachment "gnome-settings-daemon_3.4.0-0ubuntu3.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.0-0ubuntu3

---------------
gnome-settings-daemon (3.4.0-0ubuntu3) precise; urgency=low

  * debian/patches/correct_logout_action.patch:
    - display the logout action on ctrl-alt-del (lp: #961501)
  * debian/patches/60_unity_hide_status_icon.patch:
    - don't show the power status icon under classic either (lp: #965279)
  * debian/patches/git_keyring_environment.patch:
    - "Get the environment from gnome-keyring When launching
       custom applications." (lp: #839444)
 -- Sebastien Bacher <email address hidden> Tue, 03 Apr 2012 17:28:40 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
hansvschoot (hansvschoot) wrote :

is there any way to overrule this behaviour? I prefer the notification area battery icon (because I'm using Avant Window Navigator)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers