[xsettings]: gnome-settings-daemon crashed with SIGSEGV in translate_int_int()

Bug #963704 reported by Tomas Cassidy on 2012-03-24
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

This error just appeared. Don't know why.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Sat Mar 24 17:43:23 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120323)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 SHELL=/bin/false
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
Title: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in g_cclosure_marshal_VOID__STRINGv()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Tomas Cassidy (tomas-cassidy) wrote :

StacktraceTop:
 translate_int_int (manager=0xc07c00, trans=0x7fa8aa15a4e0, value=0xc42670) at gsd-xsettings-manager.c:291
 process_value (value=0xc42670, trans=0x7fa8aa15a4e0, manager=0xc07c00) at gsd-xsettings-manager.c:771
 xsettings_callback (manager=0xc07c00, key=<optimized out>, settings=0xbb18f0) at gsd-xsettings-manager.c:816
 xsettings_callback (settings=0xbb18f0, key=<optimized out>, manager=0xc07c00) at gsd-xsettings-manager.c:796
 g_cclosure_marshal_VOID__STRINGv (closure=0xc0d180, return_value=<optimized out>, instance=0xbb18f0, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0xaa0a60) at /build/buildd/glib2.0-2.31.22/./gobject/gmarshal.c:1004

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in
- g_cclosure_marshal_VOID__STRINGv()
+ translate_int_int()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/963704

tags: added: iso-testing
visibility: private → public
Erick Brunzell (lbsolost) wrote :

Duplicate bug 981355 appeared only once after installing 'gnome-panel', 'indicator-applet',& 'indicator-applet-session', then logging out, choosing classic (no effects) and initially logging into the classic DE. All subsequent boots have been error free. If it were not marked as a duplicate I'd be tempted to mark it invalid.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu2

---------------
gnome-settings-daemon (3.4.2-0ubuntu2) quantal; urgency=low

  * debian/patches/xsettings_signal_handling.patch:
    - upstream bugzilla patch, fix segfaults in the xsettings code which
      seem to happen at logout
      (lp: #946295, #948347, #963704)
 -- Sebastien Bacher <email address hidden> Wed, 23 May 2012 21:50:41 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Hello! This bug is attached to an upload in the queue for precise-proposed. However, it does not contain the requisite fields for the SRU team to process the upload. Please add them per the process outlined here. To be more succinct, make sure the bug description lists these fields: "Impact, Dev Fix, Stable Fix, Regression Potential, Test case".

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

The upload will likely not be looked at by the SRU team until these fields are present.

Thank you!

Sebastien Bacher (seb128) wrote :

see bug #946295 for the SRU summary

Hello Tomas, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

not sure if the segfault is fixed but the new version works without regression so setting it verification-done

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers