CTRL+ALT+DEL no longer brings up "Logout Dialog"

Bug #961501 reported by Rainer Rohde on 2012-03-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

This is a regression.

Pressing CTRL+ALT+DEL no longer brings up "Logout Dialog", but launches the "Shutdown Dialog" instead. This stated to happen a few days ago.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-19.31-generic 3.2.12
Uname: Linux 3.2.0-19-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 21 13:50:26 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to precise on 2012-03-02 (19 days ago)

Related branches

Rainer Rohde (rainer-rohde) wrote :
Rainer Rohde (rainer-rohde) wrote :

This bug has not been fixed today's gnome-settings-daemon.

gnome-settings-daemon:
  Installed: 3.4.0-0ubuntu2
  Candidate: 3.4.0-0ubuntu2
  Version table:
 *** 3.4.0-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     3.4.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's a wanted upstream change:
http://git.gnome.org/browse/gnome-settings-daemon/commit/?id=86c152eabcac6386f275132cbd0c111821e15c34

"media-keys: Call Shutdown for the logout action
By default will request whether to shut down the machine, or reboot it.

https://bugzilla.gnome.org/show_bug.cgi?id=671979"

Not sure that's what we want though...

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

see also bug #890747 about what it should be doing

description: updated
Rainer Rohde (rainer-rohde) wrote :

I see. I'd rather have the logout option when pressing CTRL+ALT+DEL, because when pushing the power button on my laptop, the shutdown dialog appears. Historically, CTRL+ALT+DEL "killed" the X-window session, effectively logging you out. That concept should be kept.

Doesn't make sense to me why pushing the power button and pressing CTRL+ALT+DEL bring up the same dialog...

Rainer Rohde (rainer-rohde) wrote :

... and yes, I agree with the sentiments in bug #890747 - there should be more options available when pressing CTRL+ALT+DEL.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.0-0ubuntu3

---------------
gnome-settings-daemon (3.4.0-0ubuntu3) precise; urgency=low

  * debian/patches/correct_logout_action.patch:
    - display the logout action on ctrl-alt-del (lp: #961501)
  * debian/patches/60_unity_hide_status_icon.patch:
    - don't show the power status icon under classic either (lp: #965279)
  * debian/patches/git_keyring_environment.patch:
    - "Get the environment from gnome-keyring When launching
       custom applications." (lp: #839444)
 -- Sebastien Bacher <email address hidden> Tue, 03 Apr 2012 17:28:40 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Rainer Rohde (rainer-rohde) wrote :

This works again as expected! Thanks to everyone involved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.