[power]: gnome-settings-daemon crashed with SIGSEGV in gnome_rr_screen_get_dpms_mode()

Bug #956824 reported by Fabio Marconi on 2012-03-16
146
This bug affects 32 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
New
Medium
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Hello
It crash on a fresh dreated usb live session, no actions performed.
Thanks
fabio

ProblemType: CrashDistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.91-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.311
Date: Fri Mar 16 10:08:27 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ExecutableTimestamp: 1331836366LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120316)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcCwd: /
ProcEnviron:
 LANGUAGE=
 TERM=linux
 PATH=(custom, no user)
 LANG=
SegvAnalysis:
 Segfault happened at: 0x7f27b83aed89 <gnome_rr_screen_get_dpms_mode+73>: mov 0x18(%rdi),%rax
 PC (0x7f27b83aed89) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: gnome-settings-daemon
StacktraceTop:
 gnome_rr_screen_get_dpms_mode () from /usr/lib/libgnome-desktop-3.so.2
 gnome_rr_screen_set_dpms_mode () from /usr/lib/libgnome-desktop-3.so.2
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: [power]: gnome-settings-daemon crashed with SIGSEGV in gnome_rr_screen_get_dpms_mode()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Fabio Marconi (fabiomarconi) wrote :
visibility: private → public

StacktraceTop:
 gnome_rr_screen_get_dpms_mode (screen=0x0, mode=0x7fff0036541c, error=0x7fff00365468) at gnome-rr.c:1157
 gnome_rr_screen_set_dpms_mode (screen=0x0, mode=GNOME_RR_DPMS_ON, error=0x7fff00365468) at gnome-rr.c:1241
 idle_set_mode (manager=0x1f01050, mode=<optimized out>) at gsd-power-manager.c:3021
 idle_evaluate (manager=0x1f01050) at gsd-power-manager.c:3190
 _g_closure_invoke_va (closure=0x1ff7720, return_value=0x0, instance=0x1f4fb80, args=0x7fff00365788, n_params=0, param_types=<optimized out>) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:840

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/956824

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Tobin Davis (gruemaster) on 2012-03-16
tags: added: armhf
Fabio Marconi (fabiomarconi) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=672245

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
assignee: Stéphane Graber (stgraber) → nobody
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/956824

tags: added: localized-iso
tags: added: qa-manual-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.0-0ubuntu2

---------------
gnome-settings-daemon (3.4.0-0ubuntu2) precise; urgency=low

  * debian/patches/10_smaller_syndaemon_timeout.patch:
    - don't change delay, use -t option to block the clicks (lp: #962958)
  * debian/patches/61_unity_use_application_indicator.patch:
    - small tweaks to be consistant with other indicators,
      change the order and label from the two bottom items (lp: #964178)
  * debian/patches/bugzilla_segfault_dpms.patch:
    - upstream fix for a segfault (lp: #956824)

  [ Iain Lane ]
  * debian/patches/16_use_synchronous_notifications.patch: Fix invalid cast
    causing segfault when using keyboard backlight keys. (LP: #959874)
 -- Sebastien Bacher <email address hidden> Thu, 29 Mar 2012 21:43:49 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.