the locate pointer option breaks other keybindings

Bug #9441 reported by Michael Koshelev on 2004-10-25
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Fix Released
gnome-settings-daemon (Ubuntu)

Bug Description

If 'Locate pointer' mouse feature is enabled (Computer->Desktop
preferences->Mouse->Cursors->Locate Pointer), and you try to copy file by
Ctrl+dragging, nautilus will stop responding when you release Ctrl or left mouse
button to drop copy to destination folder. This effectively disables all desktop
operations and panels until nautilus is killed from console.

Exact sequence to reproduce:
0) Enable 'Locate pointer' mouse feature
1) press Ctrl
2) drag file to destinaton
3) release Ctrl or left mouse button
You must FIRST press Ctrl, and THEN begin to drag file - if order is reverse
operation will success.

Sebastien Bacher (seb128) wrote :

*** Bug 23213 has been marked as a duplicate of this bug. ***

Carthik Sharma (carthik) wrote :

Changing status to confirmed, since upstream has had this bug since 2003, and a patch too, but the patch hasn't yet been committed.

Changed in control-center:
status: Unconfirmed → Confirmed
Changed in control-center:
status: Unconfirmed → Confirmed
Changed in control-center:
status: Confirmed → Triaged
Andreas Moog (ampelbein) wrote :

This works for me in Intrepid. Can you confirm it is fixed for you, too?

Changed in control-center:
assignee: seb128 → desktop-bugs
Toby Bartels (tobybartels) wrote :

Something very like this is still broken for me in Intrepid; there is a lot of discussion at Bug #217685 (now marked as a duplicated of this bug).

Toby Bartels (tobybartels) wrote :

See also Bug #303921, which may be same thing, it turns out.

Toby Bartels (tobybartels) wrote :

Also bug #188702. I hesitate to mark these all as duplicates until it's confirmed that disabling Locate Pointer works for them all. But I wouldn't be surprised.

summary: - Nautilus stops responding on copy-drag if 'Locate pointer' mouse feature
- is enabled
+ the locate pointer action breaks other keybindings
summary: - the locate pointer action breaks other keybindings
+ the locate pointer option breaks other keybindings
affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
Mark Painter (mpainter) wrote :

I've seen one case of this in Hardy where disabling "Locate Pointer" did not work, I've yet to track down what part of the profile was still conflicting.

Pedro Izecksohn (izecksohn) wrote :

This bug seems fixed here, on Jaunty on amd64.

Pedro Izecksohn (izecksohn) wrote :

But I'd like to use Ctrl+t to open gnome-terminal and 'Locate pointer' impedes it.

MD4 (bruno-mueller) wrote :


I have a Dell Studio 1555 with Jaunty 9.04 AMD64 fresh install, and I see this very same problems with the media keys (they are on F7 to F12).
As soon as I enable the Locate Pointer these keys stop working.

Mike-coder (mflint) wrote :

Confirming bug.

I have a Dell Inspiron 6400 (in the UK - think it might be an E1505 in the US), and Locate Pointer was killing my keyboard audio mute button (as bug 303921), on 8.10. Switching off the Locate Pointer restored things.

talent03 (talent03) wrote :

I just wanted to confirm this as well with M1330 media keys not working when locate pointer is selected. I marked my own bug as a duplicate once I found this. I am using Ubuntu 9.04 Jaunty.

Anton¡o Sch¡fano (skiantoz) wrote :

I just noticed that (in Karmic) if I activate this option, also CTRL+<Mouse wheel> will stop working, which is very annoying for instance in web browsers.

frizzle21 (frederik-nnaji) wrote :

@Antonio: i think it's only Firefox..
Epiphany doesn't have this problem, OpenOffice doesn't either:
upon CTRL Scroll they zoom, after releasing CTRL they show the pointer position.

i think firefox is doing something wrong here.. could it be?

Changed in gnome-control-center:
importance: Unknown → Medium
Kirill Müller (krlmlr) wrote :

Ctrl key events are not passed to Virtualbox 4.1.2 if the "Locate pointer" feature is enabled.

Kirill: I am commenting as the member of the VirtualBox development team in charge of keyboard handling in Linux. My guess is that the "locate pointer" tool places a "passive grab" [1] on the control key. What this means if it is correct is that as of the point when the grab is placed no other application can see the control key being pressed or released unless the tool explicitly allows it (I presume it doesn't); however they can still (usually) see combinations including the control key, such as Ctrl-Scroll in Frederik's example above. Certainly VirtualBox relies on being able to spot individual keypresses and releases and doesn't try to monitor key combinations to work around this sort of thing: we take the point of view that if the user wants to take keys away from us for other purposes they should know what they are doing, and we don't want to add complexity to deal with it and risk creating bugs for other people. If there were a nice way of spotting passive grabs by other applications we might warn the user, but I don't know of any way other than trying to grab every key ourselves to see which ones we can't get.


I had the locate cursor option turned on for at least a week before this bug bit me. For some reason, though other programs are ok (I'm sure I used Ctrl+Z in lots of other tools), Ctrl+Z in Blender was interpreted as just plain 'Z', which toggles wireframe instead of Undo-ing. Turning off the locate cursor option fixed it right away.

Just leaving this here in case someone goes looking for 'Ctrl+Z', 'Blender', 'wireframe', and 'bug'...

Changed in gnome-settings-daemon (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Mike Mestnik (cheako) wrote :

The solution for me, using xfce4, was to logout and into gnome-shell. Then I could change the setting... Using gconf-editor didn't work, the option was checked when I looked at it in gnome's control center under mouse. When I loged back into xfce4, all was/is good. xev reports ctl as it should.

Sebastien Bacher (seb128) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center:
status: Confirmed → Fix Released
pabouk (pabouk) wrote :

The problematic option in Ubuntu 12.04 is:
System Settings -> Mouse and Touchpad -> Show position of pointer when the Control key is pressed

This bug causes also problems in:
VNC Viewer
Remmina (if Grab all keyboard events is not turned on)

pabouk (pabouk) wrote :

> Changed in gnome-control-center:
> status: Confirmed → Fix Released

Where can I see for which Ubuntu release was the fix released? In Ubuntu 12.04 the bug is still present.

Sebastien Bacher (seb128) wrote :

it's not fixed in Ubuntu yet that's why the ubuntu line is "fix commited" and not "fix released"

Sebastien Bacher (seb128) wrote :

The issue is fixed with 3.6 in raring

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Ben Abrams (benabrams41) wrote :

This is still not fixed or is a regression in xenial. Should we re-open or create a new request?

I can replicate this with keepass2 and virtualbox.

Replication steps:
1. Go to gnome tweak tool and change "Show location of pointer" to "ON"
2. attempt to use the ctrl key such as ctrl + c, all ctrl key combinations are swallowed.
3. Go to gnome tweak tool and change "Show location of pointer" to "OFF"
4. attempt to use the ctrl key such as ctrl + c, everything should work as intended.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.