Ubuntu does not remember LCD brightness

Bug #896595 reported by Ernestas on 2011-11-26
194
This bug affects 41 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Unknown
Medium
gnome-settings-daemon (Baltix)
Medium
Unassigned
gnome-settings-daemon (Fedora)
Unknown
Unknown
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

Everytime I boot Ubuntu (or ArchLInux, but this is a bug report for Ubuntu...) screen brightness gets set to maximum. I think it's a problem of a kernel, but kernel.org doesn't have a bug report form yet, and as far as I know Ubuntu has a little bit patched kernel, so maybe someone will create a patch for this.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: udev 173-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sat Nov 26 17:08:38 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: ASUSTeK Computer Inc. K43SJ
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=422db72c-3b01-4413-ac35-541447d8f6af ro quiet splash vt.handoff=7
SourcePackage: udev
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/16/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K43SJ.210
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: K43SJ
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK43SJ.210:bd02/16/2011:svnASUSTeKComputerInc.:pnK43SJ:pvr1.0:rvnASUSTeKComputerInc.:rnK43SJ:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K43SJ
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Ernestas (ernetas) wrote :
Martin Pitt (pitti) on 2011-11-28
affects: udev (Ubuntu) → gnome-settings-daemon (Ubuntu)
yo (yomoyourmind) wrote :

i'm on hp pavilion dv6, i5, 4gb ram, ubuntu 11.10 unity

the screen brightness keeps getting set to 100% after restart, it does not remember the setting i leave it at.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Lina Pug (linapug) wrote :

Hi papukaija! Hello all!
Excuse the delay in my response.
I would like to help. How to get those details which you refer?

By now I can say that I have a laptop and a netbook, both Samsung.
The laptop is 64bit and have installed Ubuntu 12.04. The netbook is 32bit and have installed Xubuntu 11.10. Both have the same problem reported by me and I applied the same solution in both.
Although my laptop has two video cards - Intel and Nvidia, I think the problem is the "ever blessed" card from Intel... so beloved by Samsung.

Best Regards!
Lina

(my bug description on 2012-04-12)

<<The screen brightness always start with 100% and typing the Fn + F2/F3 keys only makes to appear the pointer on the screen, but doesn't work.

To change the screen brightness, only in the System Configurations – Brightness and Block, “every time that one switch on or restart the notebook”.

If one want to change again “ in the same session”, when the application window opens the screen brightness return to 100%.

I solve this problem changing the command line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"

even thus, at every restart one need to change the brightness, the configuration doesn't hold.

My Notebook:
Samsung model 300E4A-AD1
Intel Core i5 2450M
Ubuntu 12.04 64bits
Graphic Processor Intel GMA HD
Chipset Intel HM65>>

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → In Progress
Brendan Griffin (brenfar) wrote :

This bug is creating all kinds of problems for me because I can't do remote starts, I can't boot and then leave the computer without experiencing massive battery drain. Hopefully it will be fixed soon.

mark baraco (mkbaraco) wrote :

I'm gonna have to stop using Ubuntu because of this bug. All my displays are getting burn-in from the high brightness. I thought LCD screens were immune to burn in, but I've been proven wrong. The Launcher has been burned into my screen. The firefox URL bar as well.

Hopefully this will be fixed soon, cause I'm gonna have to start using Windows until this is fixed. I don't want to damage my screen any more than it already is.

Lina Pug (linapug) wrote :

And ... well, after last update (07-23-2012), which was good... nearly lost.
Now only works Fn + F2, that is, I can only decrease the brightness of screen.
Fn + F3 does not work anymore. The brightness control of Sistem Configuration is not working too.
I tried redoing the change that I wrote before, but this did not work.
Now I'm looking for another solution.
Anyone else experienced this problem, this change?
Does anyone know how to solve this?

Best Regards!

Lina Pug (linapug) wrote :

Hello everyone!

I did some research on the site "Ask Ubuntu" and been able to solve the problem, I think definitely.
I rewrote the command:

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"

as follows:

GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi="

For more details access the page:

Brightness controls stopped working after update on a Samsung
http://askubuntu.com/questions/168197/brightness-controls-stopped-working-after-update-on-a-samsung-qx412-s01au

Great guys of Ask Ubuntu!

Best Regards!

Quim Gil (quimgil) wrote :

Hi, not sure whether this is the same bug but reporting anyway, just in case it's useful:

Running Ubuntu 12.10 Beta 2 64 on a Lenovo T430. Brightness control works well both with Fn F8/F9 and with the settings window. Logging out and in preserves the previous brightness value. But shutting down or restarting brings back the 100% brightness.

Not the end of the world but annoying, yes.

I can confirm having run into this bug on my Toshiba Satellite A505-S6960 under Ubuntu 12.04 LTS and after installing Ubuntu 12.10 over it. It's a big battery drain and I have to keep turning the brightness down manually after logging in; it's very annoying.

tags: added: precise quantal

This bug also affects Ubuntu 13.04 on a fresh install. Tested with an ASUS EeePC 1215N and a Zenbook Prime UX32VD.

tags: added: raring
Wesley Turner (wturnerharris) wrote :

Confirming that this issue also affects a fresh install of Raring 13.04 as well as on the recent updates. Unity does not remember LCD brightness or (in my case) keyboard backlight brightness. For me this has been an issue since 11.04. My system is a 13" MacBook 5,2 (first unibody with removable battery). There are ways to set the brightness of both at startup via scripts, but Unity does not remember on its own. This is most definitely a bug since mostly all other systems will remember their settings after a reboot.

Changed in gnome-settings-daemon (Baltix):
status: New → Confirmed
importance: Undecided → Medium
Changed in gnome-settings-daemon:
status: In Progress → Unknown
Dmitry Savin (envelsavinds) wrote :

It looks like feature is implemented in systemd >= 209 and it stores screen backlight brightness for the whole system (not per user).
The attached patch allows you to restore backlight for each user separately in gnome-settings-daemon 3.8.5 for Ubuntu 13.10.

The attachment "gsd_keep_backlight.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pierre Equoy (pierre-equoy) wrote :

The problem still happens with Ubuntu 14.04.

I'm using an Asus K43SD (Intel® Pentium(R) CPU B970 @ 2.30GHz × 2 and GeForce 610M/PCIe/SSE2 GPU).

Steps to reproduce:

1. Using Settings > Brightness & Lock (or Brightness Indicator <https://launchpad.net/~indicator-brightness/+archive/ubuntu/ppa/+packages>), set the screen brightness to minimum (see attachement for details).
2. Wait until the screen turns off (in my case, 5 minutes).
3. Wake up the screen by moving the mouse/typing on the keyboard
→ the screen brightness is back to 100% (Not OK)
→ Brightness indicator indicates brightness=0
→ Brightness level in Settings is also to the minimum, which is in contradiction with the fact that screen brightness is to the max.

If I scroll down on the brightness indicator, the screen will immediately go to the dimmest brightness.

I hope a solution can be found for this issue! :)

Pierre Equoy (pierre-equoy) wrote :

P.S.: it looks like there was a similar issue in earlier versions of Ubuntu, but a fix was released... I don't know if this issue is related:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/137598

Jingguo Yao (yaojingguo) wrote :

This still happens on Ubuntu 14.04 64 bit. I am using Thinkpad T440S. The following workaround works for me:

http://askubuntu.com/questions/151651/brightness-is-reset-to-maximum-on-every-restart

Jingguo Yao (yaojingguo) wrote :

After recovering from screen dimming, the brightness is set set maximum for my case. For this problem, I follow the instructions in https://wiki.ubuntu.com/Kernel/Debugging/Backlight. After adding "acpi_backlight=vendor" kernel parameter, the problem is fixed.

But during the boot of Ubuntu, I still get the following error message:

thinkpad_acpi: Unsupported brightness interface, please contact <email address hidden>.

I am using Ubuntu 14.04 64 bit with a Thinkpad T440S.

Norbert (nrbrtx) on 2015-04-12
summary: - Ubuntu does not remember LID brightness
+ Ubuntu does not remember LCD brightness
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.