"Low disk space" warning popping up repeatedly.

Bug #881376 reported by donquixote on 2011-10-25
154
This bug affects 31 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

On Ubuntu 11.10 Oneiric Ocelot.
Since that upgrade, I repeatedly get the warning

"Low Disk Space"
"The volume "..." has only [..] MB disk space remaining.
This is for a few Windows partitions on a multiboot machine, which I mount by default on Linux startup.

The problem:
- I could not care less about disk space on these partitions, while on Linux. I want to take care of them while on Windows.
- The dialog is showing up repeatedly for the same disk.
- It's a disruptive popup dialog, instead of being a more subtle bubble notification (this is being discussed in a feature request somewhere on launchpad).
- The "Don't show any warnings again for this file system" does not have any effect. Yes, it does change a setting somewhere in system settings, but the popup will show up nevertheless.
- Trying to change the threshold or the exclude directories via system settings did not help either.
- I did not find how to uninstall or disable this new "feature".

This is just one of the many things that make the new 11.10 a horrible experience for me.

donquixote (lemon-head-bw) wrote :

Btw, it would already help me a lot if I knew how to disable or uninstall this thing.

donquixote (lemon-head-bw) wrote :

Btw,
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/405237
No idea if this is the same thing, but:
I can make the popup show up again by typing "gnome-settings-daemon" on the console. I have no idea what this command would do, but it does give me the error popup.

Robert Roth (evfool) on 2011-10-25
affects: ubuntu → gnome-settings-daemon (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
zzarko (zzarko-gmail) wrote :

I have about 10 almost full NTFS partitions with various data (and I like it that way) and this dialog pops up every minute or so, for the same partitions, although I clicked on "Don't show" checkbox. It is EXTREMELY annoying. Is there at least any way to completly turn off this feauture?

zzarko (zzarko-gmail) wrote :

I even added all paths to my NTFS drives to housekeeping/ignore_paths (using gconf-editor), but warnings keep popping up... Any idea how to stop them? Working in this situation is almost impossible...

Ubuntux (4chim) wrote :

Exactly the same thing is happening on my machine over and over again.
Those "Low Disk Space" warnings keep popping up... although I checked the "Don't show warning again"-dialog several times.

Modifying "housekeeping/ignore_paths" using gconf-editor didn't work for me either.

Strangely those warning-messages don't reappear if you clicked them away a few times (about five to six times for the same volume!).
But after a reboot everything starts all over.

It's very annoying since I have several partitions that are "intentionally full".
(Partitions that each hold one image-file of the partitions size. I mount these image-files via a script.)

This problem occured after upgrading to 11.10 ... 11.04 worked fine.

Hope this can be fixed soon.

Thanks.

Fabian Schmidt (fnjschmidt) wrote :

One "workaround" (this really doesn't deserve the name...) is to just open the disk space analyzer and keep it in the background. This "mutes" the messages.

Would really be nice if this bug would be fixed asap, it's things like these that make Ubuntu less and less fun to use with every release.

kk_hephot (ksk) wrote :

Can also confirm this on a fresh install of 11.10 (x86-64). I have near-full NTFS partitions and I keep getting "low disk space" notifications even after checking the "Don't show any warnings again for this file system" box. I added the partitions to /etc/fstab post-install (by uuid) rather than specifying mount points for them during installation at the partitioning stage. Starting the "Disk Usage Analyser" app and going to Edit -> Preferences and then unchecking the partitions makes no difference.

pef (pef-gomez) wrote :

Hi,

I'm also affected by this bug, on a fresh install of Ubuntu 11.10 Oneiric Ocelot.

In my case, I use a bunch of LVM2 logical volumes to store my files. Each volume holds a "collection" of related files, so its size intentionally fits its contents as close as possible : in order words, most of my logical volumes intentionally have as few free space as possible.

If I need more space in a "collection", I extend the corresponding logical volume. If I need to store a new "collection" of related files, I create a new logical volume.

Those logical volumes are all specified in my /etc/fstab : as you can see, this warning can quickly get *very* annoying, as it pops up for every single collection I have.

The following gconf settings don't have any effect :
- /apps/gnome_settings_daemon/plugins/housekeeping/active => setting to 0 doesn't prevent the dialog to appear
- /apps/gnome_settings_daemon/plugins/housekeeping/free_size_gb_no_notify => the granularity is too large (it is an integer, not a float)
- /apps/gnome_settings_daemon/plugins/housekeeping/ignore_paths => correctly filled, but no effect : in my case, this setting would be the most useful, since I still want to be informed for "normal" file systems.

Dominique Lasserre (lasall) wrote :

Try the following workaround to disable all disk-notifications:

Disable autostart of gdu-notification-daemon provided by /etc/xdg/autostart/gdu-notification-daemon.desktop .

Information from German Ubuntu forum http://forum.ubuntuusers.de/post/3769367/ .

kk_hephot (ksk) wrote :

@Dominique
I already tried disabling gdu-notification-daemon by renaming it, but the popups keep on coming; so, for me at least, the problem remains. By the way, in case anyone is wondering, don't try the same for gnome-settings-daemon. It stops the popups OK, but it also stops everything else too!

zzarko (zzarko-gmail) wrote :

I also tried both fixes from german forum, but to no avail.

Resager (resager) wrote :

I also tried both fixes from german forum, but to no avail too!!! Please, fix bug.

zzarko (zzarko-gmail) wrote :

This bug is STILL present in 12.04 beta 2. And still extremly annoying as in 11.10...

Mazay (mazay0) wrote :

The bug is still alive at April 1, 2012 in 11.10 .

David Clayton (dcstar) wrote :

Install the dconf-tools package and then run the dconf-editor and try changing the relevant settings in the following key:

org.gnome.settings-daemon.plugins.housekeeping

zzarko (zzarko-gmail) wrote :

@dcstar: tried that, didn't help...

zzarko (zzarko-gmail) wrote :

To disable housekeeping plugin:
1. Open a terminal and make yourself a root user:
sudo su
2. Go to /usr/lib/gnome-settings-daemon-3.0:
cd /usr/lib/gnome-settings-daemon-3.0
3. Make a backup dir:
mkdir backup
4. Move two files to backup:
mv housekeeping.gnome-settings-plugin backup/
mv libhousekeeping.so backup/
5. Logout and login again

The most annoying dialog is GONE! (at least, until next gnome-settings update)

zzarko (zzarko-gmail) wrote :

As a bonus, this workaround works in 11.10 also...

Sebastien Bacher (seb128) wrote :

easier workaround which doesn't need to be redone over update:

'gsettings set org.gnome.settings-daemon.plugins.housekeeping active false'

that needs to be done for every user though

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Ubuntux (4chim) wrote :

Just installed Ubuntu 12.04.
The bug is still alive and still extremely annoying. :-(

I really really wonder why something like this can't be fixed.

Sebastien Bacher (seb128) wrote :

@Ubuntux: it can be fixed, and lucky you it's opensource so you can work on it yourself and contribute to get it resolved for others as well if you want

bottom line: the workaround is easy "make space on your disk" and there are higher issues on the todolist but we will try to address the issue there at some point

Changed in gnome-settings-daemon (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Ivan Zakharyaschev (imz) on 2012-08-03
tags: added: 11.10 oneiric
Ken Sharp (kennybobs) on 2012-09-30
tags: added: nuisance
Ubuntux (4chim) wrote :

Just for the records: The bug is still alive and nagging in 12.10.
(And yes... I probably COULD contribute and fix this myself. But I guess that my C++-coding skills aren't sufficient for that.)

zzarko (zzarko-gmail) wrote :

I can confirm that this bug is still present in 12.10 and thar workarounds in #18 and #20 still work. Workaround in #22 isn't a workaround at all for me, bacause,as I said, my partitions are full on purpose and I need them that way. I won't buy new disks just to make annoying messages go away.

carloslp (carloslp) wrote :

Great tip #20 You saved my day :) Thanks!

David Lesieur (davidlesieur) wrote :

Personally I prefer to disable the warning only for specific volumes. An alternative to #20 is:

gsettings set org.gnome.settings-daemon.plugins.housekeeping ignore-paths "['/my/mount/path/to/ignore', '/my/other/mount/path/to/ignore']"

FYI this bug was being caused by using G_N_ELEMENTS on a non-static array in gsd-disk-space.c. It would only load the 1 most recent path that was added to the ignore list.

It looks like it was fixed in https://mail.gnome.org/archives/commits-list/2013-February/msg07341.html

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.6.4-0ubuntu10

---------------
gnome-settings-daemon (3.6.4-0ubuntu10) saucy; urgency=low

  [ Martin Pitt ]
  * Drop 51_lock_screen_on_suspend.patch: Superseded by handling this key in
    gnome-screensaver. With that, g-screensaver mirrors what's being done in
    g-shell, and avoids patching settings-daemon.

  [ Sebastien Bacher ]
  * debian/patches/git_housekeeping_ignore_list.patch:
    - correctly handle ignore list for disk space notifications (lp: #881376)
  * debian/patches/git_glib_get_xdg_dirs.patch:
    - use glib to get xdg dirs (rather than reading the environment)
  * debian/patches/git_sound_not_polling.patch:
    - don't poll on non existant directories
 -- Sebastien Bacher <email address hidden> Mon, 13 May 2013 15:28:42 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
FurqanHanif (furqanhanif20) wrote :

This Bug is Still Present, Low Disk warning Popping again and again....
See the Attachment.....
i am using LM16 Cinnamon.....

xXx (luk9000) on 2014-07-18
no longer affects: gnome-settings-daemon
zzarko (zzarko-gmail) wrote :

I just made a fresh install of 14.04.1 64bit and I can confirm that thuis bug is still present. Clicking on "Ignore" when message pops up does nothing, it just pops up again in a few minutes. Luckuly, solution from #20 still works.

I also confirm that this is still a problem in 14.04.1. Although in my case it started to be a problem recently.

I had two partitions excluded already from popping those messages and they were quiet. But for some reason when I reached low disk space on another partition they also started to bug me with low disk space messages.

The curious thing is that if I check "Don't show any warnings again for this file system" and then press "Ignore" the messages will display endlessly for all the partitions with low disk space. But if I just click "Ignore" for the first partition that display low disk space dialog then I won't get any more such messages (it will end on that one).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers