Two keyboard indicators are visible in Gnome-Shell

Bug #878951 reported by gururise on 2011-10-20
120
This bug affects 82 people
Affects Status Importance Assigned to Milestone
Ubuntu network, Bluetooth, keyboard menus
Fix Released
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

When using Gnome-Shell 3.2 with multiple keyboard layouts, the gnome keyboard layout switcher indicator is visible in the top right of the status bar, while another keyboard layout switcher indicator with a different icon shows up in the bottom panel...

In upstream gnome-settings-daemon's keyboard plugin, a GtkStatusIcon is created using libgnomekbd. GNOME Shell blacklists that StatusIcon, since it is needed in fallback mode but not Shell.

Ubuntu has a patch that replaces the StatusIcon code with an AppIndicator, which has a StatusIcon fallback. The problem is that the StatusIcon made by libappindicator has a different WM_CLASS name. I guess the best solution would be for Ubuntu to make sure that their indicator patches to GNOME components are bypassed entirely outside of Unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-usernameric 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 20 09:19:12 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (19 days ago)

gururise (gururise) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

thank you for your bug report, is that still an issue? do you know what WM_CLASS is the status icon using?

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-indicator-mods:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.3.91-0ubuntu3

---------------
gnome-settings-daemon (3.3.91-0ubuntu3) precise; urgency=low

  * debian/control.in:
    - updated gsettings-desktop-schemas requirement for the lock key
  * debian/patches/61_unity_use_application_indicator.patch:
    - updated indicators ids, combined with the libappindicator new version
      that should give the correct wm_class to the fallback gtkstatusicon
      which should fix some gnome-shell issues (lp: #878951)
    - use set_icon_full() with "Keyboard" as a11y description (lp: #740726)

  [ Marc Deslauriers ]
  * Add a new preference to lock the screen when the system suspends.
    (LP: #938076)
    - 51_lock_screen_on_suspend.patch: use lock-on-suspend gsettings to
      determine if screen should be locked.
    - 51_always_lock_screen_on_suspend.patch: removed.
    - 54_lazily_connect_to_screensaver.patch: refreshed.
    - 60_unity_hide_status_icon.patch: refreshed.
 -- Sebastien Bacher <email address hidden> Fri, 09 Mar 2012 18:25:40 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers