Ubuntu starts with lowest brightness on HP G62[regression]

Bug #873191 reported by Santiago M. Mola on 2011-10-13
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)

Bug Description

Ubuntu Oneiric starts with the lowest brightness value by default (even if AC powered) on HP G62. This is a regressions since Ubuntu Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,compiztoolbox,unitymtgrabhandles,regex,mousepoll,vpswitch,place,resize,snap,gnomecompat,move,session,grid,wall,animation,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: None
Date: Thu Oct 13 09:35:42 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:143a]
 ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series] [1002:68e0] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:143a]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
MachineType: Hewlett-Packard HP G62 Notebook PC
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=fedf2154-36ec-408f-bb55-744752f19c8e ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/29/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.37
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 143A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 60.3F
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.37:bd10/29/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr0594110000252710001020100:rvnHewlett-Packard:rn143A:rvr60.3F:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 0594110000252710001020100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Santiago M. Mola (smola) wrote :
summary: - Ubuntu starts with lowest brightness on HP G2[regression]
+ Ubuntu starts with lowest brightness on HP G62[regression]
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Ihorko (ihorchyhin) wrote :

Please commit fix for this bug as soon as possible. Because I have to login almost in 'blind' mode.
Installation was always with the lowest brightness.
I've managed to install xbacklight for increasing brightness after login. But I'll appreciate if someone writes how to fix it at login screen

LowPOwerPC (alexpey85) wrote :

Hi, I can confirm the bug. Really annoying thing, do I have to post the output on any command?

bugbot (bugbot) on 2011-10-16
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot) on 2011-10-16
tags: added: backlight
Bryce Harrington (bryce) on 2011-10-25
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

The X driver doesn't control brightness. Might be an issue in the userspace daemon. Or some ACPI quirkiness.

affects: xserver-xorg-video-intel (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → New
Bryce Harrington (bryce) wrote :

Possibly dupe of 872932... similar symptoms around the same time frame.

Santiago M. Mola (smola) on 2011-10-26
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Ihorko (ihorchyhin) wrote :

As workaround I currently use kernel option acpi_brightness=vendor. Now startup brightness is equal to 100% :-)
And if display goes dim after inactivity timeout brightness is not restored and stayes 0%. But this problem handles keyboard shortcuts for increasing brightness with xbacklight.

Andrea Amoroso (heiko81) wrote :

I have an HP G62 with video card Ati 5470 and I'm using the open source driver..so I think this bug doesn't affect only xorg-video-intel..and it also runs hot very soon, but this was just inserted in an other bug..it doesn't happen with the proprietary driver, but there are many other bugs using that..it didn't happen with the proprietary driver in Ubuntu 11.04 and there weren't critical bugs using that..

I always have this issue while booting without AC. Tried the kernel boot option workaround but that didn't help. Have Intel gfx.

I get a complete blank screen with HP G62 on boot. Even if fiddle to get a visible screen it is restricted to 1024 x 768 so there is definitely something wrong driver installation wise. My hardware reports intel

             description: VGA compatible controller
             product: Core Processor Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 02
             width: 64 bits
             clock: 33MHz
             capabilities: vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:42 memory:b0000000-b03fffff memory:a0000000-afffffff ioport:3050(size=8)

Is there Ati hardware here too? Lot's of references. Is the system getting confused between drivers?

vellamike (vellamike) wrote :

This issue a serious issue which is still affecting users as of 20/08/12 on Ubuntu 12.04.

Bug is still present in 12.10 Beta 1. I have managed an ACPI work around but it is not satisfactory because it leads to overheating and a battery that lasts about 15 minutes! There must be thousands of these HP intel driver laptops affected.

markba (mark-baaijens) wrote :

By sheer coincidence (what are the odds?), I happen to have 2 optically identical HP G62's, one with a Intel-card and one equipped with ATI. Both suffer from the same brightness problem, very weird indeed. The remark of Ian at #10 might be correct: maybe the drivers are mixed up, in a way neither of the gfx's work.

As I happen to have both machines at the same time (they are from people who asks me to put Ubuntu on it), I can do tests on both machines, which could help in solving this bug. I'm looking forward to any suggestion. I post the exact specs later, when I have them on hand.

Santiago M. Mola (smola) wrote :

Note that the problem is unrelated to ATI. I have access to two G62. One of them has both an integrated Intel graphics card and an ATI Radeon. The other has just the Intel card. Both suffer the same problem since Oneiric (and persisting in Precise).

Model without ATI:
$ lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Model with ATI:
$ lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series] (rev ff)

markba (mark-baaijens) wrote :

My hardware:

Intel: $ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

ATI: $ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]

Strange thing is that the model with ATI reports 2 different cards, and that in a laptop, how curious. The ATI-model differs slightly from the one smola has in #14.

I have both installed with 10.04 and they work just fine. My hope is that there is a solution before 10.04 gets obsolete (2013).

 I came across a suggestion to a brightness issue on a different machine that was fixed by setting GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="acpi_os_name="Microsoft Windows XP"". Apparently fooling the bios into thinking its running Windows frees up more facilities including control of brightness.

To make the adjustment to Grub, go to a terminal, sudo gedit etc/default/grub will put the grub file into gedit, find the line and edit it and save. Then in the terminal sudo update-grub.

Not yet tried it because I need more time in case I lose my screen again! But someone else might want to.

Some more details of my set up below. (Note I currently have acpi off as part of a different more complex fix and hope to be able to get it back on to stop my laptop overheating and running the battery down in 10 minutes!)

ian@ian-HP-G62-Notebook-PC:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.2.0-32-generic root=UUID=9ed9a092-9789-4941-adb9-7bfc021fc975 ro quiet splash text acpi_osi=linux acpi=off vt.handoff=7
ian@ian-HP-G62-Notebook-PC:~$ ls /sys/class/backlight/*/
actual_brightness brightness max_brightness subsystem uevent
bl_power device power type
ian@ian-HP-G62-Notebook-PC:~$ sudo lspci -vnn | grep -A10 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device [103c:1439]
 Flags: bus master, fast devsel, latency 0, IRQ 19
 Memory at b0000000 (64-bit, non-prefetchable) [size=4M]
 Memory at a0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 3050 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
 Capabilities: [d0] Power Management version 2
 Capabilities: [a4] PCI Advanced Features
 Kernel driver in use: i915

adutzu89 (verbanady) wrote :

This bugg I've enctountered since 12.04 until 13.10 they're workarounds but would be nice to be solved since it is there for a long long time.
I have encountered it on a HP 635 widh AMD 6310 integrated graphic card.

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6310]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers