gnome-settings-daemon crashed with SIGSEGV in engine_coldplug()

Bug #868928 reported by Eyad Salah on 2011-10-06
124
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Critical
gnome-settings-daemon (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

On Startup

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-settings-daemon 3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Wed Oct 5 17:32:19 2011
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 SHELL=/bin/false
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f0686fca3d8 <gsd_power_manager_start+1656>: mov 0x8(%rax),%rcx
 PC (0x7f0686fca3d8) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 gsd_power_manager_start () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 gnome_settings_plugin_info_activate ()
 _start ()
Title: gnome-settings-daemon crashed with SIGSEGV in gsd_power_manager_start()
UpgradeStatus: Upgraded to oneiric on 2011-09-27 (8 days ago)
UserGroups:

Eyad Salah (eyad-salah) wrote :
visibility: private → public

StacktraceTop:
 engine_coldplug (manager=0x111a080) at gsd-power-manager.c:1100
 gsd_power_manager_start (manager=0x111a080, error=0x7fff4eaa6a48) at gsd-power-manager.c:3446
 impl_activate (plugin=0x1123a10) at gsd-power-plugin.c:78
 _activate_plugin (info=0x1124820) at gnome-settings-plugin-info.c:408
 gnome_settings_plugin_info_activate (info=0x1124820) at gnome-settings-plugin-info.c:431

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
summary: - gnome-settings-daemon crashed with SIGSEGV in gsd_power_manager_start()
+ gnome-settings-daemon crashed with SIGSEGV in engine_coldplug()
Changed in gnome-settings-daemon (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
tags: added: bugpattern-needed
Michael Terry (mterry) wrote :

I can't figure out how this could happen in the current code path. But for defensive programming purposes, there should be an extra NULL check to prevent this crash. I'll work on a patch.

Michael Terry (mterry) on 2012-04-25
Changed in gnome-settings-daemon (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.1-0ubuntu2

---------------
gnome-settings-daemon (3.4.1-0ubuntu2) quantal; urgency=low

  * debian/patches/power-check-null-devices.patch:
    - NULL-guard the return value of up_client_get_devices.
      LP: #868928
  * debian/patches/power-ignore-bad-dbus-requests.patch:
    - If we get a DBus request while the manager isn't active, ignore it.
      LP: #969535
 -- Michael Terry <email address hidden> Tue, 01 May 2012 09:12:02 -0700

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Michael Terry (mterry) wrote :

Just uploaded a fix to quantal and precise-proposed.

Hello ComputerJy, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Lucas Magasweran (lucasrangit) wrote :

I enabled -proposed and did a `sudo apt-get update && sudo apt-get install gnome-settings-daemon` to just get that package from proposed. I rebooted and now the crash report is not coming up and my GTK apps (Chrome) show the correct theme. Thanks Martin.

Martin Pitt (pitti) on 2012-05-06
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.1-0ubuntu1.1

---------------
gnome-settings-daemon (3.4.1-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/power-check-null-devices.patch:
    - NULL-guard the return value of up_client_get_devices.
      LP: #868928
  * debian/patches/power-ignore-bad-dbus-requests.patch:
    - If we get a DBus request while the manager isn't active, ignore it.
      LP: #969535
 -- Michael Terry <email address hidden> Tue, 01 May 2012 09:30:20 -0700

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon:
status: New → Incomplete
Changed in gnome-settings-daemon:
status: Incomplete → Expired
tags: added: apport-request-retrace
Changed in gnome-settings-daemon:
status: Expired → New
Changed in gnome-settings-daemon:
status: New → Fix Released

This error can be consistently reproduced on Ubuntu >=12.04 (at least) by typing this command --> /etc/init.d/networking restart

I believe that the crash requires isc-dhcp-server to be installed. Also, the /etc/network/interfaces file had been changed in all cases with multiple interfaces present on the hardware.
I would be willing to pin down the exact steps required to produce this error if it is needed (shoot me an email). Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.