Display unreadable after dimming

Bug #850749 reported by Han Pilmeyer on 2011-09-15
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Abhishek kumar singh

Bug Description

Once my laptop screen is dimmed I can not read it any more. Dimming happens even when "dim" is not selected in the "screen" settings. It also happens before logging in. There is nothing I can do to un-dim the screen (i.e. moving the mouse, keyboard, but also using the contrast/brightness keys). When the screen is not dimmed, it is possible to adjust brightness etc using the contrast/brightness keys.

If the laptop is suspended/resumed the screen will be back to normal until it decides to dim the screen again.

This is reproducible and can be repeated as many times as necessary.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,dbus,compiztoolbox,snap,ring,imgpng,resize,move,screenshot,regex,place,resizeinfo,put,annotate,grid,vpswitch,mousepoll,commands,session,animation,thumbnail,fade,cube,rotate,expo,unityshell]
CompositorRunning: compiz
Date: Thu Sep 15 11:00:12 2011
DistUpgraded: Log time: 2011-08-22 16:01:49.906813
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company NC6220 [103c:308a]
   Subsystem: Hewlett-Packard Company Device [103c:308a]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110131)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 002: ID 03f0:011d Hewlett-Packard Integrated Bluetooth Module
MachineType: Hewlett-Packard HP Compaq nc6220 (EA766UC#ABB)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LC_TIME=en_ZA.utf8
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_ZA.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-11-generic root=UUID=3cd4d9b5-f50a-41d2-8099-63d1181c43d8 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.usernamedoff=7
SourcePackage: xorg
Symptom: display
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: Upgraded to oneiric on 2011-09-15 (0 days ago)
dmi.bios.date: 02/27/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DTU Ver. F.13
dmi.board.name: 308A
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 40.22
dmi.chassis.asset.tag: CNU6082483
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DTUVer.F.13:bd02/27/2007:svnHewlett-Packard:pnHPCompaqnc6220(EA766UC#ABB):pvrF.13:rvnHewlett-Packard:rn308A:rvrKBCVersion40.22:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq nc6220 (EA766UC#ABB)
dmi.product.version: F.13
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Han Pilmeyer (pilux) wrote :
bugbot (bugbot) on 2011-09-15
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
bbruecker (bb-benjaminbruecker) wrote :

Same Problem on Dell Latitude D430.

In my case its just a bit different. I also selected not to dim, but after some time the computer dims. I can activate the screen by pressing the shift key, but the screen is dimmed to the darkest possible setting. When I press the brightness key once, the screen is getting a bit brighter, but if I press it again, it turns a bit darker agian (not as dark as it was bofore).

Bryce Harrington (bryce) on 2011-10-25
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

The X driver doesn't control brightness. Might be an issue in the userspace daemon. Or some ACPI quirkiness.

affects: xserver-xorg-video-intel (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → New
Han Pilmeyer (pilux) wrote :

There is definitely something strange going on in the settings daemon (also). When I select the "screen" settings and slide the "brightness" control, I would expect the screen to get darker or brighter depending on the direction in which I move the slider. This is not happening. When I move it to the left it sometimes gets brighter then darker and brighter again. Very strange. The brightness keys, when they work which is not always the case, have a similar effect. Dimming may actually make the screen brighter.

I still observe the original problem. When the screen dims, it stays dark. Hibernate/resume will bring it back. It's easy enough to reproduce. Let me know if I can help to debug this.

Changed in gnome-settings-daemon (Ubuntu):
status: New → In Progress
assignee: nobody → Abhishek kumar singh (abhishekkumarsingh-cse)
Andre (ajx) wrote :

This bug affects Intel 915GM (i915) too (IBM Thinkpad X41). I have turned off 'dim'. My screen is switched off after 10 minutes. In many cases it does not turn on again completely. I can only see a very dark picture of whatever should be on the screen. I can even jump between ttys and back to the desktop with no effect. Hotkeys for brightness don't allow to increase brightness then. The only thing that helps is going to standby (closing the lid, because I can't really see where I'm clicking) and waking up, or killing the session (Alt + Print + K).

Emmanuel Simon (manu-simon) wrote :

Same problem as already describe on HP NC6120
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers