Wallpapers are not updated on upgrade to Natty

Bug #746028 reported by Jonathan Carter on 2011-03-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
edubuntu-artwork (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
High
Canonical Foundations Team
Natty
High
Canonical Foundations Team
Oneiric
High
Unassigned
ubuntu-wallpapers (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

When upgrading from Maverick to Natty Beta 2, the Edubuntu/Ubuntu wallpaper and GDM login screen is still the old wallpaper.

New users on the system get the new wallpaper.

Fixing this would require UI and FF exceptions, and it's possible that it won't be fixed by release. If so, it would probably be a good idea to release note it.

tags: added: iso-testing
Jonathan Carter (jonathan) wrote :

16:29 < highvoltage> seb128: I'm dead-sure, since I've done it about 16 times on brand new Edubuntu installations during beta1 and beta2 testing
16:30 < highvoltage> seb128: and it affects gdm's wallpaper as well, which isn't ideal imho. a user might suspect that the upgrade process didn't complete
16:31 < seb128> highvoltage, trying pinging didrocks when he's online tomorrow he's the one who wrote the background caching code

Didier, I'm going to take the liberty to subscribe you to this bug, I hope that's ok :)

summary: - Edubuntu Wallpapers are not updated on upgrade to Natty
+ Wallpapers are not updated on upgrade to Natty
Changed in edubuntu-artwork (Ubuntu):
assignee: Jonathan Carter (jonathan) → nobody
description: updated
description: updated
affects: edubuntu-artwork (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Wishlist → Undecided
status: Confirmed → Triaged
Stéphane Graber (stgraber) wrote :

Worth noting that for Ubuntu the change of background is so minimal that pretty much nobody will notice.

For Edubuntu it's a completely different deal as our wallpapers for Maverick and Natty are completely different.
This mean that a user upgrading from maverick might think the upgrade didn't succeed or will be surprised to get a completely different wallpaper the next time they create a new user.

Didier Roche (didrocks) wrote :

I explicitly tested this for karmic -> lucid -> maverick and it was working.

I tried again:
- my wallpaper for gdm is /usr/share/backgrounds/warty-final-ubuntu.png
- my own wallpaper is /usr/share/backgrounds/Aubergine_Sea_by_Wyatt_Kirby.jpg

Try open gimp, and change both:
- in my session, I immediately see the wallpaper changing while saving
- when selecting "switch user" which sent me back to gdm, I see my modified warty-final-ubuntu.png image.

So if the timestamps are correct (meaning, the new one > the old one), the cache will be refreshed. Are you doing any special tweaks in edubuntu?

Didier Roche (didrocks) wrote :

correction, it's rather: (if new one != old one) (we don't make a strict distinction in the code)

Jonathan Carter (jonathan) wrote :

Didier, did you happen to explicitly test it for maverick -> natty upgrade? That's the only case where this bug occurs.

Didier Roche (didrocks) wrote :

@Jonathan Carter: I didn't test on edubuntu, I tested on ubuntu yesterday on my spare machine and I can tell you the wallpaper is upgraded (despite the minor difference visually on the wallpaper, I compared the timestamp to see it was refreshed).

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Colin Watson (cjwatson) on 2011-04-15
Changed in gnome-settings-daemon (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)

Just went and did a check on my updated Ubuntu system ( all defaults) and
usr/share/backgrounds/warty-final-ubuntu.png has a date stamp of 2011-03-23 17:34, so its picking up the Natty version ( subtle change though it is).

I think this is just an Edubuntu issue, and have removed the Ubuntu team from the assignment.

Changed in gnome-settings-daemon (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
summary: - Wallpapers are not updated on upgrade to Natty
+ Edubuntu: Wallpapers are not updated on upgrade to Natty
Stéphane Graber (stgraber) wrote :

I don't think Edubuntu ships anything that could cause that.
I'm currently doing the following test to prove it:
 1) Install Ubuntu 10.10 from netboot (so it's perfectly up to date by default)
 2) Make a screenshot of gdm and default user session
 3) Upgrade to Natty with update-manager
 4) Make a screenshot of gdm and default user session

If the bug also affects Ubuntu, all screenshots should be identical. Otherwise, I'll get two maverick wallpaper and two natty wallpaper.

Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :

Ok, so attached are 5 screenshots:
 - maverick-desktop.png: Screenshot of the desktop on an up to date Maverick
 - maverick-gdm.png: Screenshot of gdm on an up to date Maverick
 - natty-desktop.png: Screenshot of the desktop on an up to date Natty
 - natty-gdm.png: Screenshot of gdm on an up to date Natty
 - natty-desktop1.png: Screenshot of the desktop of a new user on an up to date Natty

You'll notice that they are all identical wallpapers except for natty-desktop1.png which is a new user and so didn't have any cache date from Maverick.

I think it's pretty clear that the issue isn't Edubuntu specific. It's just a LOT more visible on Edubuntu where our two wallpapers are radically different.

Jonathan Carter (jonathan) wrote :

@Didier See above. If you can't reproduce that then I want to see screenshots! :)

Didier Roche (didrocks) wrote :

Right now on my machine, with the default wallpaper:
timestamp of the cache:
$ ls -l ~/.cache/wallpaper/zoom_1920_1080__usr_share_backgrounds_warty-final-ubuntu.png
-rw-r--r-- 1 didrocks didrocks 392625 2011-04-19 09:23 /home/didrocks/.cache/wallpaper/zoom_1920_1080__usr_share_backgrounds_warty-final-ubuntu.png

timestamp of the source image (0.31.9)
$ ls -l /usr/share/backgrounds/warty-final-ubuntu.png
-rw-r--r-- 1 root root 231208 2011-03-23 23:34 /usr/share/backgrounds/warty-final-ubuntu.png

So, I created ubuntu-wallpapers 0.31.9ppa1 with a totally new wallpaper (still warty-final-ubuntu, expressing all my artistic creation writing "BRAND NEW!" on it ;)
You can find it in my ppa: https://launchpad.net/~didrocks/+archive/ppa
When I install it, I see the wallpaper changing, showing a nice "Brand New!". That's also confirmed by the timestamps:

$ ls -l ~/.cache/wallpaper/zoom_1920_1080__usr_share_backgrounds_warty-final-ubuntu.png
-rw-r--r-- 1 didrocks didrocks 670582 2011-04-19 09:30 /home/didrocks/.cache/wallpaper/zoom_1920_1080__usr_share_backgrounds_warty-final-ubuntu.png

$ ls -l /usr/share/backgrounds/warty-final-ubuntu.png
-rw-r--r-- 1 root root 713318 2011-04-19 09:28 /usr/share/backgrounds/warty-final-ubuntu.png

Any hint? This should reproduce the upgrade case (we are using nautilus in the gnome session, but it's calling the same library, and if, after this, I try to start gdm (using g-s-d), I see the new wallpaper as well. Can you try with the wallpaper asset in my ppa (I only changed warty-final-ubuntu.png)

For Jonathan, here is the screenshot :)

PS: the exact same code is now in GNOME3 (I ported it, but no change at all in the logic) and there is no bug opened against it.

Jonathan Carter (jonathan) wrote :

How bizarre. In both Stéphane and my case, we installed a brand new maverick machine, installed all the updates, and then used update manager again to upgrade to the latest development release. And it's reproducible every singe time on Ubuntu and Edubuntu. I'll look a bit deeper today to see what actually happens in our systems. I really thought it would be easier for everyone else to reproduce. Thanks for the screenshot :)

Stéphane Graber (stgraber) wrote :

In my test VM:

root@ubuntu:~# ls -l /usr/share/backgrounds/warty-final-ubuntu.png
-rw-r--r-- 1 root root 231208 2011-03-23 18:34 /usr/share/backgrounds/warty-final-ubuntu.png
root@ubuntu:~# ls -l /home/stgraber/.cache/wallpaper/zoom_1024_768__usr_share_backgrounds_warty-final-ubuntu.png
-rw-r--r-- 1 stgraber stgraber 327146 2011-04-18 18:10 /home/stgraber/.cache/wallpaper/zoom_1024_768__usr_share_backgrounds_warty-final-ubuntu.png
root@ubuntu:~# ls -l /home/stgraber1/.cache/wallpaper/zoom_1024_768__usr_share_backgrounds_warty-final-ubuntu.png
-rw-r--r-- 1 stgraber1 stgraber1 194801 2011-04-18 19:21 /home/stgraber1/.cache/wallpaper/zoom_1024_768__usr_share_backgrounds_warty-final-ubuntu.png

Kate Stewart (kate.stewart) wrote :

The case I was doing was fresh maverick, apply all updates, then fresh natty.

Stéphane Graber (stgraber) wrote :

Installing Didier's new wallpaper, I get it on all of gdm, current user and new user.

So the issue happens when you install a new Maverick machine after the new ubuntu-wallpaper has been uploaded in Natty.
In this case, the cache is newer than the new wallpaper and so won't be rebuilt, leaving the user with the old wallpaper.

Stéphane Graber (stgraber) wrote :

Adding a "touch" in .postinst would set the timestamp to the current date and time which should trigger a rebuild of the cache.
The only issues with that is that:
 1) We are (kind of) modifying a file post-install (although the checksum will remain the same so won't really be considered as a change)
 2) We'd need to patch every wallpapers package to include that fix

Stéphane Graber (stgraber) wrote :

Another way of improving this in the future would be to set the mtime of the cache to be the same as the file it's caching.
That won't help with update for anyone who installed their system before that fix enters the distro though, so I still think the easiest and most effective way of fixing it for now, is to add a "touch" in the postinst of all wallpaper packages.

Stéphane Graber (stgraber) wrote :

Updated title to no longer be Edubuntu specific.

For Edubuntu I just uploaded a new edubuntu-artwork including the "touch" hack I mentioned before. That should workaround the issue.

I'd suggest doing the same in ubuntu-wallpapers unless we know for sure we'll have another (cleaner ?) way of updating the cache on upgrade.

summary: - Edubuntu: Wallpapers are not updated on upgrade to Natty
+ Wallpapers are not updated on upgrade to Natty
Changed in gnome-settings-daemon (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Didier Roche (didrocks) wrote :

@Stéphane: this only affect people installing maverick after 2011-03-23, and considering that it's only for the default wallpaper, which didn't change a lot for natty, I think it's safe to discare this case (the wallpaper will be updated if they changed the wallpaper).

Didier Roche (didrocks) wrote :

(talking for /usr/share/backgrounds/warty-final-ubuntu.png)

Stéphane Graber (stgraber) wrote :

Yeah, my biggest issue was for Edubuntu where we switch between two completely different wallpapers and will likely have user use the difference of wallpaper to know if a system is Maverick or Natty. The Edubuntu part of this bug has been "fixed" by my upload yesterday.

A similar fix could be applied to ubuntu-wallpaper if we're fine with adding a touch in the .postinst to update the timestamp but I agree it's not critical as both wallpapers are almost identical.

Stéphane Graber (stgraber) wrote :

After discussion with Kate in -release, I'll do a quick test to make sure Edubuntu works fine after yesterday's workaround and if it does, will apply the same "fix" to ubuntu-wallpapers.

It's just a workaround and ideally the caching system should be updated to fix that issue in the future (include original filesize in the cache filename ?).

Changed in ubuntu-wallpapers (Ubuntu Natty):
status: New → Fix Released
Changed in edubuntu-artwork (Ubuntu Natty):
status: New → Fix Released
Changed in gnome-settings-daemon (Ubuntu Natty):
status: Triaged → Won't Fix
Changed in ubuntu-wallpapers (Ubuntu Oneiric):
status: New → Invalid
Changed in edubuntu-artwork (Ubuntu Oneiric):
status: New → Invalid
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Ian Santopietro (isantop) wrote :

Sorry about that guys. I have too many bug reports open. :(

Changed in bluez-utils (Ubuntu Natty):
status: New → Invalid
Changed in bluez-utils (Ubuntu Oneiric):
status: New → Invalid
Ian Santopietro (isantop) wrote :

(Wrong Bug Report)

Changed in gnome-settings-daemon (Ubuntu Oneiric):
milestone: none → oneiric-alpha-2
Didier Roche (didrocks) wrote :

This is fixed by new ilbgnome upstream

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers