GNOME bars theme lost

Bug #735393 reported by Paolo Sammicheli on 2011-03-15
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unknown

Performing Unity 3D testcase:

http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Unity%203D%20session
After opening a terminal and adding it to the panel with right click and "keep on panel" the top bar changed theme reversing to the GNOME Default.
See the attached screenshoot.
Natty Alpha3 20100314

UPDATE:
The bug was reproduced in the Classic Desktop, so it's not strictly related to Unity iteself. The second time I had it I was opening glxgears from a shell. See comment #10

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.29 Wed Feb 23 16:16:53 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-6ubuntu1)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Mar 15 11:56:55 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
GraphicsCard:
 nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
MachineType: System manufacturer P5K-E
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=761ec3bd-f463-4926-b4ad-0d4422201ecc ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
ProcVersionSignature__: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/25/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5
---
Architecture: i386
DistroRelease: Ubuntu 11.04
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
NonfreeKernelModules: nvidia
Package: gnome-settings-daemon 2.32.1-0ubuntu9
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Tags: natty running-unity
Uname: Linux 2.6.38-6-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Paolo Sammicheli (xdatap1) wrote :
summary: - Unity: theme on the upper bar lost
+ Unity: theme on the top bar lost
summary: - Unity: theme on the top bar lost
+ Unity: top bar theme lost

thanks for the bug report but the issue you are facing is not caused by unity itself. its a crash in gnome-settings-daemon please report a bug with the .crash file in you /var/crash directory with the name gnome-settings-daemon in it.

Changed in unity (Ubuntu):
status: New → Invalid
Paolo Sammicheli (xdatap1) wrote :

Hi Omer,
in the /var/crash there isn't a gnome-settting-daemon file. Is it one of the following?
$ ls /var/crash/
_usr_lib_evolution_e-calendar-factory.1000.crash
_usr_lib_unity_autopilot.py.1000.crash
_usr_lib_unity-place-applications_unity-applications-daemon.1000.crash

BTW, I admit that the package would be wrong, but why you don't change package instead to asking me to open a new bug?

Changed in unity (Ubuntu):
status: Invalid → New
Paolo Sammicheli (xdatap1) wrote :

changing package according Omer Akram suggestion

affects: unity (Ubuntu) → gnome-settings-daemon (Ubuntu)
tags: added: apport-collected
description: updated

apport information

Download full text (8.9 KiB)

changing to gnome-settings-daemon is of no need since we dont have any crash
data

On Tue, Mar 15, 2011 at 11:50 PM, Paolo Sammicheli <email address hidden>wrote:

> changing package according Omer Akram suggestion
>
> ** Package changed: unity (Ubuntu) => gnome-settings-daemon (Ubuntu)
>
> ** Tags added: apport-collected
>
> ** Description changed:
>
> Binary package hint: unity
>
> Performing Unity 3D testcase:
>
>
> http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Unity%203D%20session
>
> After opening a terminal and adding it to the panel with right click and
> "keep on panel" the top bar changed theme reversing to the GNOME
> Default.
>
> See the attached screenshoot.
>
> Natty Alpha3 20100314
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.4-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> Uname: Linux 2.6.38-6-generic i686
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory:
> '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86 Kernel Module 270.29 Wed Feb 23 16:16:53
> PST 2011
> GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-6ubuntu1)
> Architecture: i386
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Tue Mar 15 11:56:55 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
> GraphicsCard:
> nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if
> 00 [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
> InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
> InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
> JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver
> (Proprietary, Enabled, In use)
> MachineType: System manufacturer P5K-E
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic
> root=UUID=761ec3bd-f463-4926-b4ad-0d4422201ecc ro quiet splash vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> ProcVersionSignature__: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
> Renderer: Unknown
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 05/25/2007
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0307
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: P5K-E
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvn...

Read more...

Hey Paolo ;)

Is there a way you can reproduce the issue? For example, try to remove things from the launcher, and then try to re-add them.

I'm also interested in the other crash reports you listed in comment #3. Just report as individual bugs with apport-bug /var/crash/<crash file path>

Thanks

Paolo Sammicheli (xdatap1) wrote :

Hello David! Nice to hear you :)

about the 3 crashes above:

 * "_usr_lib_evolution_e-calendar-factory.1000.crash" I reported it in the bug #735419
 * "_usr_lib_unity_autopilot.py.1000.crash" reported in the bug #735410

The third one "_usr_lib_unity-place-applications_unity-applications-daemon.1000.crash" I haven't got the apport dialog so I didn't reported it. I'm reporting it right now and I will subscribe you to the new bug.

Meanwhile I will also try to make this bug happen again :)

Talk to you later, bye!

Paolo Sammicheli (xdatap1) wrote :

Hello David,

I tryied to report the unity-applications-daemon crash but I got:

"The problem cannot be reported: The program crashed on an assertion failure, but the message could not be retrieved. Apport does not support reporting these crashes."

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Paolo Sammicheli (xdatap1) wrote :

Just reproduced in a fresh installation with the 20110321 image this time with Natty Classic Desktop. It's not a gnome-settings-daemon crash because it's running:

$ ps -ef | grep setting
x 1868 1 0 11:08 ? 00:00:00 /usr/lib/gnome-settings-daemon/gnome-settings-daemon

Attaching a new screenshot.

summary: - Unity: top bar theme lost
+ Top bar theme lost
description: updated
summary: - Top bar theme lost
+ GNOME bars theme lost
Rocko (rockorequin) wrote :

I get this in unity in a fresh installation of natty under VirtualBox. Ambiance loads and stays working for about five seconds, and then the theme half-resets to what looks like Clearlooks. The title bars remain as Ambiance. If I run the appearance manager, it thinks I have a custom theme setting; if I change it to Ambiance, it makes no difference, and when I next run the appearance manager it thinks again that I have a custom theme set.

The only extra applications I installed were virtualbox-ose-guest-x11, -utils, -dkms, and the dkms package (which are required for 3d support to get unity working).

Rocko (rockorequin) on 2011-05-03
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Glauco (glauco-hass) wrote :

Yesterday I restored some of my old folders from Maverick (10.10) and ~/.compiz was one of them. Today, the topbar was exactly the same as OP. Removing it fixes the issue.
Here's the clue from dmesg wich make me to believe that compiz was guilty:

[ 607.195639] compiz[1404]: segfault at 11 ip 0087c33d sp bff24564 error 4 in libpthread-2.13.so[874000+15000]
[ 783.094914] compiz[2361]: segfault at 13 ip 0057033d sp bf8bcd64 error 4 in libpthread-2.13.so[568000+15000]
[ 799.357040] polkit-gnome-au[1428]: segfault at 24 ip 002ffeb7 sp bf893870 error 4 in libglib-2.0.so.0.2800.6[2dc000+d5000]

Dario Bertini (berdario) wrote :

I tested in a virtualbox installation, and it also happens with the classic environment without any desktop effects (thus, it's not compiz fault)

moreover: I've seen this problem first hand on 3 other installations of people around here, so I'm quite surprised that this bug has only 12 people affected (and thus such a low heat)

fwiw: here're the last 2 lines from my dmesg (after multiple tests both with the compiz environment and the metacity one... thus after every logout/login I got something like 4 different "crashes" of the theme, and these lines are only talking about 2 single crashes, so these're almost certainly unrelated):

[ 1455.905648] atkbd serio0: Spurious NAK on isa0060/serio0. Some program might be trying access hardware directly.
[ 1740.363830] compiz[1883] general protection ip:7f910127e394 sp:7fff7e678740 error:0 in libpthread-2.13.so[7f9101275000+18000]

Dario Bertini (berdario) wrote :

forgot to mention:

nothing whatsoever in /var/crash and deleting ~/.compiz hasn't accomplished anything

Robin Stocker (nibor) wrote :

Maybe it's the same problem as in bug 649809. Try the workaround in the following comment:

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/649809/comments/68

Thiago Arrais (thiago-arrais) wrote :

Just for the record: the workaround Robin mentioned didn't work for me.

I'm on Virtualbox and my setup behaves just like Rocko's description. The starting theme looks like Ambiance and after some seconds the screen looks pretty much like Paolo's screenshot.

David Barth (dbarth) wrote :

I think the original bug is definitely a gnome-settings-daemon crash.

The second crash related to unity-place-applications is a different issue. If it's still reproducible it should be tracked as a separate bug.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
To post a comment you must log in.