maverick gnome-settings-daemon doesn't start

Bug #652929 reported by Cameron Braid on 2010-10-01
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

I have just installed a clean install of maverick rc

When I login to gnome, the panel isn't styled, and applications like terminal show with a white background colour.

I looked in ~/.xsession-errors to see this :

** (gnome-settings-daemon:1684): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1684): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

So I tried running it :

sudo gnome-settings-daemon --no-daemon

then the terminal changed to purple background, and the panel got its theme

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-settings-daemon 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Oct 1 21:33:36 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928.1)
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon

Cameron Braid (cameron-braid) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report but the log indicators there is already a settings manager running so that's not a bug

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Cameron Braid (cameron-braid) wrote :

I'm sorry - but you can't just disregard everything that I stated just because think the log indicates something different.

There is definately a bug here... otherwise I wouldn't have bothered to come to launchpad. I just spent a few hours reinstalling maverick from scratch to verify that this issue happens with the latest ISO image, since I had the same issue with the beta release

Please re-read what i said, as it explains the issue I am experiencing.

It could quite possibly not be a bug in gnome-settings-daemon - however i don't know where to start looking - please ask for more information instead if dismissing this issue.

moojix (moojix) wrote :

After uprading a box from Lenny to Maverick I had exactly the same symptoms as Cameron describes: panel isn't styled, theme isn't applied to all windows etc. (grey and ugly gnome UI).

in ~/.xsession_errors I had the same warning as Cameron:
** (gnome-settings-daemon:2028): WARNING **: You can only run one xsettings manager at a time; exiting

The interesting part is, that after 7 reboots, suddenly the error in .xsession_errors was gone.
That sounds, that we have here a timing issue not a configuration issue.

Nevertheless, I reinstalled:
aptitude reinstall gnome-control-center

rebooted 3 times to verify.
The mentioned error is gone and the panel and windows appear as expected.

Cameron Braid (cameron-braid) wrote :

I've just re-installed from the maverick-alternate-amd64.iso and am experiencing the same issue

jaywhy (jaywhy) wrote :

Same problem here on 10.10, after login I get the ugly gray top panel and gray menu bars in applications. Window decorations are correctly applied. Checking my .xsession-errors file I'm getting the following error.

** (gnome-settings-daemon:1682): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1682): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

My stupid fix is to kill gnome-settings-daemon and restart it.

jaywhy@jason-ubuntu:~$ ps auxww | grep gnome-settings-daemon
jaywhy 1682 0.0 0.1 384296 11904 ? Ssl 09:35 0:00 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
jaywhy 11933 0.0 0.0 11336 876 pts/2 S+ 09:43 0:00 grep --color=auto gnome-settings-daemon
jaywhy@jason-ubuntu:~$ killall -9 gnome-settings-daemon
jaywhy@jason-ubuntu:~$ gnome-settings-daemon

This works and subsequent logoffs and logins don't recreate the problem, but once I restart the problem returns.

jaywhy@jason-ubuntu:~$ uname -a
Linux jason-ubuntu 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

I'm running on amd64 as others in this thread are, is that a pattern or coincidence?

jaywhy (jaywhy) wrote :

moojix has the fix.

sudo aptitude reinstall gnome-control-center

I've restarted after reinstalling gnome-control-center, and the bug has not returned.

I believe it is likely something I installed after that created this bug, because on my first boot into 10.10 the bug didn't show. Only after I ran 'apt-get upgrade'(I didn't let the installer do this), installed a bunch a software including possible culprits like compiz or emerald, added medibuntu and uncommented partner repositories, etc, etc, did the problem show.

Others have said after reinstalling or installing they're experiencing this bug, yet this was not my experience. The question I have is, did you guys let the installer update from the internet? If so and you experienced the problem after booting up the first time into 10.10, then it is likely the bug lays in the recent updates as I only experienced the bug after installing them.

jaywhy (jaywhy) wrote :

I booted up my PC this morning and the issue returned. :(

So I was a little on the "fixed" statement.

Cuihtlauac (cuihtlauac) wrote :

Adding

ps -ef | grep gnome-settings-daemon > $HOME/DEBUG

just before

exec $STARTUP

in /etc/X11/Xsession.d/99x11-common_start

shows that the gnome-settings-daemon spawn by the greeter is not yet dead when gnome-session is launched. I suppose it should already be dead.

~>cat DEBUG
gdm 15611 1 2 16:56 ? 00:00:00 /usr/lib/gnome-settings-daemon/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins

Cuihtlauac (cuihtlauac) wrote :

Replacing the ps pipe by sleep 2 (sort-of) fixes the problem on my machine.

Lukas Z. (lukas-zaruba) wrote :
Download full text (3.4 KiB)

Hi,
I am experiencing same behavior on newly installed Ubuntu 10.10 AMD 64. First time I have noticed this was after installation of NVidia drivers, but actually it was the first time I have restarted the computer. Problem was appearing ever sync irregularly.
Adding sleep 2 into the /etc/X11/Xsession.d/99x11-common_start script seems to fix the problem so I suspect it to be some nasty race condition (thanks Cuihtlauac).

Best
Lukas Zaruba

I am attaching beginnings of .xsession-error logs...

This is the log from the session which run correctly:
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=cs_CZ.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
GNOME_KEYRING_CONTROL=/tmp/keyring-lGXhzY
GNOME_KEYRING_CONTROL=/tmp/keyring-lGXhzY
GNOME_KEYRING_CONTROL=/tmp/keyring-lGXhzY
SSH_AUTH_SOCK=/tmp/keyring-lGXhzY/ssh
** Message: adding killswitch idx 0 state KILLSWITCH_STATE_UNBLOCKED
** Message: adding killswitch idx 2 state KILLSWITCH_STATE_UNBLOCKED
** Message: killswitch 0 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitch 2 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitches state KILLSWITCH_STATE_UNBLOCKED
** (bluetooth-applet:2028): DEBUG: Unhandled UUID 0000111b-0000-1000-8000-00805f9b34fb (0x111b)
** (bluetooth-applet:2028): DEBUG: Unhandled UUID 00005005-0000-1000-8000-0002ee000001 (0x5005)
** (bluetooth-applet:2028): DEBUG: Unhandled UUID 00005557-0000-1000-8000-0002ee000001 (0x5557)
** (bluetooth-applet:2028): DEBUG: Unhandled UUID 00005601-0000-1000-8000-0002ee000001 (0x5601)
** Message: killswitch 0 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitch 2 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitches state KILLSWITCH_STATE_UNBLOCKED

(polkit-gnome-authentication-agent-1:2036): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

And this from the session which had the problem
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=cs_CZ.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
GNOME_KEYRING_CONTROL=/tmp/keyring-OsXurr
GNOME_KEYRING_CONTROL=/tmp/keyring-OsXurr
GNOME_KEYRING_CONTROL=/tmp/keyring-OsXurr
SSH_AUTH_SOCK=/tmp/keyring-OsXurr/ssh

** (gnome-settings-daemon:1960): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1960): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.
** Message: adding killswitch idx 0 state KILLSWITCH_STATE_UNBLOCKED
** Message: adding killswitch idx 1 state KILLSWITCH_STATE_UNBLOCKED
** Message: killswitch 0 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitch 1 is KILLSWITCH_STATE_UNBLOCKED
** Message: killswitches state KILLSWITCH_STATE_UNBLOCKED
** (bluetooth-applet:2006): DEBUG: Unhandled UUID 0000111b-0000-1000-8000-00805f9b34fb (0x111b)
** (bluetooth-applet:2006): DEBUG: Unhandled UUID 00005005-0000-1000-8000-0002ee000001 (0x5005)
** (bluetooth-applet:2006): DEBUG: Unhandled UUID 00005557-0000-1000-8000-0002ee000001 (0x5557)
** (bluetooth-applet:2006): DEBUG: Unhandled UUID 00005601-0000-1000-8000-0002ee000001 (0x5601)
** Message:...

Read more...

Nick (nick-peeples) wrote :

Ubuntu 10.10 AMD 64

This did not fix it for me:

sudo aptitude reinstall gnome-control-center

Adding in sleep 2 to the /etc/X11/Xsession.d/99x11-common_start does fix it, but I do not see this as a solution. It's a small annoying pause in my otherwise very fast boot.

I'm willing to help, but as someone above said, I have no idea where to even begin looking.

- Nick

Cuihtlauac (cuihtlauac) wrote :

Adding sleep 2, is definitely *not* a solution, nothing but an ugly and hopefully interim workaround. I'm wondering why the gdm gnome-settings-daemon is not yet dead when the logging user process kicks in. Either it's stalled waiting for something late, or it is just too slow to die. I'm tempted to think it may be second case, my machine is pretty fast (dual 6 core Xeon X5650), in such case it may be upstream bug.

PS1: Shall we consider changing the status of this bug? It seems confirmed.
PS2: BTW, the title is wrong, it does affect production Maverick. I guess we don't care any longer about rc.

Cuihtlauac (cuihtlauac) on 2010-11-19
summary: - maverick rc gnome-settings-dameon doesn't start
+ maverick gnome-settings-dameon doesn't start
summary: - maverick gnome-settings-dameon doesn't start
+ maverick gnome-settings-daemon doesn't start
Solorvox (solorvox) wrote :

This bug also affects me with a clean install.

10.10 amd64 SSD (220mb/s) disk on i7 950, nvidia 460GTX.

Why won't someone re-open this bug? It is NOT invalid.

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → New
Simon Strandman (nejsimon) wrote :

This happens to me too sometimes. Just login out and in a few times fixes it.

The importance shouldn't be low btw, gnome doesn't work properly if gnome-settings-daemon isn't started so it's serious problem.

This affects me also.

10.10 amd64, SSD (275mb/s), i7 740m, ATi 5650

Is there already a solution apart from adding sleep 2?

Really, this is a bug. It affects me too. I'm not reopening this one because it is a duplicate of bug 649809. Please, start watching the other bug and add any further comments there. Thank you.

haxmeadroom (haxmeadroom) wrote :

I'm getting this same bug, which is new after I upgraded to an SSD on a Sandy Bridge i7-2600k, which boots much faster. I believe this is a race condition that isn't normally noticed and affects faster systems.

Linux wubuntu 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux
DISTRIB_RELEASE=10.10
model name : Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers