gnome-settings-daemon crashed with signal 5 in xkl_process_error()

Bug #631672 reported by Sean Fitzpatrick on 2010-09-06
194
This bug affects 44 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

Occurred while opening firefox, not long after an upgrade that included several gconf packages.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-settings-daemon 2.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Mon Sep 6 09:18:28 2010
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 xkl_process_error () from /usr/lib/libxklavier.so.16
 _XError () from /usr/lib/libX11.so.6
 _XReply () from /usr/lib/libX11.so.6
 XQueryTree () from /usr/lib/libX11.so.6
Title: gnome-settings-daemon crashed with signal 5 in xkl_process_error()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 gdk_x_error (display=0x8da6698, error=0xbf834e8c)
 xkl_process_error (dpy=0x8da6698, evt=0xbf834e8c)
 _XError (dpy=0x8da6698, rep=0x8ee51c0)
 _XReply (dpy=0x8da6698, rep=0xbf834f70, extra=0, discard=0)
 XQueryTree (dpy=0x8da6698, w=35651588, root=0xbf835044,

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: iso-testing

I've had this crash a few more times; it seems to be more or less random but usually occurs while opening some program. The last two times happened while opening the game Tali, and then when opening Thunderbird. However it doesn't happen on every occasion so I don't know how to reproduce it.
It's likely that in most instances I've had chromium running, since I've been trying it out the last couple of weeks.

tags: added: bugpattern-needed
visibility: private → public
Pedro Villavicencio (pedro) wrote :

Is this still a problem with latest package there? we don't have any new report about it for a while. Please try to reproduce again and comment back, thanks in advance.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Incomplete

I haven't seen a crash in a long time, so I'll have to assume it's fixed!

Launchpad Janitor (janitor) wrote :

[Expired for gnome-settings-daemon (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Expired
Alessandro Losavio (alo21) wrote :

I have the same problem in Ubuntu 11.10 amd64 Live USB, but not always

crtm (carlosrtm) wrote :

After update, then crash

Pedro Villavicencio (pedro) wrote :

If you're having the issue could you please open a new bug with apport? we can follow up on that, thanks in advance.

Alessandro Losavio (alo21) wrote :

After I updated the system, seems the problem is solved. So I did not open a new bug.

Thanks

Dan Wood (dan-wood) wrote :

Happened to me after clean boot, log in, click on icon in dock to launch Chromium.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers