gnome-settings-daemon crashed with SIGSEGV in g_main_context_dispatch()

Bug #626379 reported by Artur Rona on 2010-08-29
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
High
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

I have reproduced this report through gdb. This is the same bug as bug 533432. During edit any image in kolourpaint4, gnome style is broken - gnome-settings-daemon.

TEST CASE:

1) Run kolourpaint4 on Gnome;
2) Edit any image file -> copy/paste from clipboard + cut
3) After some minutes, Gnome is going to very old theme - see attachment.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-settings-daemon 2.30.2-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Aug 29 19:50:02 2010
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcCmdline: /usr/bin/gnome-settings-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
SegvAnalysis:
 Segfault happened at: 0x1655687: mov 0x4(%ecx),%edx
 PC (0x01655687) ok
 source "0x4(%ecx)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_main_context_dispatch()
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Related branches

Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
visibility: private → public
Krzysztof Klimonda (kklimonda) wrote :

Attached below is a simple patch that fixed the crash for Artur. It's mostly a band-aid as the case it guards against should not happen - looks like XGetWindowProperty returns X_ATOM_PAIR in &type and 0 in &nitems.. I don't know how is that possible as I'm not familiar with Xlib.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: patch
Changed in gnome-settings-daemon:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for your work on that, could you add your patch on the upstream bug as well?

Krzysztof Klimonda (kklimonda) wrote :

Attached is a cleaner version of the previous patch - instead of checking whether conversion is NULL check the value of nitems early and return if it's zero.

Changed in gnome-settings-daemon:
importance: Unknown → High

StacktraceTop:
 clipboard_manager_event_filter (xevent=0xbffff09c,
 gdk_event_translate (display=<value optimized out>,
 gdk_event_translate (display=<value optimized out>,
 _gdk_events_uninit (display=0x8082978)
 g_source_set_name () from /lib/libglib-2.0.so.0

Changed in gnome-settings-daemon (Ubuntu):
importance: Low → Medium
tags: removed: need-i386-retrace
Rodrigo Moya (rodrigo-moya) wrote :

Patch committed to GNOME GIT

Changed in gnome-settings-daemon:
status: New → Fix Released
Artur Rona (ari-tczew) wrote :

gnome-settings-daemon (2.32.0-0ubuntu1) maverick; urgency=low

  * New upstream release.
 -- Michael Terry <email address hidden> Mon, 27 Sep 2010 10:15:53 -0400

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Artur Rona (ari-tczew) on 2010-11-21
tags: added: lucid sru
Martin Pitt (pitti) wrote :

What is to be uploaded here? Ari's branch or Krzysztof's debdiff? Please get it uploaded, so that it can be SRU processed, this looks okay for SRU.

Changed in gnome-settings-daemon (Ubuntu Lucid):
importance: Undecided → Low
status: New → Triaged
Artur Rona (ari-tczew) wrote :

Krzysztof has attached a patch, not debdiff. My branch includes a debdiff and is ready to upload.

Oliver Grawert (ogra) wrote :

uploaded to lucid-proposed

Accepted gnome-settings-daemon into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Krzysztof Klimonda (kklimonda) wrote :

I've tested gnome-settings-daemon 2.30.1-0ubuntu1.1 on Ubuntu 10.04 and can confirm that it fixes the crash that were present with gnome-settings-daemon 2.30.1-0ubuntu1

tags: added: verification-done
removed: verification-needed
Krzysztof Klimonda (kklimonda) wrote :

One little comment - when Kolourpaint is started in a way that previously lead to crash it takes around 10 seconds for it to launch. After this time the "QClipboard: Unable to receive an event from the clipboard manager in a reasonable time" is displayed and application works fine - I can copy and paste as expected, even from other applications. It still beats crashing gnome-settings-daemon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.30.1-0ubuntu1.1

---------------
gnome-settings-daemon (2.30.1-0ubuntu1.1) lucid-proposed; urgency=low

  [ Krzysztof Klimonda ]
  * debian/patches/92_return_if_nitems_is_0.patch: (LP: #626379)
    - Fix handle clipboard with KDE apps on Gnome, e.g. kolourpaint4.
 -- Artur Rona <email address hidden> Sun, 21 Nov 2010 14:21:45 +0100

Changed in gnome-settings-daemon (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.