Gnome Settings Daemon uses 100% CPU load

Bug #624477 reported by David Planella on 2010-08-26
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Karl Lattimer

Bug Description

Binary package hint: gnome-settings-daemon

I've noticed this two times already. For some reason gnome-settings-daemon starts using 100% CPU load, and once it starts behaving like this, it won't stop.

I'm not sure whether this is the cause or the consequence, but I've noticed it when trying to change keyboard layout through a shortcut key, which is something that I do quite often. I remember in bug 531290 there were modifications to g-s-d, but I'm not sure if this is just a red herring...

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-settings-daemon 2.30.2-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-17.23-generic 2.6.35.2
Uname: Linux 2.6.35-17-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Aug 26 09:17:27 2010
ProcEnviron:
 LANGUAGE=ca_ES:ca:en_GB:en
 LANG=ca_ES.utf8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon

David Planella (dpm) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

From IRC

(09:31:26) klattimer: xkl_engine_save_state triggers a state-changed signal, which then calls a function which xkl_engine_save_state's again, ad infinitum

This is most likely the cause, I'm looking into this and also a memory leak which may be one and the same bug.

Therefore is linked to bug 531290

Fix is simple, add checking for NULL in the right spot and there we go :) Already updated the patch, and will attach it to the GSD indicators support bug after a little testing.

Karl Lattimer (karl-qdh) wrote :

Bug fix for this is in the following bug; https://bugs.launchpad.net/ayatana-ubuntu/+bug/599844

I tested how this bug manifested itself to me, (changing layouts with keyboard shortcut while in screensaver dialog) and it seems to be OK, I'll obviously keep it running and see if it does manifest itself over time.

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.31.91-0ubuntu2

---------------
gnome-settings-daemon (2.31.91-0ubuntu2) maverick; urgency=low

  * debian/patches/08_xrandr_command.patch:
    - still call gnome-display-properties to configure the display, the
      control center changes didn't land this cycle (lp: #631761)
  * 06_use_application_indicator.patch: updated version by Karl Lattimer
    - don't start using cpu when switching layout (lp: #624477)
    - respect the option to display flag icons (lp: #623435)
 -- Sebastien Bacher <email address hidden> Mon, 06 Sep 2010 19:38:10 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
David Planella (dpm) wrote :

I've got the latest packages and I've already experienced the bug two times more.

I'd open a new bug, but I don't actually know what triggers it. What I've noticed now is that it happened after having pressed on the key I use to switch layout for a couple of seconds (after mistakenly thinking it was Ctrl).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers