Ubuntu

randomly gnome-settings-daemon fails to start

Reported by H3g3m0n on 2010-06-01
284
This bug affects 55 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Unknown
Medium
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

Randomly when logging in, rather than the normal Ambiance theme I get a default default GTK theme on the gnome-panel.

There is no gnome-settings-daemon listed in the processes.

Going in the the Appearance seems to start it up, and the theme is applied to the gnome-panel. I need to kill nautilus for it to be rethemed.

This is happening on 2 different computer systems. Both AMD64 with nvidia graphics cards (using the proprietary driver), otherwise with fairly different hardware.

There was another bug for this, with several other people reporting the same issue however it seems to have been closed as 'incomplete'.
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/312501

I also sometimes notice the long delay on login mentioned in the above bug, (basically the wallpaper loads then it just sits there doing nothing, then the panels come in). Not sure if it has anything to do with the gnome-settings-daemon though (sometimes the panels come in fine).

I have the following in xsession-errors:
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1177 error_code 8 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

H3g3m0n (h3g3m0n) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

summary: - [lucid] randomly gnome-settings-daemon fails to start
+ randomly gnome-settings-daemon fails to start
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
H3g3m0n (h3g3m0n) wrote :

I have tried the dbgsym version of gnome-settings-daemon, however I don't see how to go about getting a backtrace on a program that automatically starts at login.

It doesn't seem to flag the apport automatic bug reporting thing, I'm guessing it starts after gnome-settings-daemon (or needs it).

I tried killing and restarting gnome-settings-daemon after login about 20 times without any problems. It seems to only happen at boot (about 1 in 5 times?). So starting gnome-settings-daemon with gdb in the console won't cause the problem since it works fine after login.

In addition to that those instructions on the wiki don't actually work, installing the dbgsym package doesn't seem to actually replace the binary according to the md5sum of the binary and gdb reports no symbols. No error is shown during the install, I tried with a normal apt-get, one that specified the version as shown in the wiki and through synaptic. I can't uninstall the non-debug version without it trying to remove most of Gnome.

mlaverdiere (mlaverdiere) wrote :

This is a "me too" report.

On my laptop running Ubuntu Lucid, my findings is that the problem always occur upon wake-up (resume) process, after I have moved my laptop (while in sleep mode) from one wi-fi area (e.g.: home) to another wi-fi area (e.g.: work), i.e. when network-manager has to change the connection to the newly available pre-registered SSID (which often fails). Then, all the gtk apps revert back to to default (ugly!) gtk theme. In order to get the ambiance theme back, I have to open the theme applet. The problem doesn't seem to happen otherwise.

Id2ndR (id2ndr) wrote :

i have encountered this trouble too. However it doesn't occur at each boot.

Dist : Ubuntu 10.04 x64
GPU : nvidia 8600GT with driver of serie 256 (from x-swat-x-updates ppa)
GDM : autostartup (without delay)

I tried to got the debug output doing the modification of the attached patch, but the trouble doesn't appears doing this (at least for the 5 tries I made since this). Maybe others will success in doing this.

My idea is that there is a race condition between dbus and g-s-d that prevent g-s-d to start if dbus isn't totally ready, but I can't prove it, and I don't now how to log the startup of dbus and g-s-d.

Id2ndR (id2ndr) wrote :

Some precisions:
- if g-s-d still doesn't start after applying the modification I added, errors will be traced in ~/.xsession-errors file.
- if g-s-d start after applying the modification I added, I think this is because the computation of log(s output take some time and 'slow down the startup of g-s-d. This may be the sign of the race condition that I suspect, but it will be harder to debug.

Pascollin (pascollin) wrote :

I have the same trouble here.
Dist : Ubuntu 10.10 i686
GPU : Intel Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
GDM: autostartup (without delay)

Astrocitoma (diodo-vettoriale) wrote :

Same trouble here.
Dist: Ubuntu 10.10 x86_64
GPU: Nvidia GeForce 8600 GT 512M
NVIDIA Driver Version: 260.19.06

SteveTurner (kbturner31) wrote :

I think this bug is the same as what's being reported here:

http://ubuntuforums.org/showthread.php?t=1575703

To summarize that thread, when multitasking for an hour or so, the gnome theme reverts to the default. It doesn't always happen, but it is happening pretty regularly to me and the other users in that thread. Opening System->Preferences->Appearances then causes the theme to change back to whatever the user had previously set it to, except for the icons (they remain set to the default theme). The following error message showed up in syslog:

gnome-settings-[1411]: segfault at 4 ip 0838396f sp bfaebdc0 error 4 in libclipboard.so[8381000+5000]

Since the settings daemon starts when the gnome session starts, I tried to do a backtrace by using Ctrl-Alt-F2, starting X on dislpay :1, and running a second gnome session under gdb. After seeing the bug behavior, I killed the session in the terminal, entered "bt" at the gdb prompt, and got the following:

(gdb)bt
#0 0x0012d422 in ?? ()
#1 0x00a16b86 in poll () from /lib/tls/i686cmov/libc.so.6
#2 0x007ac4eb in g_poll () from /lib/libglib-2.0.so.0
#3 0x0079f0ac in ?? () from /lib/libglib-2.0.so.0
#4 0x0079f817 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5 0x002873c9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#6 0x08062033 in ?? ()
#7 0x0096dbd6 in __libc_start_main () from /lib/tls/i686/cmov/libc.co.6
#8 0x08051291 in ?? ()
(gbd)

I hope this helps.

SteveTurner (kbturner31) wrote :

I updated this thread:
http://ubuntuforums.org/showthread.php?t=1575703&page=2
but here's the short version.

I removed the sun-java6-plugin package, thinking it was the source of the problem, but I continued to see random theme changes. Then I stopped using Gnome-Do/Docky and went back to using the regular Gnome panel. Since then, I haven't seen any random theme changes. My new plan is to begin using Gnome-Do/Docky again to try and recreate the bug.

If successful, then I think the bug can be safely narrowed down to the Gnome-Do/Docky package.

Id2ndR (id2ndr) wrote :

I've seen this bug on a machine that doesn't have gnome-do/docky installed.

SteveTurner (kbturner31) wrote :

>>"I've seen this bug on a machine that doesn't have gnome-do/docky installed."

That makes me a little sad, because I was really hoping I had narrowed the problem down, but it's helpful nonetheless.

After re-reading this thread, I'm starting to wonder if maybe mine is a different bug. OP's report describes an error occurring at startup, but my bug's symptoms occur well after startup. I originally thought these were related as gnome-settings-daemon errors, but maybe I'm wrong.

My new hypothesis is that some program sends a message to the X-server to redraw/update a window while several programs are running. In order to redraw/update the window, the settings daemon must supply theme, font, color, and other settings. The gnome-settings-daemon then crashes due to lack of available resources, poor process scheduling, or some other problem, and lacking settings info, the X-server reverts to the default theme. In my case, docky was at least related to the crashes-- the symptoms went away when I stopped using it-- but I'm unsure how it was causing them.

I don't have the expertise to explore this line of reasoning, nor do I have the knowledge to determine if this is sound logic. What would be nice is if some code guru out there in Launchpad Land could investigate this bug a little bit.

SteveTurner (kbturner31) wrote :

I spoke too soon in declaring the bug squashed. I had some trouble printing a document, fiddled with CUPS, tried to see the print queue via System->Administration->Printing, and then saw my theme revert to the default theme.

The printer I was using is a network printer, and it worked fine this morning. Between then and the failure to work, there were no major changes to my system. I'm still using the regular gnome panel instead of Docky, and I haven't re-installed the sun-java6-plugin package that I first thought was the source of the problem.

I just posted a little more detail in the other thread (the link is in posts #9 and #10 ITT), but basically, I'm thinking this could be due to using older hardware. I'm using a 5 year-old Sony Vaio PCG-K45 with 3.2 GHz P4 and 1 Gb of RAM. Has anyone seen this bug on a computer that was built within the last year?

Kupfer (tamas-kadas) wrote :

This problem keeps appearing for me since yesterday. Just as in the bug description, when I log in, sometimes the ambiance theme doesn't load and I get the default GTK-Theme instead. I have to either log out and log back in or start the appearances window to solve this annoying issue.
Also, even tough I don't know whether this is normal or not (I usually don't fiddle around with appearance settings, but use the defaults instead), when I'm selecting ambiance, after restart or log in-log out it is set to "custom". Again, I have no clue if this is relevant.
I'm using Ubuntu 64bit desktop edition on an Asus EeePC 1005PE.

Kupfer (tamas-kadas) wrote :

Here some additional information about the problem appearing on Ubuntu 10.10:

If I type 'ps aux | grep settings' in the terminal gnome-settings-daemon isn't shown.

If i type gnome-settings-daemon the ambiance theme starts. I also get the error message:

** (gnome-settings-daemon:3606): WARNING **: Got less number of items in credentials hash table than expected!

After that 'ps aux | grep settings' show gnome-settings-daemon running.

I don't know if this is relevant, but if I type in gnome-settings-daemon after that again, I get the following error message:

** (gnome-settings-daemon:3693): WARNING **: Failed to acquire org.gnome.SettingsDaemon

** (gnome-settings-daemon:3693): WARNING **: Could not acquire name

The ambiance theme not loading on startup is very annoying. Now it happens every time I log in.

Luis Lobo (luislobo) wrote :

Same thing happening here since a couple of days.

here running
 Linux laptoplub 2.6.35-23-generic-pae #41-Ubuntu SMP Wed Nov 24 10:35:46 UTC 2010 i686 GNU/Linux

How can I report more information to help?

Roman Yagodin (roman-yagodin) wrote :

Same problem running Ubuntu 10.10...

Linux Satellite 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux.

In my case, bug started to showup after adding ru.png & us.png images for keyboard indicator in /usr/share/pixmaps. As I think now, where may be a problem with gnome / ubuntu indicator applets. Still checking...

Roman Yagodin (roman-yagodin) wrote :

One more sympthom: I may manually switch to Ambience theme, but icon theme remains default.

Some things I done:

1) Removed all indicator applets from desktop panels;
2) In gconf-editor, set /desktop/gnome/peripherals/keyboard/indicator/showFlags back to 0/false/unchecked state;
3) Remove all keyboard indicator icons from /usr/share/pixmaps & ~/.icons/flags (with dir). And there was а [possible] duplicate: ru.png & ru.svg files;
4) Reboot;
5) Add indicator applets again.

After this, I have 4 hot and cold reboots - bug doesn't show up... Crossing fingers :)

Rookcifer (rookcifer) wrote :

Same problem here. Grey theme at boot. Going into theme preferences will fix the panel, but it will not fix Nautilus or the desktop icons.

I'm using ubuntu 10.10 x64 with an nvidia graphics card (using binary drivers).

What is the status of this bug? Can any developer here tell me if you are working on it? This bug is rather infuriating and there doesn't seem to be any progress being made on it.

tags: added: lucid maverick
Kupfer (tamas-kadas) wrote :

For the record: I filed a bug report on bugzilla.gnome.org reporting the problem - hopefully it will yield some result:

https://bugzilla.gnome.org/show_bug.cgi?id=637921

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Starjana (thomas-velde) wrote :

i Think this bug is not related with any program like, Java6, Gnome-Do/Docky or what so ever. I Think this because the bug just happened after a system update of last week. That update cycle only contains update of the standard Ubuntu software source. I don know which one is causing the problem.

I tried several things like reinstalling all packages that contains "gtk¨ and that helped only within this session after the reboot it resets itself back to the buggy default gnome theme.

I am no master of this stuff but I am trying my best to help you people who can.

H3g3m0n (h3g3m0n) wrote :

I actually think we are seeing a few different bugs that all result in gnome-settings-daemon crashing.

The bug I originally reported, which happened to me on 2 separate computers, with very different hardware (other than the fact they where both x86_64 installs), seemed to stop occurring on both systems. I'm guessing some update rolled out that fixed it. I have had almost no problems with gsd since then.

In my original case there was no gnome-do, docky, sun-java6 or any other programs other than the defaults. I don't think those would cause any problems since afaik gsd is just for giving settings to applications, it doesn't really care what the settings are.

The main problem is that there isn't any way to get debugging output of gnome-settings-daemon-dbgsym if it crashes at login making reporting bugs close to impossible.

gdb does support attaching to an already running process. Perhaps it's possible to use a script in a loop that keeps looking for it running and tried to attach then dump a backtrace somewhere (or runs in a screen so you can get the backtrack yourself)? If you getting crashing some time after login then it should be no problem to attach.

The following could work:
while true; do; PID=`pidof gnome-settings-daemon`; if test $PID; then; sudo gdb attach --pid=$PID; sleep 1; fi; done

Just /etc/init.d/gdm stop, ctrl+alt+f2 to virtual terminal. Execute the above as root (it would probably be easier to save it to a script file first and run from that, it also might be worth while running it in a 'screen' session so you can attach to it from within a Xorg terminal). Then restart gdm. After gnome-settings-daemon crashes, ctrl+alt+f2 back to the VT and take a screen dump.

The question is if it will connect to the process in time.

Fabio Marconi (fabiomarconi) wrote :

This bug in close as "NOT GNOME" in bugzilla tracker.

Rookcifer (rookcifer) wrote :

Yeah it seems neither the Gnome or the Ubuntu devs want to help. I am seriously thinking of switching to a KDE distro because of this.

Kupfer (tamas-kadas) wrote :

The bug just returned for me on Maverick. As a result, I'm going to remove it now, and never use it again. Instead I'm going to use my Lucid install (which doesn't show the symptom) whenever I want to use Ubuntu. I'll be back for Natty if the problem somehow magically resolves itself by then or someone finally looks into it. Unfortunately, those are big ifs. Until then I'm going to find another up-to-date Gnome/Linux distro for my main OS.

Ron S (ronshere-people) wrote :

In maverick I have had this bug happen to me on several occasions on boot up. logging out and logging back in fixes the problem.
I have noticed this only happens to me after updating but only after an update where it say ureadahead will be re-profiled at next
boot up . Since noticing this every update that forces re-profiling has caused this problem but only on my pc and not my laptop.
PC uses nvidia driver 260.19.06 while laptop uses ati driver.

H3g3m0n (h3g3m0n) wrote :

I doubt anyone will be able to fix this without a stack trace.

From what I can see, the current ddeb dbgsym packages have the gnome-settings-deamon binary in them which for some reason they didn't when I tried back with Lucid which made getting a stack trace impossible.

Since they now seem to work, Grab the dbgsym version and give the instructions I gave for logging gnome-settings-daemon a go. I would but it's no longer happening to me.

If the other instructions don't work or you want a different way, It might also be possible to rename dbgsym version of the /usr/bin/gnome-settings-daemon binary and replace it with script containing something like:
screen -L gdb --eval-command='run' gnome-settings-daemon.therealfile

Then just 'screen -x' and get a backtrace.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
Rdvonz (rdvonz) wrote :

I'm having the exact same problem described as above.

Bug encountered: When logging into ubuntu Maverick Meerkat 10.10, seemingly randomly.

Computer: HP mini 110, ubuntu netbook remix with default ubuntu desktop session. 1gb ram, intel graphics, compiz enabled.

Theme installed: Elementary theme with the Faenza icon set.

Workaround: Open terminal, start the gnome-settings-daemon process (which doesn't show up under the system processes after logging in), restart nautilus.

I'd really like to see this bug fixed, it randomly occurs to me and doesn't happen more than once a week, so it's probably going to be extremely hard to remedy.

martin (martin-probst-web) wrote :

I tried to get a stacktrace with gdb. I attached gdb to the running process of gnome-settings-daemon by using a startup-script that contained the following lines:

gdb -batch-silent \
 -ex 'set logging overwrite on' \
 -ex "set logging file /tmp/gdb-gsd-${RANDOM}.txt" \
 -ex 'set logging on' \
 -ex 'handle SIG33 pass nostop noprint' \
 -ex 'set pagination 0' \
 -ex "attach ${pid}" \
 -ex 'continue' \
 -ex 'backtrace full' \
 -ex 'info registers' \
 -ex 'x/16i $pc' \
 -ex 'thread apply all backtrace' \
 -ex 'quit' \
 < /dev/null

When gnome-settings-daemon crashed, the output was as follows:

[Thread debugging using libthread_db enabled]
[New Thread 0xb748db70 (LWP 1861)]
[Thread 0xb748db70 (LWP 1861) exited]

Program exited with code 01.
No stack.
The program has no registers now.
No registers.

Unfortunately there is still no stacktrace. Did I miss something on using gdb?

Sebastien Bacher (seb128) wrote :

it seems in your case it exits and doesn't crash

martin (martin-probst-web) wrote :

Yeah, it seems that way. But I don't think this is just in my case. I'm experiencing the exact behaviour discussed in this bug. Sometimes (not regularly, maybe on every 3rd or 4th start-up) right after logging-in the desktop appears with the gnome default-theme. There is no gnome-settings-daemon process any more. Maybe it's not a crash, but the daemon shouldn't exit anyway (especially not with exit code 1, which indicates a problem, doesn't it?). Isn't there a way to configure gdb to produce a stacktrace on program termination with exit codes other than 0?

David Kühling (dvdkhlng) wrote :

@sebastien, @martin: try setting a breakpoint on the exit function(s):

break exit
break _exit

Clemens Kühling (clekuehl) wrote :

I can confirm this bug on my system as well.

My Ubuntu-Version: 10.10
Hardware: Asus Eee-Pc-1201t, (CPU: AMD-Neo, GPU: ATI Radeon HD3200)

charakteristika of the bug:
1. gnome-settings-daemon randomly fails to start after log-in resulting in the standard-gnome-look (symbols and color-scheme in gnome-panel and nautilus)
2. after starting the appearence-menue gnome-settings-daemon starts without any problems solving the panel-issue
3. nautilus on the other hand stays uneffected
4. logging out and again logging seemes to solve the problem

The problem first occured a few weeks ago, since then sporadiclly however since yesterday it occoures permanently. I ran a regular system-update yesterday. Due to var/log/dpkg.log the following packages were affected

icedtea6-plugin 6b20-1.9.2-0ubuntu2 6b20-1.9.4-0ubuntu1
icedtea-6-jre-cacao 6b20-1.9.2-0ubuntu2 6b20-1.9.4-0ubuntu1
openjdk-6-jre-lib 6b20-1.9.2-0ubuntu2 6b20-1.9.4-0ubuntu1
openjdk-6-jre-headless 6b20-1.9.2-0ubuntu2 6b20-1.9.4-0ubuntu1
openjdk-6-jre 6b20-1.9.2-0ubuntu2 6b20-1.9.4-0ubuntu1

the hicolor-icon-theme 0.11-1 0.11-1 is also mentioned in the log-file. Perhaps var/log/daemon.log gives some suggestions, what might be going wrong at system-start. It says:

Jan 28 18:53:24 erpel gdm-simple-greeter[1771]: Gtk-WARNING: /build/buildd/gtk+2.0-2.22.0/gtk/gtkwidget.c:5684: widget not within a GtkWindow
Jan 28 18:53:26 erpel gdm-session-worker[1780]: GLib-GObject-CRITICAL: g_value_get_boolean: assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed

Me Too:
HP dv7 4290US core i7-2630QM
Ubuntu 10.10

I have the problem where nautilus does not pick up the current theme.
Log out and log in do not resolve it.
Reboot does not resolve it.

Kill and restart gnome-settings-daemon and kill and restart nautilus do work.
Here is the
$ ps aux |grep settings
charles 3624 0.3 0.2 211568 12244 ? Rsl 11:54 0:06 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
$ kill -9 3624
$ gnome-settings-daemon
$ /usr/share/themes/exotic/gtk-2.0/gtkrc:336: error: invalid string constant "theme-menu-
widget_class ", expected valid string constant

The only recent change I can think of is that I installed Dropbox v1.0.20

alex (aarw2) wrote :

I have it on both my 10.10 installations (one on a classic netbook and one a fujistu tablet). i have not seen it on my 10.04 laptop. in the 10.10 systems I am using the desktop interface as Unity is unusable. As with all other comments it is random at startup. Theme can be altered back by going to appearance but nautilus stays ugly. I do not think it is dropbox related as posted above since I have drop box on my laptop 10.04 that does not have the bug, and on my 10.10 netbook that does have the bug whereas the tablet running 10.10 has no dropbox but does have the bug. The bug occurred on the netbook after "upgrading" to 10.10

martin (martin-probst-web) wrote :

After not having seen this bug for a while, it finally appeared again and I got the backtrace (see attachment). I had the breakpoints set on exit and _exit as suggested by David. I hope this helps and someone can take a look at this soon. BTW the .xsession-errors showed the following error:

The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1355 error_code 8 request_code 3 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Greets, Martin

Kupfer (tamas-kadas) wrote :

If i may inquire... now, that Martin has provided a backtrace, is the problem being looked into by a developer now (as the bug is still set to unassigned)? I know these things take time, but some feedback of activity would have a calming effect on us folks experiencing the problem.

Sebastien Bacher (seb128) wrote :

seems similar to bug #639913

I've recently been seeing this happen across two different motherboards.

I hadn't seen it appear at all previously.

I'll wager that on some level this is a race condition. It occurred zero times with a quad core and about 50% of the time with my six core. This happened on identical hardware with the only difference being the processor.

Me too!
HP Probook Ubuntu 10.10 and Linux Mint 10 Radeon 4300 series

drink (martin-espinoza) wrote :

I have this problem on an install of lucid from the original alternate ISO and upgraded from there, i386 on a P4 with ATI (Mobility). Compiz is working nicely but gnome-settings-daemon usually doesn't start. No problems on my natty desktop.

I think I know what is the problem.

When logging in the gnome-setting-manager with gdm's pid is still active. This makes users gnome-settings-manager fail to start. After some time gdm's one finally exits and users is left with gray theme.

The following in:

[mutex:/etc/gdm]% cat /etc/gdm/PostLogin/Default

killall gnome-settings-daemon 1>>/tmp/log.1 2>>/tmp/log.2
killall -9 gnome-settings-daemon 1>>/tmp/log.1 2>>/tmp/log.2

has fixed my problem.

Michał J. Gajda (mgajda) wrote :

For some people it also happens during a first login. See #574296

Yrogirg (sargrigory) wrote :

I have the same problem --- occasionally after reboot the theme is reverted from radiance to ambiance and icon theme to some ugly default. If I log in / log out then everything goes back, i don't have to do nothing in settings for it.

Tamas Orszagh (oszkar00) wrote :

Same happened to me.

Description: After a different user (with a different appearance settings) hase logged in (and after it logged out), with my user the theme was with ugly icons and menu backgrounds and unity panel.

Workaround:
killall gnome-settings-demon
gnome-settings-demon &
# after these two command the panel and the menu background was OK
killall nautilus
# after the automatic restart of nautilus the icon theme was OK

Matt Fischer (mfisch) wrote :

I am seeing this in 11.10 after I resume from sleep. Tamas's work-around seems to solve the problem, as does logging out and logging back in.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.