Ubuntu

No way to tweak multi-finger tap reaction

Reported by Evgeny Kuznetsov on 2010-04-14
118
This bug affects 22 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Invalid
Medium
gnome-settings-daemon (Ubuntu)
Wishlist
Unassigned
Declined for Lucid by Sebastien Bacher

Bug Description

Binary package hint: gnome-settings-daemon

In current Karmic and Lucid gnome-settings-daemon ignores x.org's and synaptics driver's settings concerning 2-finger and 3-finger tap behaviour and resets it's own hard-coded configuration as soon as an input device is added/removed.

This behaviour effectively renders multifinger tap settings unchangeable by the user.

Gnome-settings-daemon should either not mess with those settings at all and inherit them from X (not a good idea since the settings in question shoud better be per-user, not per-system), or there shoud be an option to configure the behaviour user desires by means of gnome-settings-daemon itself.

A patch by Yuri Khan adds the necessary keys to gconf and makes the settings tweakable.

Yuri Khan (yurivkhan) wrote :

The patch above is a little dated and will not apply cleanly to gnome-settings-daemon 2.30. I maintain a package in my PPA, the relevant patches are:

06_add_corner_tapping_button_settings.patch
06_add_tap-to-click_button_settings.patch
06_change_tap-to-click_defaults.patch

I will post their current versions below.

I have also submitted the first two patches upstream, so when they are accepted, they will propagate to Ubuntu eventually.

Yuri Khan (yurivkhan) wrote :

In this patch:
 * Add gconf settings for one-finger, two-finger and three-finger taps.
 * Add code to read and apply these settings.
 * Additionally, the effect of X device button mapping on the tap mapping is considered. (Original code does not do this, causing incorrect behavior if the user changes the button mapping other than by selecting “left-handed” configuration.)

Yuri Khan (yurivkhan) wrote :

Sorry, mixed up the order. This one is the first in series. The description above applies to this patch. The correct description for the patch above, which is second in series:

 * Add gconf settings for corner taps (left top, left bottom, right top, right bottom).
 * Use the same logic as in the first patch to reverse the effect of X device button mapping.

Yuri Khan (yurivkhan) wrote :

This patch was added just yesterday, following suit with Alberto Milone who changed the defaults. This also changes defaults to what they were in Jaunty:
* 1 finger for left button
* 2 fingers for middle button
* 3 fingers for right button

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
DarkV (yhonay) on 2010-04-15
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)

After the kernel package update to 2.6.32-21 I was much annoyed to find that the multi-finger tap-clicking behavior on my MacBook 4,1 had changed (to right-clicking with three fingers, middle-clicking with two, had been the other way round all the time). I updated gnome-settings-demon to the one from Yuri Khan's PPA, adapted the relevant new gconf keys, and got the old behavior back. Thanks a lot, Yuri!

I definitely think that tap-clicking should be configurable by default in Ubuntu/Gnome, optimally with GUI options in Mouse Preference.

Yuri Khan, can we get another update of the version in your PPA? The Canonical developers have gone and "fixed" things with another update and I no longer have my tap to click capabilities in Lucid... Thanks ahead of time!

--bornagainpenguin

Yuri Khan (yurivkhan) wrote :

Thanks for prodding me. I uploaded the updated source packages; builds should be available in about an hour.

Thanks! Unfortunately they've gone and done it again...

Is there a way I can force the system to use your package and NOT revert to Canoncials malfunctioning one every time there's an update?

Yuri Khan (yurivkhan) wrote :

If you are using synaptic, you can force my version and then pin it. But you will miss on updates.

I have updated the package but the build farm is very busy these days. Also, since Lucid is officially out, I’m freezing my main PPA. Further official updates are in the lucid-proposed pocket; my updated builds will be in ppa:yurivkhan/proposed.

@Alberto Milone: Could you please have a look at my patches and maybe integrate them in lucid-proposed? Or should I rather try to get it reviewed and accepted upstream?

Changed in gnome-settings-daemon:
status: Unknown → New
Heinz Werner Kramski (kramski) wrote :

Yuri Khan,

thanks a lot for your patch/ppa.

Works great on an Eee-PC 900a (standard 10.04 i386 desktop).

Regards,
   Heinz

Johannes Konow (itix) wrote :

Worked for me until just recently...
There was a bundle of 27 upgrades which I installed and now it doesn't work again :(

Johannes Konow (itix) wrote :

Ok, here is what to do if the functionality is reverted... go to system -> administration -> synaptics package manager. Search for gnome-settings-manager and select it (just select, dont double klick).

Klick on "package" in the top of the window (just under the window list) and select "force version". Then select "2.30.0-0ubuntu7~ppa1~lucid1" if you have lucid lynx
or "2.30.0-0ubuntu7~ppa1~karmic2" if you have karmic.

Now you need to go to system -> administration -> update manager and klick the "update" button. You should now se that the gnome-settings-manager is available for update. Install updates and you should be finished.

Just restart the computer and things will be back to normal.

Can somebody please tell me when this patch reaches normal channels?
I don't like having a locked version of a package... the package updates are done for a reason.

Yuri Khan (yurivkhan) wrote :

@Johannes Konow

If you are using the lucid-updates and/or lucid-proposed repositories, you might also want to add ppa:yurivkhan/proposed.

Kyle Weaver (kweaver87) wrote :

Using yurivkan/proposed on customized Ubuntu 10.04 Netbook Remix on an EeePC 901. Finally fixes this bug, where startup scripts, udev rules, and x11 configs failed. No issues noticed. Thanks for the fix!

Matyas Maa (matyas-maa) wrote :

Solved with ppa:yurivkhan/proposed in my case.

These settings should really be configured straight from the GUI of mouse settings by default. Does anyone know if the Ubuntu developers are working on it?

Juan Restrepo (juanrestrepojr) wrote :

This Bug Affected me until i did the Yuri Khan PPA Patch and it's working wonders. Thanks a million, guys!!!

tags: added: patch-forwarded-upstream
removed: patch
barna (magyarkuti) wrote :

thanks for the patch, works well on a fujitsu-siemens amilo li1720 using lucid...

dmitri.agueev (dmitri-agueev) wrote :

is it possible to modify the patch so that the variable
synaptic VertTwoFingerScroll is not modified by gnome-settings-daemon?
The command
$ synclient VertTwoFingerScroll=1
sets it to one, but after re-login it is zero again.

Alex Dicks (ajdicks) wrote :

Just upgraded to Lucid, and once again Yuri saves the day with his cure for multi-tap woes. Three cheers for him, and a special multi-tap two-finger salute to all those preventing this from being included as standard.

Mitch Graw (mitch-graw) wrote :

Thanks Yuri Khan! I've had this problem for so long on my macbook pro (1,1) but it works now thanks!!

lanzen (lanzen) wrote :

"Affects me too" is not a proper statement here. It should rather be "no set up option available". It affects gnome, but not kde. In Kubuntu, in fact, it is possible to change settings in "System Settings.

lanzen (lanzen) wrote :

Oh, I forgot: Yuri Khan PPA fixes this bug.

lanzen (lanzen) wrote :

For some unknown reason I've lost the three finger tap that now doesn't seem to work on my eeepc 1000H anymore. Two finger tap and scroll still works fine.

Also, I'm not sure if this is an Ubuntu or a Gnome bug as it looks as it is affecting other distros (e.g. fedora). As I've already said before KDE offers easy - and working - customisation. I wonder why it it's true they stand on the same base.

Yuri Khan (yurivkhan) wrote :

Yes it is a GNOME bug and a link to the related upstream bug report is provided above. But I am doing limited testing on Ubuntu users like myself while waiting for the upstream to come out of feature freeze.

Meanwhile, the package for Maverick is available in ppa:yurivkhan/ppa, although it is bound to be a hard time for me keeping up with new versions.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
Yuri Khan (yurivkhan) wrote :

I’ve added to my PPA a version of gnome-control-center that allows one to configure tap-to-click and corner click button mappings via GUI. Maverick only. Testing results, regression reports, positive or negative feedback, constructive criticism welcome.

Piotr Kęplicz (keplicz) wrote :

Thanks, Yuri, it works fine. Finally an easy way to fix #432814 that should definitely make its way on to maverick-updates.

Rémi (pazelty) wrote :

hello

Thanks to work about that stupid bug

I installed the ppa. both packtages
I configured in gconf-editor, it's appear that nothing happening

I tried the gui to but it's the same nothing changing...

If you have some advice I could be happy...

Rémi

Evgeny Kuznetsov (nekr0z) wrote :

Rémi, currently Yuri's PPA doesn't fix this problem (at least for Maverick), Yuri hasn't patched the latest version of gnome-settings-daemon yet.

Yuri Khan (yurivkhan) wrote :

Sorry, I haven’t yet had a chance to notice the new version. Thanks for reminding. Will post an update soon.

Yuri Khan (yurivkhan) wrote :

Ok, it was just a matter of copying the package from my “proposed” ppa. Enjoy.

Evgeny Kuznetsov (nekr0z) wrote :

Is there anything we can do to make sure this bug is patched in Natty? (We should have done it in Maverick, for sure.) Now that we ditch upstream Gnome in favour of Unity this becomes even more of an issue.

Yuri Khan (yurivkhan) wrote :

I have not yet installed Natty, and I am not at all confident I will be ditching Gnome. Technically, if Unity also overwrites synaptic settings with non-configurable defaults, that would be a separate bug in a different program.

F. Hantho (hantho) wrote :

These packages fixes the Gnome bug https://bugzilla.gnome.org/show_bug.cgi?id=598820 for me.
I am using Maverick 64-bit with an Elantech touchpad, that Ubuntu has not always been very accepting towards. Tried all kinds of tricks to get my TapButton2=2 and TapButton3=3 to stick without success, but this seems to work.

May I add that the configurable Touchpad settings under System->Preferences->Mouse is a very nice touch. Oh and props for not messing with my other manually specified synclient settings.

Oldo Bert (oldobert) wrote :

Using Maverick, the packages from the PPA of Yuri work fine, I've installed them from a while.
Thank you very much, this is quite important for the quality of my working hours.

Changed in gnome-settings-daemon:
status: New → Invalid

Those using natty with Unity(gnome 2), could join my PPA https://launchpad.net/~o.shybystyi/+archive/gnome-settings-daemon-natty.

Yuri Khan (yurivkhan) wrote :

Uploaded packages for Natty to my PPA.

Johannes Frank (jmfrank) wrote :

Hello Yuri,

is it possible to update the lucid version. I installed lucid on a new netbook and the ppa doesn't install since there is a newer version available Many thanks for your efforts.

@alberto milone:
triaging this bug as whishlist is critical in my opinion. one uses the pad every second and since i have a second netbook with different behavior new installations get nearly unusable. I mix up the right and middle buttons all the time.
This is a showstopper, and I am really angry by now, This issue is up for more than two years.
Even microsoft and apple are behaving better in such cases.
So please make this bug critical! It is!

Yuri Khan (yurivkhan) wrote :

Will get to a Lucid machine on Monday.

lanzen (lanzen) wrote :

@ Yury:

Thanks for all your work on this annoying bug/feature... Myself I'd hope to have a choice!

Anyway, as you may know, a simple script in startup fixes or, better said, works around, this choiseless gnome choice at least in natty as it was doing years ago:

synclient TapButton2=2 TapButton3=3

BTW: work in squeeze, too,

I'm still hoping gnome would change their minds and allow an option to be easily available. As I already said, KDE has it.

Yuri Khan (yurivkhan) wrote :

@Johannes Frank: fresh lucid build done.

@lanzen: the startup script won’t prevent g-s-d from overriding your settings when the user mucks the settings around in the GUI. On the up side, in GNOME 3 there will be a proper place to put this script so that it will work reliably.

Changed in gnome-settings-daemon (Ubuntu):
assignee: Alberto Milone (albertomilone) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.