Ubuntu

Cannot switch Monitor configuration CRTC 58

Reported by arky on 2009-11-17
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Fix Released
Low
gnome-settings-daemon (Ubuntu)
Medium
Chase Douglas

Bug Description

When laptop lid is closed and opened. There are following errors in .xsession-errors
[ 1039.531199] [drm] LVDS-8: set mode 1280x800 c
[ 1042.444490] [drm] LVDS-8: set mode 1280x800 c
[ 1695.731119] [drm] LVDS-8: set mode 1280x800 c
[ 1701.615430] [drm] LVDS-8: set mode 1280x800 c
[ 1897.308479] [drm] LVDS-8: set mode 1280x800 c
[ 1904.300095] [drm] LVDS-8: set mode 1280x800 c

And there is error notification with notify-osd.

$ uname -a
Linux karmic-kola 2.6.32-4-generic #5-Ubuntu SMP Fri Nov 13 13:38:07 UTC 2009 i686 GNU/Linux
~$ lsb_release -a
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: iise 1680 F.... pulseaudio
 /dev/snd/pcmC0D0p: iise 1680 F...m pulseaudio
 /dev/snd/pcmC0D0c: iise 1680 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6dfc000 irq 21'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,10280298,00100000'
   Controls : 14
   Simple ctrls : 7
Date: Tue Nov 17 19:09:59 2009
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=252576b5-cbd7-4622-bb69-7754c46423f5
MachineType: Dell Inc. Vostro A840
Package: linux-image-2.6.32-4-generic 2.6.32-4.5
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=c46be738-de75-47f9-8f41-9e0b971c20a7 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-4.5-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.24
Reproducible: No
SourcePackage: linux
Tags: needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-4-generic i686
WpaSupplicantLog:

dmi.bios.date: 07/30/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.name: 0G216H
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd07/30/2008:svnDellInc.:pnVostroA840:pvr:rvnDellInc.:rn0G216H:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Vostro A840
dmi.sys.vendor: Dell Inc.

arky (arky) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Andy Whitcroft (apw) on 2009-11-30
tags: added: kernel-lucid
Andy Whitcroft (apw) wrote :

@arky -- That implies that the mode we thing the display is in is not a valid mode. Could you attach the output of xrandr on this system please.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → In Progress
status: In Progress → Incomplete
tags: added: lucid
removed: kernel-lucid
Ketil (ketil-froyn) wrote :

I get this same issue, on a Toshiba Portege R500 laptop with a BENQ T24IWA external monitor. Rebooting with the screen attached is the only way to get my desktop on the screen in a usable manner, and then it works perfectly. However, after doing this, I can never get my laptop screen back after a suspend, even if I switch display settings back to the laptop monitor before suspending.

I'd be happy to gather more debug info to help resolve the issue.

Ketil (ketil-froyn) wrote :

Sorry, I wasn't real clear. The issue I experience is that when I try to use my laptop's keycombo to switch display settings, I get the error message:

Could not switch the monitor configuration
could not set the configuration for CRTC 58

and the remote screen remains black. Rebooting with the laptop attached to the external screen is the only way I have been able to get the external screen working. I don't necessarily have the same log messages as the original poster.

radostyle (mr--jon) wrote :

I have the message "Could not switch the monitor configuration could not set the configuration for CRTC 58", though my screen does actually switch, and I can get it back after a suspend resume command by using a xrandr script, but after running my command I get that message, even though my screen switches over to dual display fine. I have a Lenovo T500 laptop with a Hanns-G monitor.

Julian Gilbey (jdg-polya) wrote :

I am observing the same bug with my Dell Inspiron 1545 laptop: close the laptop, reopen it and the screen is blank. Do Ctl-Alt-F1 and then Ctl-Alt-F7 and I get back to my X-session, with the error message "could not set the configuration for CRTC 64". Kernel log has:

Feb 18 14:42:53 polya kernel: [65517.943549] [drm] LVDS-8: set mode 1366x768 c

and xrandr says:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 353mm x 198mm
   1366x768 60.0*+
   1360x768 59.8
   1024x768 85.0 75.0 70.1 60.0
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
DP1 disconnected (normal left inverted right x axis y axis)

Chaostya (chaostya) wrote :

Also affects me. Dell D610 + ViewSonic VP930-3

Benjamin Davis (benkong2-gmail) wrote :

It affects me also Gateway EC1803u 1368x768 laptop

Pouyan (pouyan) wrote :

After Compiling New Kernel from kernel.org I got this error.
Kernel V 2.6.33

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Chase Douglas (chasedouglas) wrote :

I had a hard time finding where the "could not set the configuration for CRTC 58" message is emitted from. I found it in the gnome-desktop source package in libgnome-desktop/gnome-rr.c:444.

Chase Douglas (chasedouglas) wrote :

The libxrandr2 function XRRSetCrtcConfig (called from gnome-settings-daemon through libgnome-desktop) is called twice when I open the lid on my laptop. The second call has an older timestamp value, and thus the xorg xserver is returning RRSetConfigInvalidTime. Now we need to figure out why it's called twice like this.

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → Chase Douglas (chasedouglas)
Chase Douglas (chasedouglas) wrote :

Gnome-settings-daemon is receiving two input events in a very short amount of time from the kernel. The input events are basically fn-F7, or "change my display output configuration". Unfortunately, these events are coming in reverse order, so the timestamps go backwards. The input timestamps are fed to the xserver, which evaluates the first just fine, and then errors out on the second due to the timestamp warping. What we need to do is either:

a. Have g-s-d detect warped timestamps and refuse to continue
b. Have g-s-d detect warped timestamps and set a the timestamp to the previous + 1

I'm testing out a. right first since it's the cleaner approach. I don't think there will be any issues with it, but you never know. I'll test out b. if a. has issues.

affects: linux (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
milestone: none → ubuntu-10.04
Chase Douglas (chasedouglas) wrote :

I've uploaded a fixed version of gnome-settings-daemon to my ppa at ppa:chasedouglas/gnome-settings-daemon. Please test it out by doing the following:

$ sudo add-apt-repository ppa:chasedouglas/gnome-settings-daemon
$ sudo apt-get update
$ sudo apt-get install gnome-settings-daemon

Ensure this install version 2.30.0-0ubuntu3~ppa1. If not, then you may need to wait a bit for the package to finish building and get published to my ppa.

Test it out and then report back here. When you want to remove my ppa, run:

$ sudo apt-get install ppa-purge (if it's not already installed)
$ sudo ppa-purge ppa:chasedouglas/gnome-settings-daemon

Thanks

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → In Progress
Kai Jauch (kaijauch) wrote :

Chase, I tried version 2.30.0-0ubuntu3~ppa1 on a Dell Latitude E6400 with an Intel GM45. The error message ("could not switch configuration [...]") is gone with that version (on both suspend/resume and closing/opening the lid).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.30.0-0ubuntu3

---------------
gnome-settings-daemon (2.30.0-0ubuntu3) lucid; urgency=low

  * Fix handling of fn-F7 (xrandr) when xev timestamp is later than server
    timestamp (LP: #484186)
 -- Chase Douglas <email address hidden> Thu, 01 Apr 2010 22:27:55 +0000

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-settings-daemon:
status: Unknown → New
Changed in gnome-settings-daemon:
status: New → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.