gnome-settings-daemon crashed with SIGSEGV in g_slice_alloc()

Bug #410534 reported by Rami Al-Rfou' on 2009-08-08
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-settings-daemon

this happened after killing pulseaudio which was configured before not to respawn automatically

ProblemType: Crash
Architecture: i386
Date: Sat Aug 8 03:12:09 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
Package: gnome-settings-daemon 2.27.5-0ubuntu2
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SegvAnalysis:
 Segfault happened at: 0x9c9f76 <g_slice_alloc+262>: mov (%edx),%ecx
 PC (0x009c9f76) ok
 source "(%edx)" (0x0000000f) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 g_slice_alloc () from /usr/lib/libglib-2.0.so.0
 g_list_append () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_slice_alloc()
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Rami Al-Rfou' (rmyeid) wrote :

StacktraceTop:IA__g_slice_alloc (mem_size=12)
IA__g_list_append (list=0x0, data=0x8bb5f80)
_gdk_event_queue_append (display=0x8b4e000, event=0x8bb5f80)
_gdk_events_queue (display=0x8b4e000)
gdk_event_dispatch (source=0x8b57f80, callback=0,

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Incomplete
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Invalid
Chascon (chascone) wrote :

I'm getting this same error on an upgrade to 12.10.

Mario Vukelic (mario-vukelic) wrote :

I'm seeing this several times a day in Quantal. I'll try with Valgrind, give me some time ..

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Incomplete
tags: added: quantal
Chascon (chascone) wrote :

I haven't noticed getting this while using pulseaudio,but I usually have vlc open and constantly watching something with audio. The only other common denominator, at least for me, is that I always get this while logged in using OpenBox. It's always after a gnome-settings-daemon error that my theme drops into something resembling Windows 95. I think what's happening is that my these support is dropped. What this has to do with pulse, is beyond me but the error always inculpates the gnome-settings-daemon.

Mario Vukelic (mario-vukelic) wrote :

I ran g-s-d through valgrind for 2 days now, and the issues seems to have happened twice during the night, which is consistent with what I though was my experience without valgrind as well. May have something to do with turning off or locking the screen when the laptop is not in use - there is nothing else happening over night that I know of.

I piped the command through tee in order to also catch g-s-d's own debug log:

G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log gnome-settings-daemon debug | tee gnome-settings-daemon-with-valgrind-debug.log

Both log files are attached

Mario Vukelic (mario-vukelic) wrote :

I forgot to mention that these logs are from one overnight run, I discarded the logs from the first night.

tags: added: amd64
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Mario Vukelic (mario-vukelic) wrote :

Also somehow the dashes in front of the debug option where lost when copying the valgrind command from the terminal. For the sake of correctness her it is again, sorry for spam:

G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log gnome-settings-daemon --debug | tee gnome-settings-daemon-with-valgrind-debug.log

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers