Newest version causes high CPU load when pulseaudio not running

Bug #404340 reported by Anton Kraus on 2009-07-24
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-settings-daemon

This problem appeared after upgrading to version 2.27.4-0ubuntu1.

Gnome-settings-daemon continuously consumes about 50% CPU (on a single-core machine with Hyper-Threading).
Downgrading to gnome-settings-daemon_2.27.3-0ubuntu2 restores normal behaviour.

If I kill the process and then start it in a terminal, it ceaselessly floods the window with the following message:
"** (gnome-settings-daemon:4386): WARNING **: Connection failed, reconnecting..."

ProblemType: Bug
Architecture: i386
Date: Fri Jul 24 23:33:28 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-settings-daemon 2.27.4-0ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.21-generic
SourcePackage: gnome-settings-daemon
Uname: Linux 2.6.31-4-generic i686

Anton Kraus (done) wrote :
Chris Coulson (chrisccoulson) wrote :

Not confirming the issue here. Have you got Pulseaudio running?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
tags: removed: gnome-settings-daemon
Michael Milligan (milli) wrote :

I can confirm I'm seeing the same issue with gnome-settings-daemon after update to 2.27.4-0ubuntu1 WITHOUT pulseaudio installed and running. When I install pulseaudio, pulseaudio-esound-compat, , pulseaudio-module-hal, and pulseaudio-module-x11, then gnome-settings-daemon stops looping and is "happy".

I also was seeing this with gnome-volume-manager and it is no longer looping once pulseaudio daemon is running.

Anton Kraus (done) wrote :

I also have no pulseaudio on my system, so I guess we've found out what causes the problem.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → Confirmed
Daniel Newman (dmnewman) wrote :

Confirmed using gnome-settings-daemon 2.27.4-0ubuntu1 on a 64bit quad-core system without pulseaudio. Killing gnome-settings-daemon fixes the problem, but of course then I only get the standard desktop decorations.

Andreas Brauchli (blk) wrote :

Also confirming that installing pulseaudio (pulseaudio-esound-compat is not required) fixes the loops

WARNING **: Connection failed, reconnecting...
socket(): Address family not supported by protocol

seen in
- gnome-settings-daemon
- gnome-volume-control
- gnome-volume-control-applet

would be nice if it weren't a dependency (alsa works just fine for me; i think of PA only as additional latency / cpu cycles) - or if it needs be, then add it as explicit dependency to these packages (not just to libpulse0 as it stands now).

Sarvatt on IRC also suggested setting /apps/gnome_settings_daemon/plugins/sound/active to no in gconf-editor
that would probably fix the gnome-settings-daemon issue, but not the gnome-volume-control[-applet] one.

Christoph Reiter (lazka) wrote :

Same here. volume applet and settings daemon.

/apps/gnome_settings_daemon/plugins/sound/active to no doesn't fix it.

Chris Coulson (chrisccoulson) wrote :

Disabling the sound plugin probably won't fix it, as it is the media-keys plugin that is using Pulseaudio. (The sound plugin uses it too, but not all the time). gnome-settings-daemon now uses Pulseaudio for setting volume (in exactly the same way that gnome-volume-control-applet does), so if you disable Pulseaudio, your volume keys won't change your audio volume.

summary: - Newest version causes high CPU load
+ Newest version causes high CPU load when pulseaudio not running
Chris Coulson (chrisccoulson) wrote :

This is fixed upstream in GIT already.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.27.90-0ubuntu1

---------------
gnome-settings-daemon (2.27.90-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #413618):
    - Update gnome-volume-control from gnome-media (Bastien Nocera)
      (#589825).
    - Fix crash in gvc_mixer_stream_is_running() (Chris Coulson)
      (#590073).
    - Add '-k' option to syndaemon call for 'Disable touchpad while
      typing' (C de-Avillez) (#590588, LP: #408095).
    - Low disk space warning bug-fixes (Chris Coulson)
      (#591153, LP: #404340).
  * Removed patches that are merged upstream now:
    - 60_ldsm_notification_fixup.patch
    - 62_fix_media_keys_memory_errors.patch
  * Removed 11_sleepkey.patch - there is no key assigned to sleep by
    default and gdm-signal does not exist on the default install.
  * Refreshed patches:
    - 61_fix_volume_notification.patch
    - 70_migrate_touchpad_config.patch
    - 90_autoreconf.patch
  * debian/control:
    - Add versioned build-dep on libpulse-dev (>= 0.9.15).
  * Also fixes LP: #404340.

 -- Chris Coulson <email address hidden> Fri, 14 Aug 2009 15:04:39 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Andrew (andrew-rw-robinson) wrote :

I installed a brand new copy of karmic amd64 and am having this problem after uninstalling pulse audio

gnome-settings-daemon & gnome-media Version: 2.28.1-0ubuntu1

dlocate -s gnome-settings-daemon
Package: gnome-settings-daemon
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 3804
Maintainer: Ubuntu Desktop Team <email address hidden>
Architecture: amd64
Version: 2.28.1-0ubuntu1
Replaces: capplets-data (<< 1:2.21.5), gnome-control-center (<< 1:2.21.5)
Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libcanberra-gtk0 (>= 0.2), libcanberra0 (>= 0.2), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgconf2-4 (>= 2.23.2), libglib2.0-0 (>= 2.18.0), libgnome-desktop-2-11 (>= 1:2.27.3), libgnomekbd4, libgtk2.0-0 (>= 2.16.0), libnotify1 (>= 0.4.5), libnotify1-gtk2.10, libpango1.0-0 (>= 1.14.0), libpulse-mainloop-glib0, libpulse0 (>= 0.9.19), libstartup-notification0 (>= 0.10), libx11-6, libxi6 (>= 2:1.2.0), libxklavier15 (>= 4.0), libxml2 (>= 2.6.27), libxrandr2, libxrender1, libxxf86misc1, zlib1g (>= 1:1.1.4), gconf2 (>= 2.12.1-1)
Recommends: pulseaudio
Conflicts: banshee (<< 0.13.2+dfsg-7), gnome-control-center (<< 1:2.21.5), rhythmbox (<< 0.11.5), totem (<< 2.22.0)
Conffiles:
 /etc/xdg/autostart/gnome-settings-daemon.desktop dc7820767f865052bc9c2d1435000baf
 /etc/gnome/config/Editres.ad 05a3123759008f95ddc2425c822bcfa4
 /etc/gnome/config/Emacs.ad 348fea42a2bc046db8ba8323027d545b
 /etc/gnome/config/General.ad 49682440378a2c7ef52c37ee91f0ba0d
 /etc/gnome/config/Motif.ad 12aca8840f777bcbec2894578141f8e2
 /etc/gnome/config/Tk.ad 0774b17084384112e7e2b5ef3d044b3c
 /etc/gnome/config/Xaw.ad 8b1d2b8fd63d2966d223c36ac56a8081
Description: GNOME settings daemon
 The package contains the GNOME daemon which handles the session settings
Original-Maintainer: Debian GNOME Maintainers <email address hidden>

gnome-volume-control -p playback

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:4601): WARNING **: Connection failed, reconnecting...

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs but open a new bug if you have a similar issue

Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Released
Andrew (andrew-rw-robinson) wrote :

But this closed bug is present again. If I open a new bug, then people mark it as duplicate and why open a new duplicate bug and have to re-repeat all of the info for a new bug when the bug has already been reported?

Sebastien Bacher (seb128) wrote :

because you comment on a closed gnome-settings-daemon bug about an issue you have on gnome-media, the code issue described there was fixed so the cause might be different and using a bug which was about an another codepath can lead to confusion, especially when those issue are about different softwares

hedgehog (hedgehogshiatus) wrote :

I'd like to reopen this bug - properly.
I'm seeing matecity deteriorate and then break after some period of usage.

I've tried reinstalling ubuntu-dektop package and all pulse* packages to no effect.

The strace is after having done all these re-installs.

This will give you some clue about that has broken.

hedgehog (hedgehogshiatus) wrote :

I'd like to reopen this bug - properly.
I'm seeing matecity deteriorate and then break after some period of usage.

I've tried reinstalling ubuntu-dektop package and all pulse* packages to no effect.

The strace is after having done all these re-installs.

This will give you some clue about that has broken.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers