Appearance preferences are being ignored

Bug #395871 reported by vinicius.vbf on 2009-07-05
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

lsb_release -rd:
Description: Ubuntu 9.04
Release: 9.04

Package: ?

After running apt-get upgrade yesterday some of my custom appearance preferences are being ignored.

The window borders looks OK (managed by metacity, I think), but both the GTK and the Panel themes are wrong.
This is happening to all themes in my Ubuntu box.

When I open the "Appearance Preferences" window, the correct GTK and Panel themes are applied for just a second, and then they fall back to the default system theme (I think).

When started from the command line, the "gnome-appearance-properties", just after falling back to the default system theme, the following error messages are displayed:

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 68 character 64: Could not parse "shade/gtk:bg[NORMAL]/0.84" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 69 character 66: Could not parse "shade/gtk:bg[NORMAL]/0.80" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 70 character 67: Could not parse "shade/gtk:bg[NORMAL]/0.78" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 71 character 60: Could not parse "shade/gtk:bg[NORMAL]/0.88" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 72 character 63: Could not parse "shade/gtk:bg[NORMAL]/1.12" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 73 character 60: Could not parse "shade/gtk:bg[NORMAL]/0.56" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 75 character 66: Could not parse "shade/gtk:bg[NORMAL]/0.76" as an integer

(gnome-appearance-properties:9846): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Line 76 character 64: Could not parse "shade/gtk:bg[NORMAL]/0.81" as an integer

As I said before, this is happening to all themes in my machine, even the original Ubuntu ones.

Nikola Yanev (gericom) wrote :

the message displayed to me is:
(gnome-appearance-properties:7830): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
and as you can see in the scr.shot, the theme i use (elementary) is applied only to gnome-appearance-properties, but not at any other program

tags: added: gnome-appearance-properties gtk
Changed in ubuntu:
status: New → Confirmed
Nikola Yanev (gericom) wrote :

updating to gnome-settings-daemon 2.27.4-0ubuntu1 fixes the issue

Changed in ubuntu:
status: Confirmed → Fix Released
status: Fix Released → Confirmed
vinicius.vbf (vinicius-vbf) wrote :

Nikola: Great! But the version 2.27.4 is not available to the Jaunty release.
This is what I get when I try to install the Karmic version of this package (2.27.4) in my box:

Preparing to replace gnome-settings-daemon 2.26.1-0ubuntu2 (using gnome-settings-daemon_2.27.4-0ubuntu1_i386.deb) ...
Unpacking replacement gnome-settings-daemon ...
dpkg: dependency problems prevent configuration of gnome-settings-daemon:
 gnome-settings-daemon depends on libgnome-desktop-2-11 (>= 1:2.27.3); however:
  Version of libgnome-desktop-2-11 on system is 1:2.26.1-0ubuntu2.
 gnome-settings-daemon depends on libgnomekbd4; however:
  Package libgnomekbd4 is not installed.
 gnome-settings-daemon depends on libgtk2.0-0 (>= 2.17.5); however:
  Version of libgtk2.0-0 on system is 2.16.1-0ubuntu2.
 gnome-settings-daemon depends on libpulse-mainloop-glib0; however:
  Package libpulse-mainloop-glib0 is not installed.
 gnome-settings-daemon depends on libstartup-notification0 (>= 0.10); however:
  Version of libstartup-notification0 on system is 0.9-1.
 gnome-settings-daemon depends on libxklavier15 (>= 4.0); however:
  Package libxklavier15 is not installed.
dpkg: error processing gnome-settings-daemon (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gnome-settings-daemon

Paul Larson (pwlars) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-settings-daemon.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
Roy (rdstrac) wrote :

I think my problem is related to this one. I am running 32bit Lucid 10.04 using GNOME 2.30.0 and kernel 2.6.32-22-generic. Since I don't like the default theme I have changed to Human Clearlooks with no visual effects. At seemingly random intervals the screen flickers and the display reverts to the default theme. There are no error messages. Entering 'Appearance Preferences' shows Human Clearlooks is still selected. Clicking on another theme then back on Human Clearlooks resets it but it usually reverts again to the default theme fairly quickly (within a couple of minutes). Restarting the computer will get it to stick for a longer period (~day or more). Computer is a Dell GX-280 P-4.

I also have an HP Q6600 quad running the 64bit version of Lucid that has given no problems.

Roy (rdstrac) wrote :

I guess I spoke too soon. Just had the same problem on the HP Q6600 quad 64 bit. This computer has been running properly since installing Lucid May 1 or 2. The last update was May 12 I believe. Same problem... No Error message; it just decided it didn't like my choice of theme.

The Dell has had the same problem ever since I installed Lucid at about the same time, though before the official release I had run the alpha 1, alpha2 and release candidate on it without seeing this problem

Lucid 10.04, GNOME 2.30.0, kernel 2.6.32-22-generic.

Juan Simón (simonbcn) wrote :
Download full text (9.5 KiB)

I have this problem in Lucid.
I have changed my cursor theme and now it shows the correct theme over some applications (like Firefox) but, in general, the cursor theme used is other that I haven't selected. ¿?
The errors in console when I open "gnome-appearance-properties":
"
(gnome-appearance-properties:25157): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

(gnome-appearance-properties:25157): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 68 carácter 64: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.84» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 69 carácter 66: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.80» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 70 carácter 67: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.78» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 71 carácter 60: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.88» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 72 carácter 63: No se ha podido interpretar «shade/gtk:bg[NORMAL]/1.12» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 73 carácter 60: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.56» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 75 carácter 66: No se ha podido interpretar «shade/gtk:bg[NORMAL]/0.76» como un entero

(gnome-appearance-properties:25158): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Línea 76 carácter 64: No se ha podido i...

Read more...

Robin Stocker (nibor) wrote :

Having the same problem after a fresh install of 10.10 on a new computer. In gnome-appearance-properties, the theme is right (ambience), but in the rest the theme is the Gtk standard theme (a.k.a. the flat ugly one). Starting gnome-appearance-properties only prints the following:

(gnome-appearance-properties:2095): Gdk-CRITICAL **: IA__gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

(gnome-appearance-properties:2095): Gdk-CRITICAL **: IA__gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

Robin Stocker (nibor) wrote :

I believe I've hit bug #649809 (don't know if this is a duplicate).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments