gnome-settings-daemon should keep its opinions about my disk management to itself

Bug #390504 reported by Steve Langasek on 2009-06-22
86
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Wishlist
gnome-settings-daemon (Ubuntu)
Low
Ubuntu Desktop Bugs
Karmic
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-settings-daemon

After a recent upgrade in karmic, gnome-settings-daemon has started giving me dialogs on every login, informing me that two of my disks are "low on disk space" (one is at 97% full, the other at 98% full).

I didn't ask its opinion.

The disks are sized according to my requirements (why should I keep more than 2% overage on a disk whose usage should be stable?) and they're *system* partitions anyway so any non-admin user receiving this message has no control over the situation anyway!

Finally, the dialogs are lacking the standard "never show this message again" interface, so I'm helpless to prevent them from showing up on each new login.

From bug #337441 I gather that this behavior was introduced in jaunty, but that I was unaware of it because the notification was never shown. Now that these notifications come as persistent windows, it's very annoying. Please correct this before the karmic release.

ProblemType: Bug
Architecture: amd64
Date: Mon Jun 22 05:31:33 2009
DistroRelease: Ubuntu 9.10
Package: gnome-settings-daemon 2.27.3-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
SourcePackage: gnome-settings-daemon
Uname: Linux 2.6.30-9-generic x86_64

Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon) wrote :

example screenshot.

Changed in gnome-settings-daemon (Ubuntu Karmic):
importance: Undecided → Medium
Chris Coulson (chrisccoulson) wrote :

Steve,

This behaviour was just introduced in Karmic because this code was never actually compiled in before, due to http://bugzilla.gnome.org/show_bug.cgi?id=584217. I'm currently doing some work on this plugin to implement http://live.gnome.org/LowDiskSpaceWarning. As part of that, I've already made the thresholds configurable so you can globally disable the warning. Perhaps you could add your thoughts to the spec though?

Changed in gnome-settings-daemon (Ubuntu Karmic):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu Karmic):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Medium → Low
Steve Langasek (vorlon) wrote :

A globally configured threshold doesn't address my objections, which are that:

- I should have an option to permanently ignore a given full disk
- I should not be given "full disk" alerts for disks that my user can't actually write to (something that GNOME as a whole should already be able to detect - nautilus knows whether or not there's a trash folder on that disk).

Not creating a wiki login to comment the upstream spec at this time, sorry.

Chris Coulson (chrisccoulson) wrote :

I've sent a patch upstream as part of the work for bug 337441. The patch addresses your first point now, and can be found at http://bugzilla.gnome.org/show_bug.cgi?id=573980

NoahY (noahy) wrote :

I don't think the ability to ignore a "given full disk" is enough... I don't see any need to be warned, for instance, that an sd card from my digital camera is "Low on disk space" in the first place. In fact, I can only see the need for such a warning on drives that are involved in the workings of ubuntu itself, i.e. the partition mounted as "/". I'll check out the patch, though. Thanks for your work on this.

Chris Coulson (chrisccoulson) wrote :

Trustiswithin - I'm one step ahead of you ;)

If you have a look at the spec linked from the Gnome bug I mentioned above and the patch I submitted, you will see that the patch disables checking of anything that's dynamically mounted (ie, your SD card or camera).

NoahY (noahy) wrote :

Cheers, Chris. You guys rock :)

Martin Pitt (pitti) on 2009-07-08
Changed in gnome-settings-daemon (Ubuntu Karmic):
status: Confirmed → Triaged
Malcolm Scott (malcscott) wrote :

In current karmic I'm getting these warnings pop up every minute or so, for a few read-only NFS filesystems. As Steve said, it is useless to provide warnings for filesystems to which the user cannot write (nor indeed can anyone else on the system, in this case). And I'm not sure why they're popping up unreasonably frequently... if you need more info to debug this, let me know.

Changed in gnome-settings-daemon:
status: Unknown → Confirmed
Chris Coulson (chrisccoulson) wrote :

This is now fixed upstream with this commit, and will be in the next version: http://git.gnome.org/cgit/gnome-settings-daemon/commit/?id=8f1e770acb92682d1a5a4b7dd16049155cad2902

Changed in gnome-settings-daemon (Ubuntu Karmic):
status: Triaged → Fix Committed
Dustin Kirkland  (kirkland) wrote :

Any idea when this might be released? This bug is driving me nuts...

:-Dustin

Chris Coulson (chrisccoulson) wrote :

Dustin,

It will be in the 2.27.5 tarball.

Martin Pitt (pitti) wrote :

Chris,

please also note that this very much looks like a notification which was turned into a dialog box by notify-osd because it has an action ("Investigate"). This aggravates the annoyance a lot.

Chris Coulson (chrisccoulson) wrote :

Martin,

That's right. The changes I've made to this plugin actually properly implement a dialog rather than using libnotify, which makes it possible to have a checkbox to disable any further nagging. Here's a screenshot of what the new implementation looks like on my system:

http://bugzilla.gnome.org/attachment.cgi?id=137491&action=view

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.27.4-0ubuntu1

---------------
gnome-settings-daemon (2.27.4-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #401510):
    - Remove screensaver plugin, it's autostarted now
      (Matthias Clasen)
    - Don't take too long in RANDR D-Bus method implementation
      (Federico Mena Quintero)
    - Add support for Synaptics touchpads (Matthias Clasen)
    - Don't spawn more than one syncdaemon (Matthias Clasen)
    - Depend on gnome-desktop >= 2.26.3 (Rodrigo Moya)
    - Update gnome-volume-control code from master (Bastien Nocera)
    - Fix order of arguments to strstr (Federico Mena Quintero)
    - Depend on libxklavier 4.0 (Sergey V. Udaltsov)
    - Remove libglade dependency from media-keys and keyboard plugins
      (Felix Riemann)
  * debian/control{.in}:
    - Bump libgnome-desktop-dev build-dependency.
    - Migrate libxklavier12-dev build-dep to libxklavier-dev and bump
      version requirement.
    - Build-depend on libpulse-dev.
  * Refreshed patches to apply cleanly again.
  * Dropped 07_use_gstreamer_volume.patch to use the Pulseaudio
    volume control rather than the old GstMixer interface.
  * Dropped 08_extra_touchpad_options.patch - fixed upstream now.
  * debian/gnome-settings-daemon.install:
    - Updated to correctly install *.ui files and control-center
      xml file.
  * debian/patches/50_ldsm_notification.patch:
    - Upstream change to implement the new low disk space warning
      (Fixes LP: #337441, LP: #390504 and LP: #396864).
  * debian/patches/60_ldsm_notification_fixup.patch:
    - Fix some bugs in the upstream implementation of the last patch,
      eg, I made the assumption that all mounts with a device node
      not beginning with /dev could be ignored as a way of filtering out
      uninteresting volumes. This is not so, as the GUnixMountEntry for
      the root filesystem can have "rootfs" as the device node, and
      we don't want to filter the root filesystem out.
    - Make sure that no warning is shown for volumes with more than 2GB
      free space by default.

 -- Chris Coulson <email address hidden> Thu, 23 Jul 2009 21:34:51 +0100

Changed in gnome-settings-daemon (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Wishlist
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.