Keyboard 'Custom Shortcut' does not retain environment

Bug #373111 reported by Cédric Jeanneret deactivated on 2009-05-07
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Invalid
Medium
gnome-settings-daemon (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Hello,

I discover a nice thing in Jaunty :

when we launch a shell from a keyboard shortcut (system -> preferences -> keyboard shortcut -> add), I don't have my environment, for example :
- no ssh agent
- I'm not in my home, but in /

When I launch the same terminal from "run application" (std shortcut "alt+F2"), it's working nice.

When I launch the same terminal from some icon in my pannel, it's working fine too.

I tried with those terminals :
- gnome-terminal
- xterm
- urxvtc
- urxvt

Same behaviour for all of them.

System informations :
Description: Ubuntu 9.04
Release: 9.04

ii gnome-terminal 2.26.0-0ubuntu2
ii rxvt-unicode 9.06-1
ii xterm 241-1ubuntu1

Any idea ?

Thanks.

C.

I tried another thing :
as, for me, gnome integrated launcher is a mess [no tab completion!!!!], I tried to use "gmrun", which is really faster, nicer and so on.
But I have exactly the same behavior using gmrun or shortcuts ! NO env, NO ssh-agent [for a sysadmin work, it's.... well, just imagine]...

that's really, really, REALLY annoying.

I see something interesting :
"env" command outputs some nice thing, especially :

[gnome-terminal launched through menu]
GNOME_KEYRING_SOCKET=/tmp/keyring-mNji2A/socket
SSH_AUTH_SOCK=/tmp/keyring-mNji2A/socket.ssh

[gnome-terminal launched through gmrun]
GNOME_KEYRING_SOCKET=/tmp/keyring-mNji2A/socket
SSH_AUTH_SOCK=/tmp/ssh-gvpqNC5125/agent.5125

shouldn't SSH_AUTH_SOCK be the same ?!
When launching a second terminal through the menu, it shows me that it's using the same agent [that's logical...]

so, question is : why is it using a second, unknown agent when it's launched through another mean ??

John Haitas (jhaitas) wrote :

Are you aware that there is already a defined shortcut in the 'Desktop' section named 'Run a terminal'?

The behaviour describe does not occur when you map a shortcut to 'Run a terminal'

I can, however, confirm this behaviour for a new 'Custom Shortcut' launching a terminal program...

I am going to rename this bug and mark it as 'Confirmed'

John Haitas (jhaitas) wrote :

I can confirm this behaviour

Changed in ubuntu:
status: New → Confirmed
summary: - keyboard shortcup and shell
+ Keyboard 'Custom Shortcut' for terminal does not retain environment

assigning to appropriate package and parties

affects: ubuntu → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Sebastien Bacher (seb128) wrote :

the bug should be sent to the software writters on bugzilla.gnome.org

affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
summary: - Keyboard 'Custom Shortcut' for terminal does not retain environment
+ Keyboard 'Custom Shortcut' does not retain environment

Hello,

I discovered this one a bit later after I opened the bug.
Fact is, when we use another launcher than the default one (which has no tab completion...) like gmrun, environment isn't kept as well... so it's not only for "custom shortcuts", and maybe it's the same problem source (gnome-setting-manager).

Thanks for your answers. Should I post it on bugs.gnome.org ?

Regards,

C.

Sebastien Bacher (seb128) wrote :

opening the bug upstream would be nice indeed

Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
status: Unknown → New
John Cooper (choffee) wrote :

This is still happening in the latests lucid beta. Does it have something to do with the startup order that gdm is using?

jepler (jepler) wrote :

still happening in the release version of lucid.

Burkhard Ritter (burkhard) wrote :

Here's a workaround: Using gconf-editor and editing the run_command_* and command_* in /apps/metacity/global_keybindings and /apps/metacity/keybinding_commands, respectively. Keyboard shortcuts created this way will start the applications with the correct environment.

By the way, it seems that the keyboard shortcuts from the "preferences" -> "keyboard shortcut" application are scattered across three different places in gconf: /apps/metacity/, /apps/gnome_settings_daemon/keybindings and /desktop/gnome/keybindings.

Changed in gnome-settings-daemon:
importance: Unknown → Medium
Changed in gnome-settings-daemon:
status: New → Confirmed
Changed in gnome-settings-daemon:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.