volume/brightness notifications are blank (all black)

Bug #331311 reported by Nicolò Chieffo on 2009-02-18
112
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
High
Mirco Müller
notify-osd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: notify-osd

there's no icon and no text in volume notifications!

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: notify-osd 0.8-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: notify-osd
Uname: Linux 2.6.28-8-generic i686

Nicolò Chieffo (yelo3) wrote :
Martin Pitt (pitti) wrote :

Indeed, it worked initially, but not any more. It might have been broken with the new human-icon-theme.

Changed in notify-osd:
status: New → Confirmed
importance: Undecided → High
Mirco Müller (macslow) on 2009-02-19
Changed in notify-osd:
assignee: nobody → macslow
Kenneth Wimer (kwwii) wrote :

Did it initially show the icons? If so, it cannot be a problem with the human icon theme.

I see this message when using the volume keys:
** (notify-osd:13996): CRITICAL **: load_icon: assertion `info' failed

Nicolò Chieffo (yelo3) wrote :

No... since the first release (the one which name was not notify-osd)
they were not shown.
I'm using the 'clearlooks' theme with gnome icons and it's the same

I can confirm that the only thing I see when changing volume is a black box.

Nikola Yanev (gericom) wrote :

same here, 2 days ago the updates installed alsdorf and it worked, but this was transitional pack then today the new updates installed new notify-osd and it shows only black box, it was tested with: metacity - with/without composite and also with compiz, doesnt works.
the strange is that when i use this in terminal: notify-send that *works* or notify-send something , it works. so maybe it is sth. with the icon theme or i dont know, coz only the multimedia keys are not working.
PS: icon theme i use is elementary with murrine & nodoka engines.

Martin Pitt (pitti) wrote :

Patch attached to bug 329245, will upload.

Changed in notify-osd:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.25.90-0ubuntu3

---------------
gnome-settings-daemon (2.25.90-0ubuntu3) jaunty; urgency=low

  * 16_use_synchronous_notifications.patch: Update for new icon names
    in the recent alsdorf -> notify-osd renaming. Fixes brightness
    notifications again. (LP: #331311)

 -- Martin Pitt <email address hidden> Thu, 19 Feb 2009 15:28:55 +0100

Changed in gnome-settings-daemon:
status: In Progress → Fix Released
Changed in notify-osd:
status: New → Invalid
Dana Goyette (danagoyette) wrote :

This is still broken for me, if I use a non-default icon theme (such as Tangerine). The old notification-daemon package worked perfectly fine with all my icons, but for some reason, this new one only seems to like Human -- literally NO other icon themes on my system show anything for it.

1bratek (1bratek) wrote :

After update 20.02.2009 still the same, just blackbox, no icons was changed by me, so there were ones that were assigned by default.

Nikola Yanev (gericom) wrote :

i found that's why coz notify-osd uses the icons fom human-icon-theme only ?!? and doesnt share them under hicolor, so the way is just to copy all of these started with *notification*, or to link them into your icon theme under /home/USER/.icons/icon_theme/24x24/status/ , or in /home/USER/.icons/hicolor/scalable/status,until the developers of the icon theme make something or until the dev's of notify-osd pack makes it to share its theme for all icon themes.

Nikola Yanev (gericom) wrote :

Found better and easier way for newbies :)
just open your favorite icon theme folder, find the file index.theme and there find or add line *Inherits* and add *Human after* ;) it would be something like that: Inherits=gnome,Gnome,GNOME,hicolor,Human
I am attaching the index.theme of theme i use *elementary* an there at 4-Th line I've added Human after hicolor :)
i think it's better decision of copying.

This is clearly not fixed.

Changed in notify-osd:
status: Invalid → Confirmed
Eric Appleman (erappleman) wrote :

Still not fixed. Manual override of inherits does work.

Changed in gnome-settings-daemon:
status: Fix Released → In Progress
status: In Progress → Confirmed

Currently these icons will on display with the human-icon-theme or themes that inherit Human. Making gnome-icon-theme inherit Human will fix this for nearly all icon themes as most already inherit gnome-icon-theme. I think this is the simplest fix as it will only require one patch to maintain.

Please see Bug #334472, debdiff attached.

Changed in gnome-settings-daemon:
status: Confirmed → Fix Released

Surely notify-osd should install its icons like other programs such as Epiphany instead of some hack that requires Human. People using themes that are not gnome-icon-theme or Human won't get the right icons (such as me), or do I not understand theme inheriting.

Also, if Ubuntu wants this system to be used upstream, then this will have to be fixed properly.

Chris Coulson (chrisccoulson) wrote :

Making gnome-icon-theme inherit Human seems very hack-ish, Especially when Human already inherits gnome-icon-theme

@Chris I agree it's hackish, but all inheriting does is look for icons missing in a theme in the listed themes. I don't see how any adverse effect are possible. As a default Ubuntu desktop already includes both themes, this will not pull in any extra dependencies. If for some reason some one wants to uninstall Human, it is only a Recommends for Gnome. They can do so and just have the current behavior.

@Bruce Nearly every icon theme for Gnome already inherits gnome-icon-theme. On my machine, adding an inherit on Human fixes this issue for every theme I have installed (those installed with a default Ubuntu desktop and a number of third party themes). I do not use the Human or Gnome icon themes myself. As far as to why the icons are in the Human theme as opposed to being part of OSD Notify, I can't read the minds of those who made it but I imagine that they wish to eventually get these icons to become a part of the icon theme spec instead of hard coding their specific icons. Using the method I proposed will allow individual themes to add their own notification-* icons if they please. When they do, they will be used instead as soon as the updated theme is installed.

My only motivation is to see the desktop experience not be degraded. Instead of simply criticizing the short comings of the project, I'm attempting to provide a temporary solution. The fix I propose will display the icons for nearly every icon theme used by adding a very minimal patch to only one package. The way I see it, the most correct fix would be for notification-* icons to be added to the icon theming spec and suitable notification-* icons to be submitted to at least Gnome. Once that happens, the patch should be dropped. If that is feasible before the release of Jaunty, then there is no reason to use my patch.

As long as it's only a tempory hack, I don't mind.

I didn't really mean to be quite as nasty above.

Also of note as to why I suggested what I did is that most of the
notification-* icons are not being shipped in the notify-osd package.
They are in human-icon-theme package. If they are added to the
notify-osd package itself, then putting them in hicolor like other
apps do would probably be the best route. I could provide a patch
doing that, but it would mean adding quite a few files to notify-osd.
Either way, it would be nice if someone from the dx-team would
comment.

Kenneth Wimer (kwwii) wrote :

Currently there appears to be problems with notify-osd using the non-ubuntu branded (ie gnome) icons included in the package directly.

Confirmed to be black. Changed to Human theme and they worked. Either this has something to do with missing icons or bad references... But either way the text should show up!

Here's a shot at what seems to be a more appropriate fix. This branch adds all the notification-* icons being shipped with the human-icon-theme to the notify-osd source. It then installs them to the hicolor theme. Please review:

 http://bazaar.launchpad.net/~andrewsomething/notify-osd/331311-bug-fix/revision/207

Response from my merge request:

"Thanks a lot for the effort Andrew, but that approach would just be a temporary fix we need to undo later. These icons belong to the icon-theme proper. Ripping them out and stuffing them in notify-osd is not wise (not to mention that the Tango/GNOME folks would tar and feather us for such a solution :). The remaining icon-set for other themes (GNOME/Tango, hicolor) - to satisfy the new names in the icon-theme namespace - are being worked on right now. We are also discussing this with some of the upstream people responsible vor GNOME- and Tango-icons."

So it sounds like they are planning on submitting icons upstream to GNOME....

This is clearly the ultra-long term solution.

Kenneth Wimer (kwwii) wrote :

We will include the ubuntu-branded icons in the human theme and the non-ubuntu-branded versions (currently gnome icons) in a private hicolor (ie $DATADIR/icons/hicolor/scalable/status). Once gnome/kde icon sets include icons with these newly created names we can consider removing the icons from the notify-osd package directly but until such a time this seems like the only decent way to allow *any* desktop developer to grab the package and have it simply work.

Duane Hinnen (duanedesign) wrote :

HP G60-120us
Hydroxygen icon set
darklooks theme
Architecture: amd64
DistroRelease: Ubuntu 9.04
kernel: 2.6.28-8-generic

notify-osd 0.8-0ubuntu4
gnome-settings-daemon 2.25.90-0ubuntu4

brightness/volume controls result in a black "notification bubble" with no icons or text.

I have attached a screenshot.

Thank you everyone for the hard work being put into the new release.

I think it is a very bad idea to add the notification icons to the high color set. There is a reason it is called high color set. They should be added to the gnome set or it should be the task of the icon designers to make sure their icon set has the appropriate icons...

Kenneth Wimer (kwwii) wrote :

This last comment is simply untrue. There is no given design or style for hicolor icons. Check the specification at freedesktop.org.

David Barth (dbarth) wrote :

released as part of notify-osd-0.9

Changed in notify-osd:
status: Confirmed → Fix Released
Michael Rooney (mrooney) wrote :

So now if you have a different icon theme, dialogs don't appear to show up at all. Not blank dialogs, not the old ones, just no indication of brightness or volume, though the network and other ones seem to show up fine.

If I use Human or Human Clearlooks, everything works as expected. However if I customize either of them to use a gnome-colors icon theme, then I don't get any sort of notification. Is this a different bug or a consequence of the attempt at fixing this one?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers