gnome-settings-daemon could use the new notification service

Bug #329245 reported by David Barth on 2009-02-13
6
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Wishlist
Sebastien Bacher

Bug Description

Binary package hint: gnome-settings-daemon

The new notification service developed by the DX team can display "synchronous" notifications to show feedback bubbles representing the state of the volume mixer.

The attached patch enables the support for this service. It tests at runtime if a compatible notification service is running, and if so, uses it to display volume changes.

David Barth (dbarth) wrote :
James Westby (james-w) wrote :

Hi,

Here's a debdiff that applies against the current jaunty package. After applying it you
need to regenerate the 90_autoreconf patch.

+ if (!strcmp(cap, "canonical-private-1")) {

this is obviously not great, is there any effort to get this capability added to the spec with
a well-known name?

Thanks,

James

James Westby (james-w) wrote :
David Barth (dbarth) wrote :

Thanks for the Jaunty patch James.

About the private capability, it is named "private" because it hasn't yet been discussed on the FD.o list. It should be renamed to something more appropriate once this actually becomes a standard. For the moment, it is our proposal, and I thought it would have been worse to call it a standard capability where it is not the case yet.

Martin Pitt (pitti) wrote :

Seb, can you please review this?

Changed in gnome-settings-daemon:
assignee: nobody → seb128
Sebastien Bacher (seb128) wrote :

I've some comments about the code:

+ if (! notify_get_server_info (&name, &vendor, &version, &specver))

you leak those references

the init function is also not complicated since it only call another function which you could call directly

could you fix those and update the change?

Changed in gnome-settings-daemon:
importance: Undecided → Wishlist
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.25.90-0ubuntu2

---------------
gnome-settings-daemon (2.25.90-0ubuntu2) jaunty; urgency=low

  * debian/control.in:
    - build-depends on libnotify-dev
  * debian/patches/16_use_synchronous_notifications.patch:
    - use synchronous notifications when they are supported
      thanks to the dx-team and James Westby for their work (lp: #329245)

 -- Sebastien Bacher <email address hidden> Tue, 17 Feb 2009 16:39:26 +0100

Changed in gnome-settings-daemon:
status: Confirmed → Fix Released
David Barth (dbarth) wrote :

Additional patch (to apply on top of the other one), so that the daemon uses the right icon names. This patch also adjusts the icon depending on the value of the volume.

Martin Pitt (pitti) wrote :

Uploaded Davids' patch as solution to bug 331311.

David Barth (dbarth) wrote :

Updated version of the patch, to adjust for hints changes in notify-osd-0.9 + improvements to the rendering.

Martin Pitt (pitti) on 2009-03-03
Changed in gnome-settings-daemon:
status: Fix Released → Fix Committed
David Barth (dbarth) wrote :

re-opening with the patch update

Changed in gnome-settings-daemon:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.25.92-0ubuntu3

---------------
gnome-settings-daemon (2.25.92-0ubuntu3) jaunty; urgency=low

  * 16_use_synchronous_notifications.patch: Update for new hint names and
    eject key. Patch by David Barth. (LP: #329245)

 -- Martin Pitt <email address hidden> Tue, 03 Mar 2009 14:58:19 +0100

Changed in gnome-settings-daemon:
status: In Progress → Fix Released
David Barth (dbarth) wrote :

New version of the patch:
 * supports the new hints "x-canonical-*" returned and used by notify-osd; should fix bug #338515
 * new support for the NEXT & PREV media keys

Sebastien Bacher (seb128) wrote :

thank you for your work on the updated change, don't forget to reopen bugs when you have new changes though or open a new bug next time

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

some comments

* your change does:

"-+ g_debug ("the service does not support the 'x-canonical-private-synchronous' capability");
++ g_debug ("the service does not support the 'synchronous' capability");"

is that expected?

running the new version the eject action still don't use notify-osd do I need a new notify-osd codebase?

Sebastien Bacher (seb128) wrote :

the eject action works now after updating notify-osd I will sponsor the change

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.25.92-0ubuntu7

---------------
gnome-settings-daemon (2.25.92-0ubuntu7) jaunty; urgency=low

  * debian/patches/16_use_synchronous_notifications.patch:
    - updated version by David Barth to fix other capability naming issues
      (lp: #329245)

 -- Sebastien Bacher <email address hidden> Wed, 18 Mar 2009 13:21:35 +0100

Changed in gnome-settings-daemon:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers