Hotkeys for Wi-Fi (Fn+F9) and backlight control (Fn+F5) do not work on Samsung NC10

Bug #296489 reported by anwe0212 on 2008-11-10
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
network-manager (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
udev (Ubuntu)
Medium
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Using Samsung NC10 and the are two hotkeys which do not work: fn+f9 for wifi and fn+f5 for backlight control (should set the screen on/off). This is the status in Lucid, on earlier releases, there are other hotheys which are not working too.

Key codes (from the xev command):
wifi (fn+f9):
keycode 246 = (keysym 0x1008ff95, XF86WLAN), state = 0x0

backlight (fn+f5):
keycode 156 = (keysym 0x1008ff41, XF86Launch1), state = 0x0

(there's a small typo in comment 18)

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested at https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

> Method 1

Shows nothing.

> Method 2

> sudo showkey -u | tee -a hotkey-log.txt

There is no -u option in showkey .
If you mean -s .... there is no event when pressing the keys.
But after that the keyboard does not work any more under XWindows.

> Method 3

> Run sudo tail -f /var/log/acpid

There is no /var/log/acpid.

> Method 4

No result

dmi shows

SAMSUNG ELECTRONICS CO., LTD.
NC10
Not Applicable

From dmesg;
[ 631.406391] atkbd.c: Unknown key pressed (translated set 2, code 0x86 on isa0060/serio0).
[ 631.406426] atkbd.c: Use 'setkeycodes e006 <keycode>' to make it known.

pressing Wlan off key.

[ 726.226897] atkbd.c: Unknown key pressed (translated set 2, code 0x84 on isa0060/serio0).
[ 726.226936] atkbd.c: Use 'setkeycodes e004 <keycode>' to make it known.

pressing lcd off key.

[ 786.009266] atkbd.c: Unknown key pressed (translated set 2, code 0x83 on isa0060/serio0).
[ 786.009295] atkbd.c: Use 'setkeycodes e003 <keycode>' to make it known.

pressing battery key.

Any ideas on this?

11 days, still no answer from teej.
Looks like you have no interest in taking ANY actions, as the status is still on "incomplete".

Thanks for nothing, other distris are much quicker than you.
I wish you good luck, you will need it.

Hi there,
May I remind you that triagers and developers have lives of their own and cannot contribute 24/7. I have been extremely busy and have moved recently, therefore I have been unable to look at this, but due to the fact that there should be enough information here to set it as Confirmed I shall do so. This will now be taken on by another triager/developer to look at, and if they require any more information to help in debugging they will need you to provide it.
Thank you.

Also, in regards to the Wifi off in airplanes, hospitals, etc. there are 2 simple options. One is to not use it, as using laptop/electrical equipment in hospitals and airplanes is illegal in mnay countries anyway. Failing that you can always right click the connection icon on the top Gnome bar and disable wireless that way.

FriedChicken (domlyons) wrote :

Isn't this a duplicate of bug #295251?

alain57 (alain57) wrote :

to have the wifi to work, you need :
1 :do the hal fdi modification to map the keys
2 :apply the kernel patch given here https://bugs.launchpad.net/bugs/295251
3: download git wifi-testing kernel (2.6.29)
4: apply a patch from a german guy (you can find it be searching ath5k rfkill )

BUT its still developpment and can be instable

Christophe Olinger (olingerc) wrote :

Am using kubuntu karmic. Only volume and Sleep Fn keys work by default. The others don't.

Christophe Olinger (olingerc) wrote :

Concerning the brightness keys, they do work in Grub, but in kde4 itself they don't. Probably some keybinding stuff. I'm told they do work in gnome.

Kev (ukev) wrote :

I can confirm parts of this bug in karmic rc.

Battery info does WORK.

LCD off/wireless off/Brightness Keys does NOT WORK.

At least the Brightness Keys does not work is a regression because in jaunty, they worked.

Thank you Kev for the Karmic information. Can you provide the information requested at https://wiki.ubuntu.com/Hotkeys/Troubleshooting following the section marked "Step-by-step Troubleshooting" please. Also can you provide the files from the following output, as separate attachments:
udevadm info --export-db > udev-db.txt
dmesg > dmesg.log
sudo lsinput > lsinput.log
xkbcomp -xkb :0 - > xkbcomp.txt
setxkbmap -print > xkbmap.txt
Thank you :)

summary: - Samsung NC10 FN Keys WIFI/Battery/LCD off not working
+ [hotkeys] Samsung NC10 FN Keys WIFI Battery LCD off not working

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Confirmed → Invalid
papukaija (papukaija) wrote :

The brightness controls require BIOS 11CA due to the new graphics system. See https://help.ubuntu.com/community/NC10#Karmic%209.10%20%28in%20development%29 for more information.

papukaija (papukaija) wrote :

The battery (fn+f2) works in Karmic, so the only problem is fn+f9 (wifi).

summary: - [hotkeys] Samsung NC10 FN Keys WIFI Battery LCD off not working
+ [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) not working

I'll provide the requested files and information for this bug soon.

Sorry, the backlight controll (fn+f5) isn't also working.

summary: - [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) not working
+ [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and brightness (fn+f5)
+ not working
papukaija (papukaija) wrote :

Key codes (from the xev command):
wifi (fn+f5):
keycode 246 = (keysym 0x1008ff95, XF86WLAN), state = 0x0

backlight (fn+f5):
keycode 156 = (keysym 0x1008ff41, XF86Launch1), state = 0x0

papukaija (papukaija) wrote :

I have a problem with lsinput:
sudo lsinput > lsinput.log
sudo: lsinput: command not found

papukaija (papukaija) wrote :
papukaija (papukaija) wrote :
papukaija (papukaija) wrote :
papukaija (papukaija) wrote :
papukaija (papukaija) wrote :

The requested information is now provided.

Changed in linux (Ubuntu):
status: Invalid → Confirmed

Brilliant, thank you! Since this bug has enough information provided for a developer to begin work, I'm going to mark it as triaged and let them handle it from here. Thanks again for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
papukaija (papukaija) on 2010-04-10
tags: added: karmic
summary: - [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and brightness (fn+f5)
- not working
+ [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and backlight (fn+f5) not
+ working
summary: - [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and backlight (fn+f5) not
- working
+ [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and backlight control
+ (fn+f5) not working
papukaija (papukaija) on 2010-04-23
tags: added: lucid
papukaija (papukaija) on 2010-06-04
tags: added: hw-specific
tags: added: usability

I tested the 2.6.35rc1-lucid mainline kernel and the results are the follows: FN-F5 is still not working, but fn-f9 disables the network. However, the wlan led does not switch off and more importantly I can not reconnect to the network. So Maverick does not seem to be promising.

papukaija (papukaija) wrote :

Maybe I'm wrong, but I thought that bug 554066 would have fixed this bug.

papukaija (papukaija) wrote :

This seems to be a bug in udev, if not please move back to linux.

description: updated
affects: linux (Ubuntu) → udev (Ubuntu)
summary: - [hotkeys] Samsung NC10 FN Key for WIFI (fn+f9) and backlight control
- (fn+f5) not working
+ Samsung NC10 FN Key for WIFI (fn+f9) and backlight control (fn+f5) not
+ working
TIN (tin-yotanut) on 2010-09-16
description: updated
papukaija (papukaija) on 2010-10-30
tags: added: maverick
papukaija (papukaija) on 2011-05-31
tags: added: natty

The new samsung_laptop kernel module (2.6.39+ ) was supposed to handle (at least) the wifi on/off but it doesn't work.

tags: added: kernel-hotkey oneiric
papukaija (papukaija) wrote :

The above mentioned module might actually fix this bug but there's a significant flickering issue with that (see bug 810093 for details).

Martin Pitt (pitti) wrote :

Very old bug, with the current versions the udev part (correct key codes) should be fixed. If it still does not work, it's a network-manager bug.

Changed in udev (Ubuntu):
status: Triaged → Fix Released
papukaija (papukaija) wrote :

I used a patced kernel to work around bug 810093 and pressing Fn+F9 doesn't switch wireless on/off and Fn+F5 doesn't switch screen on/off.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

papukaija (papukaija) wrote :

The backlight (fn+F5) on/off should be handled by g-p-m.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
papukaija (papukaija) wrote :

... and NM for Fn+F9 (wifi on/off).

affects: linux (Ubuntu) → gnome-power-manager (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

papukaija (papukaija) wrote :

Moved to g-s-d since I'm using Oneiric.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
papukaija (papukaija) on 2011-10-30
affects: gnome-power-manager (Ubuntu) → gnome-settings-daemon (Ubuntu)
papukaija (papukaija) wrote :

I was unable to collect any useful debug info with the documented methods. For g-s-d, I get an error message about invalid parameter:
gnome-settings-daemon --no-daemon --debug &> g-s-d-debug.txt
cat g-s-d-debug.txt:
** (gnome-settings-daemon:3403): WARNING **: Tuntematon valitsin --no-daemon

and for NM all debug output is about AP scan (get_active_ap():) and some wireless quality information (wireless_qual_to_percent()).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
status: New → Confirmed
papukaija (papukaija) on 2012-03-10
tags: added: precise
papukaija (papukaija) on 2012-04-29
tags: removed: karmic kernel-hotkey maverick
description: updated
Thomas Hood (jdthood) wrote :

Is this still a bug in Ubuntu 12.04?

papukaija (papukaija) wrote :

Yes (it's also tagged so). I'll report this to upstream soon.

Thomas Hood (jdthood) on 2012-07-18
summary: - Samsung NC10 FN Key for WIFI (fn+f9) and backlight control (fn+f5) not
- working
+ Hotkeys for Wi-Fi (Fn+F9) and backlight control (Fn+F5) do not work on
+ Samsung NC10
papukaija (papukaija) on 2013-04-11
tags: added: quantal raring
removed: natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers