Ubuntu

"Home Folder" keyboard shortcut does not work

Reported by Sebastian Bergmann on 2008-02-24
34
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

- Fresh installation of Ubuntu Hardy Heron Alpha 5 using the i386 Alternate Install CD on an IBM ThinkPad X60s.
- System installed on an encrypted LVM.

Steps to reproduce:
- Log into GNOME.
- Press CTRL+ALT+H (which I configured as the "Home Folder" keyboard shortcut).
- Nothing happens.

Other keyboard shortcuts such as CTRL+ALT+T (for terminal) and CTRL+ALT+B (for browser) work fine.

tommy (yobbobandana) wrote :

This also happens for me.

Ubuntu 8.04 Alpha 5 + updates (amd64)

steps to reproduce:
* Main Menu > System > Preferences > Keyboard Shortcuts
* set "Home folder" shortcut to anything
expected result: pressing the key combination opens home folder in nautilus
actual result: no effect

Exactly the same problem on 8.04 Alpha 4. Quite annoying / obvious bug that needs to be fixed before the release.

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Arrdee (rdmartin) wrote :

Same problem here. Hardy Alpha 6, didn't work when I upgraded from Gutsy, and didn't work when I did a clean install from an iso.

For what it's worth, Dell XPS M1210 is the system I'm having the issue on. Possible laptop issue?

KIAaze (zohn-joidberg) wrote :

I also confirm the bug on Hardy. :/

Vikesh (vikesh-rambaran) wrote :

Confirmed. It does not work under the beta release of 8.4 either.

[Did work under Ubuntu 6.06 and 7.10]

I use the same shortcuts as Sebastian Bergmann
Interesting ...

PS : Arrdee, it's not a laptop issue as i get it on my desktop as well

endived (endived) wrote :

Confirmed. Did not work in 8.04 Alpha 6 and not in 8.04 Beta after clean install.

Interestingly, I also use the same shortcut CRTL-ALT-H
Have tried other combinations but nothing happens.

Christian Becker (c-becker-88) wrote :

can confirm this bug with newest Hardy packages installed...

David (david-spiraltechnology) wrote :

Also on 8.04 (AMD64) beta with all package updates.
Running on a generic laptop with the Mitac 835H chipset.

Tried several different combinations of shortcuts.
Other keyboard shortcuts (i.e. terminal) work correctly.

forrestcupp (forrestcupp) wrote :

I'm running Hardy beta. Same problem. The other shortcuts work. It doesn't matter what key combination you use for the Home folder, it won't work.

I have the same problem with Hardy beta also.

Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gnome-control-center:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.22.1-0ubuntu1

---------------
gnome-settings-daemon (2.22.1-0ubuntu1) hardy; urgency=low

  * New upstream version:
    - Fix segfault when shutting down the typing break monitor
    - Set window type hint on the volume popup
    - Remove unused properties from actions GUI
    - Reset opacity when removing the timeout
    - Fix handling of child process
    - Add a tool to test media keys
    - Add some profiling code
    - Fix compiler warnings
    - Fix leaks
    - Add more stuff to the configuration summary
    - Don't eat key events
    - Apply keyboard settings on startup (lp: #213111)
    - Make "Home" keybinding work again (lp: #194979)
  * debian/control.in:
    - updated libgnome-desktop requirement
  * debian/patches/09_locate_pointer.patch:
    - dropped distribution change, it was not accepted upstream and they fixed
      similar issues now
  * debian/patches/91_gsd-add-randr-12.patch:
    - updated redhat version
  * debian/patches/92_gsd-xrandr-version-check.patch:
    - new version update

 -- Sebastien Bacher <email address hidden> Mon, 07 Apr 2008 14:50:01 +0200

Changed in gnome-settings-daemon:
status: Fix Committed → Fix Released
KIAaze (zohn-joidberg) wrote :

Well, it's still not working for me... :/

$dpkg -l gnome-settings-daemon
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=============================-=============================-==========================================================================
ii gnome-settings-daemon 2.22.1-0ubuntu1 GNOME settings daemon

I can create a working keyboard shortcut to nautilus using gconf-editor, but this only works for shortcuts not using the windows/super key.

gnome-keybinding-properties doesn't work at all for the "home folder" shortcut.

Windows+d (Mod4+D) works for show desktop ("hide all windows and focus desktop").

KIAaze (zohn-joidberg) wrote :

Ok, after restarting the win+E shortcut I set in gconf-editor works to launch nautilus.
However, shortcuts to the "home folder" in gnome-keybinding-properties still don't work... (win+E works for other stuff there, just like win+D for show desktop)

dlstyley (deaston) wrote :

I have this problem as well. I have gnome-settings-daemon 2.22.1-0ubuntu2 installed.

I know it sounds like low priority, but this is pretty annoying piece of the user interface and I have to believe a reasonably easy fix. Maybe someone can share a workaround that makes it less severe.

@zoidberg: can you give details on your workaround through gconf-editor? Where is the key that you have to set and what syntax do you use to tell it to use the "Windows Key"?

Solution 1:
========
1)System->Preferences->Keyboard->Layout->Other options
Alt/Win key behaviour: Select "Meta is mapped to the Win-keys"

2)System->Preferences->Keyboard shortcuts
Select "Home folder" and press the desired key combination.

It should show "Mod4+E" for win+E for example.

Solution 2:
========
1)Run "gconf-editor"

2)Navigate to "/apps/metacity/global_keybindings"
Change the value of "run_command_1" to "<Super>E"

3)Navigate to "/apps/metacity/keybinding_commands"
Change the value of "command_1" to "nautilus"

(This will only work if Alt/Win key behaviour is set to "Default" or "Super is mapped to Win-keys". See solution 1 and adapt as necessary.)

Solution 3 (Same as previous by command-line):
====================================
gconftool-2 --type string --set /apps/metacity/global_keybindings/run_command_1 '<Super>E'
gconftool-2 --type string --set /apps/metacity/keybinding_commands/command_1 'nautilus'

P.S: I incidentally just discovered another gconf entry of interest while searching for the command-line syntax:
/apps/panel/global/menu_key
http://docsun.cites.uiuc.edu/sun_docs/C/solaris_9/SUNWgndoc/GNOMEADMIN/p5.html

Very interesting. :)

dlstyley (deaston) wrote :

Solution 1 didn't work for me (that's the bug - mapping Home Folder has no effect)

Solution 2 did work for me, but had a little trouble - maybe just restarting X would have worked first try, but I got myself off in the weeds. While I was messing with this, I noticed that Compiz sets Win+E to "Expo" by default. In addition to this being broken in the Keyboard Shortcuts config dialog (it just said "E" for the "Expo" key), it brought up another issue - wouldn't Metacity and Compiz keyboard shortcuts potentially conflict with "Keyboard Shortcuts" and really confuse a user on what takes precedence. Seems like there may be some integration issues that need to be worked out there.

Anyway, sorry for getting off track. Thanks for the workaround!

KIAaze (zohn-joidberg) wrote :

Ah yes, I forgot to mention I'm using Intrepid without compiz.
The bug doesn't appear for me in that case.

I agree that having multiple places where keyboard shortcuts are
defined is a bit confusing and I have no idea which shortcuts are
prioritary (maybe there isn't any priority and it does expo + nautilus
at the same time ^^).

On 9/19/08, dlstyley <email address hidden> wrote:
> Solution 1 didn't work for me (that's the bug - mapping Home Folder has
> no effect)
>
> Solution 2 did work for me, but had a little trouble - maybe just
> restarting X would have worked first try, but I got myself off in the
> weeds. While I was messing with this, I noticed that Compiz sets Win+E
> to "Expo" by default. In addition to this being broken in the Keyboard
> Shortcuts config dialog (it just said "E" for the "Expo" key), it
> brought up another issue - wouldn't Metacity and Compiz keyboard
> shortcuts potentially conflict with "Keyboard Shortcuts" and really
> confuse a user on what takes precedence. Seems like there may be some
> integration issues that need to be worked out there.
>
> Anyway, sorry for getting off track. Thanks for the workaround!
>
> --
> "Home Folder" keyboard shortcut does not work
> https://bugs.launchpad.net/bugs/194979
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Unlock your computing: http://www.getgnulinux.org/

Mephisto (ferrylandzaat) wrote :

Weird how the comments ended back in 2008, cause it's still not working for me, so obviously the bug is still here.
I'm on 9.10 and setting any key to Home Folder doesnt work. I defined a custom hotkey in the gnome prefs and set it to "nautilus --no-desktop". Running this command from a terminal makes a file browser pop up, showing the homedir. Running the custom hotkey does nothing, even though obviously the command gets run, since i get messages in .xsession-errors:
(nautilus:14531): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

This message doesnt seem related to the problem, since i also get it in the terminal, and seems harmless for the operation. It has already been reported here: https://bugzilla.gnome.org/show_bug.cgi?id=598918. I just listed it to show that nautilus does get launched when using the hotkey, it just does not open any window.

Other keys work fine (like terminal and mail).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.