Media keys stop working due to missing service file

Bug #1832374 reported by Bruce Pieterse on 2019-06-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Unknown
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Disco
Undecided
Unassigned

Bug Description

* Impact
Sometime multimedia keys stop working

* Test case
- start playing an audio file in VLC/totem/smplayer
- pause
- open a video in another player
- exit the other player
- try to resume the music play from the first one using the play key

-> it should work

* Regression potential
Make sure that multimedia play/pause keys keep working

----------------------------------

Over the last two releases I've noticed that if you have an audio player such as Clementine running, pause the audio playback and watch a video via VLC or SMPlayer and then close the video player and try to use the media keys again, the following is logged to journald:

gsd-media-keys[2607]: Error calling method GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.mpris.MediaPlayer2.smplayer was not provided by any .service files.

From what I can see is that a service file is created for the media keys for SMPlayer, when SMPlayer is closed that service file is removed and then media keys are still bound to that service.

I get the above output for previous track, stop, play, pause and next track media keys.

I do get the following output if neither is SMPlayer or Clementine is running or if Clementine is running and playing audio and SMPlayer is open, but no video is loaded:

org.gnome.Shell.desktop[2480]: Window manager warning: Overwriting existing binding of keysym ffb5 with keysym ffb5 (keycode 54).
org.gnome.Shell.desktop[2480]: Window manager warning: Overwriting existing binding of keysym 31 with keysym 31 (keycode a-e,12,f,10,11) <-- I collapsed the range into a comma separated list

If you re-open SMPlayer and load a video, the media keys work and the GDBus error doesn't occur but the above "Overwriting ..." messages still get logged. Closing SMPlayer again does not restore media keys so that Clementine can handle them. I had SMPlayer running ~17 hours ago.

Doing a shell reload doesn't seem to fix this either.

I can't really tell if this is an SMPlay/VLC/Video Player issue or actually an issue in GSD, so filing here until someone can reassign to the relevant project.

I hit this a while ago, while trying to get some debugging information for a Clementine bug: https://github.com/clementine-player/Clementine/issues/6320

If you need any other information let me know.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: gnome-settings-daemon 3.32.0-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-16.17-generic 5.0.8
Uname: Linux 5.0.0-16-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Jun 11 17:36:07 2019
InstallationDate: Installed on 2019-02-01 (129 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20181202)
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to disco on 2019-04-09 (63 days ago)

Bruce Pieterse (octoquad) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you also send it upstream on https://gitlab.gnome.org/GNOME/gnome-settings-daemon/issues ?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Bruce Pieterse (octoquad) wrote :

Hi Sebastian,

This issue was partially fixed in GSD 3.30.2. See https://gitlab.gnome.org/GNOME/gnome-settings-daemon/issues/45

Changed in gnome-settings-daemon:
status: Unknown → New
Changed in gnome-settings-daemon:
status: New → Fix Released
Bruce Pieterse (octoquad) wrote :

According to upstream, the fix is in 3.32.1 not in 3.32.0.

Sebastien Bacher (seb128) wrote :

Thanks for reporting it upstream, they haven't rolled out an update with the fix yet but they will do it now

Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.32.1-1ubuntu1

---------------
gnome-settings-daemon (3.32.1-1ubuntu1) eoan; urgency=medium

  * New upstream version
    Media-keys:
    - Fix MPRIS issues with disconnecting clients (lp: #1832374)
  * Merge with Debian. Remaining changes:
    + debian/control.in:
      - Build-depend on accountsservice
    + debian/patches:
       - 45_suppress-printer-may-not-be-connected-notification.patch
       - 53_sync_input_sources_to_accountsservice.patch
       - 64_restore_terminal_keyboard_shortcut_schema.patch
       - correct_logout_action.patch
          display the logout action on ctrl-alt-del
       - ubuntu-lid-close-suspend.patch
          Reimplement support for setting lid close suspend actions
       - revert-wacom-migration.patch
       - revert-gsettings-removals.patch
          Revert gsettings keys that were dropped since 3.8, for u-s-d
       - revert-mediakeys-dbus-interface-drop.patch
       - ubuntu_ibus_configs.patch
       - git_binary_encoding.patch
       - ubuntu_calculator_snap.patch
    + debian/gnome-settings-daemon.install:
      - Install apport hook
  * debian/patches/*: Refresh

gnome-settings-daemon (3.32.1-1) experimental; urgency=medium

  * New upstream release

 -- Sebastien Bacher <email address hidden> Wed, 19 Jun 2019 15:48:01 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
description: updated

Hello Bruce, or anyone else affected,

Accepted gnome-settings-daemon into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.32.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-settings-daemon (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco

All autopkgtests for the newly accepted gnome-settings-daemon (3.32.1-0ubuntu1) for disco have finished running.
There have been regressions in tests triggered by the package. Please visit the sru report page and investigate the failures.

https://people.canonical.com/~ubuntu-archive/pending-sru.html#disco

Bruce Pieterse (octoquad) wrote :

This patch works as expected:

gnome-settings-daemon:
  Installed: 3.32.1-0ubuntu1
  Candidate: 3.32.1-0ubuntu1
  Version table:
 *** 3.32.1-0ubuntu1 100
        100 /var/lib/dpkg/status
     3.32.0-1ubuntu1 500
        500 http://za.archive.ubuntu.com/ubuntu disco/main amd64 Packages

tags: added: verification-done-disco
removed: verification-needed-disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.