Dell XPS 13 9380 - Screen brightness flashes

Bug #1827790 reported by Daniel C on 2019-05-05
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

I have a new 2019 Dell XPS 13 (9380). I ordered the official Ubuntu edition from Dell which came with 18.04, but I've since wiped it and installed 19.04 from a fresh ISO download. This is the non-touch non-4K version (13-inch 1080p).

Every so often (maybe a couple of times per minute), the screen flashes brighter, as if the brightness has been turned up momentarily and then back down again.

I previously had an issue with the brightness / colours changing slightly when I opened menus or if the screen content changed slightly, but I fixed that by disabling Dynamic Brightness in the BIOS. It is definitely a better experience with that turned off.

However the screen flashing still persists.

I booted a live image of Fedora 30 now that it has been released, and so far I have not seen the screen flashing, so I do not think the hardware is faulty.

I ran apport-bug, so hopefully the collected information has been attached.

Thank you.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sun May 5 15:59:45 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation UHD Graphics 620 (Whiskey Lake) [8086:3ea0] (prog-if 00 [VGA controller])
   Subsystem: Dell UHD Graphics 620 (Whiskey Lake) [1028:08af]
InstallationDate: Installed on 2019-04-28 (6 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
MachineType: Dell Inc. XPS 13 9380
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-13-generic root=UUID=fcb75d61-4e46-4391-8800-ccef7ff04f70 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/29/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.3.2
dmi.board.name: 0KTW76
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.3.2:bd03/29/2019:svnDellInc.:pnXPS139380:pvr:rvnDellInc.:rn0KTW76:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 13 9380
dmi.product.sku: 08AF
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.97-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.0.2-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Daniel C (djcater) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1826125, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

mactyr (mcohen) wrote :

I have some doubt that this is a duplicate of bug 1826125, though I see how they are similar. I'm experiencing the same issue described in this bug, and the visual effect is quite different than the photos and videos attached to the other bug. In the other one, the issue appears to involve different parts of the display flickering around, or different parts of the screen getting "out of sync" so it looks like there are horizontal bands. The problem in the other bug is also described as quite frequent/constant.

I'm not experiencing any of that, but I am experiencing what Daniel C describes in this bug: my entire screen flashes quite brightly for a split second, then calms back down. The effect is uniform across the screen, there's no banding or shifting that I can see. It only happens once every few minutes, not constantly as described in the other bug. The flashing is most noticeable when the "Night Light" effect is active in the evening, though I believe I've also seen it happen during the day.

One other important distinction: like Daniel C, I have an XPS 9380 with the non-touch 1080p display, and I wiped Dell's pre-installed 18.04 and installed 19.04 instead. The other bug has several references in the comments to it affecting the XPS 9380 with the "4k" display. So I believe the flashing described in this bug is a different problem with a different panel.

Daniel C (djcater) wrote :

I agree with mactyr that this should not be a duplicate of that bug. The flaw that I see is not what is shown in those videos. There is no glitching, it is the whole screen flashing brighter, and is why I used the word "flashes" in the title, as opposed to "flickers" or "glitches".

brandon_s (purkinje) wrote :

I agree with djcater and mactyr that this does not seem to be a duplicate. My screen flashes every several minutes.

brandon_s (purkinje) wrote :

I should probably note that I am also using the non-touch non-4K version (13-inch 1080p) screen with a clean install of 19.04. The "flash" does not appear if the Ubuntu image provided by Dell (18.04) is installed and then upgraded to 19.04. However it does occurs when 19.04 is clean installed via the Ubuntu ISO downloaded from canonical. The flash is much more obvious/annoying when the display is in "Night Light" mode.

Daniel C (djcater) wrote :

On the basis of 3 of us deeming that the symptoms of the other bug are different to the ones described in this bug, I have removed the duplicate link. I hope that's OK.

If it helps narrow it down, it seems that we all have the non-touch 1080p version, and all notice it much more when Night Light is enabled.

Daniel van Vugt (vanvugt) wrote :

Does the problem occur in only Xorg sessions ("Ubuntu") or Wayland too ("Ubuntu on Wayland")?

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
summary: - Dell XPS 13 9380 - Screen flashes
+ Dell XPS 13 9380 - Screen brightness flashes
mactyr (mcohen) wrote :

Thanks for the inquiry, vanvugt. I'm trying an Ubuntu on Wayland session this evening and the brightness flashing has continued with about the same frequency.

affects: mutter (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
affects: xorg-server (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Thomas SIMON (dev.uhuru) wrote :

Hello all, I believe that I have this same bug, also after a 19.04 fresh install. I initially posted on that bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1826125 but they kindly directed me here.

Of note, I am glad you tried wayland as I wanted to try if that made any difference. I have tried passing different kernel parameters (though not all combinations) namely:

First try: i915.edp_vswing=2
Second try: i915.fastboot=1 i915.edp_vswing=1 i915.preliminary_hw_support=1 intel_idle.max_cstate=1 acpi_backlight=vendor acpi.osi=Linux (see https://www.reddit.com/r/linuxquestions/comments/ayi4n6/flickering_on_laptops_with_a_4k_screen_and_intel/) but that did not seem to make any difference apart from disabling the backlight controls

It somewhat feels good to have that identified as a bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Thomas SIMON (dev.uhuru) wrote :

I have also been trying to see what are the packages difference between the OEM version and 19.04 since I suspect that Dell might have addressed this issue in their version. I have a list of all packages that were on the OEM but that might be tedious. If we contacted Dell directly, would they be able to help narrow it down / provide packages that they set up on the OEM?

Thomas SIMON (dev.uhuru) wrote :

So it seems that it does away with the following kernel option: i915.enable_psr=0

It seems from some Dell user forum that some have had the same issues on Windows and disabling the panel self refresh worked for them so I was searching along these lines.

I'm certain it's not a "clean" fix however to deactivate a measure that's suppose to save battery.

Kai-Heng Feng (kaihengfeng) wrote :

Thomas, if it's PSR related, please test the kernel here:
https://bugzilla.freedesktop.org/show_bug.cgi?id=110511#c25

Brad Figg (brad-figg) on 2019-07-24
tags: added: ubuntu-certified
Thomas SIMON (dev.uhuru) wrote :

Thanks & sorry for belated response. I've never manually installed a new kernel (and am not sure how to proceed about checking integrity, etc.). Is there any resource you'd advice to get info on the topic? Thanks in advance. For now I can confirm that since I added this to the kernel options, I have had 0 occurrences of the bug over the last 3 weeks.

Kai-Heng Feng (kaihengfeng) wrote :

Download all the debs to a new directory, then
$ sudo dpkg -i *deb
$ sudo reboot

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid
Thomas SIMON (dev.uhuru) wrote :

Hello, thanks for your reply. I have tested that kernel and I did not notice any such problem!

brandon_s (purkinje) wrote :

I followed these steps and the screen still flickers.

1) Downloaded the kernel linked to here into a new directory:
https://bugzilla.freedesktop.org/show_bug.cgi?id=110511#c16

2) sudo dpkg -i *deb

3) sudo reboot

Have I correctly installed the new kernel?

$ uname -a
Linux XPS-13-9380 5.1.0-rc5+ #10 SMP Mon May 27 15:43:20 EEST 2019 x86_64 x86_64 x86_64 GNU/Linux

brandon_s (purkinje) wrote :

I have now followed the same steps for the kernel linked to below and already see flickering.
https://bugzilla.freedesktop.org/show_bug.cgi?id=110511#c25

Janne Alatalo (jaltalo) wrote :

Hi, I also have this bug on my XPS-13-9380 with the 1080p screen. I tried to install the patched kernel that was linked above, but unfortunately the screen still flashes occasionally. The patch might have helped a little bit, but I'm not sure. It feels like the flashes are more rare, and maybe not so bad as previously, but they are still definitely there.

The kernel I tested, was the one that Kai-Heng Feng linked here:
https://bugzilla.freedesktop.org/show_bug.cgi?id=110511#c25

I'm running Ubuntu 18.04, if that makes any difference. And I also use the "Night Light" feature that makes the flashing super noticeable and annoying.

Ben Bromley (benuski) wrote :

I am running Ubuntu 19.04 with an XPS 13 9380 with Intel graphics. I installed the kernel mentioned above, and the problem is still occurring. I do a dmesg everytime I see it happen, but I don't see a consistent message every time it happens. I am more than willing to do any and all testing you all need, so if you think of something I could do to further investigate, let me know!

Ben Bromley (benuski) wrote :

I ran "journalctl --user" after the last flicker and this is the output from the time around the flicker

Sep 12 20:12:34 shadeball org.gnome.Shell.desktop[5959]: [1:1:0912/201234.077664:ERROR:child_process_sandbox_support_impl_linux.cc(81)] FontService unique font name matching request did not receive a response.
Sep 12 20:12:34 shadeball org.gnome.Shell.desktop[5959]: [1:1:0912/201234.078033:ERROR:child_process_sandbox_support_impl_linux.cc(81)] FontService unique font name matching request did not receive a response.
Sep 12 20:12:34 shadeball org.gnome.Shell.desktop[5959]: [1:1:0912/201234.084532:ERROR:child_process_sandbox_support_impl_linux.cc(81)] FontService unique font name matching request did not receive a response.
Sep 12 20:12:34 shadeball org.gnome.Shell.desktop[5959]: [1:1:0912/201234.084847:ERROR:child_process_sandbox_support_impl_linux.cc(81)] FontService unique font name matching request did not receive a response.

I can post the full multi-day output of journalctl --user if that would be useful to you all.

Ben Bromley (benuski) wrote :

Another error message from a flicker

Sep 12 20:28:01 shadeball org.gnome.Shell.desktop[5959]: [6514:6514:0912/202801.632870:ERROR:gl_surface_presentation_helper.cc(259)] GetVSyncParametersIfAvailable() failed for 1280 times!

Ben Bromley (benuski) wrote :

But just to confirm, I think the patched kernel did improve the amount of flickering.

Kai-Heng Feng (kaihengfeng) wrote :

OK, I think your bug is about auto screen brightness instead of PSR. Can you please disabe it?

Ben Bromley (benuski) wrote :

Alright, here we go.

I have the kernel listed above installed: Linux shadeball 5.2.0-9-generic #10~bfo110511 SMP Tue Jul 16 13:17:28 CST 2019 x86_64 x86_64 x86_64 GNU/Linux

I then went into the Power settings and turned Dim Screen When Inactive to off, Blank Screen to Never and so far there have been basically no flickers. There may have been one or two, but I can't confirm that I saw them and cannot reproduce them.

I have tried it both on AC power and on battery, and with success on both.

Thank you so much!

Ben Bromley (benuski) wrote :

I also hit Fn-A, which I saw somewhere (sorry to not have the link) that would disable adaptive brightness.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.