gsd-rfkill-manager fails to receive rfkill event

Bug #1797322 reported by ethan.hsieh on 2018-10-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

The default encoding for GIOChannel is UTF-8, but rfkill event is binary data. gsd-rfkill-manager will fail to receive rfkill event if rfkill-idx is larger than 127.

Settings will always shows Bluetooth is off after resume.

The solution is to set the encoding of GIOChannel as NULL (binary data).

[Test Case]

1) Enable the -proposed repository, and install new "gnome-settings-daemon-schemas" and "gnome-settings-daemon"

2) Reboot system

3) Run suspend/resume test more than 127 times and then check if BT settings still works well.

[Regression Potential]

Low. The default encoding for GIOChannel is wrong. Just set correct encoding to receive rfkill event.

---

The default encoding for GIOChannel is UTF-8, but rfkill event is binary data. If the value is invalid UTF-8, gsd-rfkill-manager will fail to receive rfkill event.

Steps: Run suspend/resume Test (> 127 times)
Failure Rate: 100%

In some platforms, bt will be re-probed after s3. If bt is re-probed, rfkill-idx will increase. And, 128 is the first invalid UTF-8

$ rfkill list
ID TYPE DEVICE SOFT HARD
1 wlan phy0 unblocked unblocked
128 bluetooth hci0 unblocked unblocked

Error Message:
gnome-settings-daemon/plugins/rfkill/rfkill-glib.c
gsd-rfkill[2062]: event_cb: 1 g_io_channel_read_chars
gsd-rfkill[2062]: g_io_channel_fill_buffer: cur_len=0, read_size=8
gsd-rfkill[2062]: g_io_channel_read_chars: 5 *bytes_read=8
gsd-rfkill[2062]: event_cb: 1 read=8
gsd-rfkill[2062]: event_cb: 1 source->read_buf->len=0
gsd-rfkill[2062]: event_cb: 1 source->encoded_read_buf->len=0
gsd-rfkill[2062]: RFKILL event: idx 127 type 2 (BLUETOOTH) op 1 (DEL) soft 0 hard 0
gsd-rfkill[2062]: event_cb: 2 g_io_channel_read_chars
gsd-rfkill[2062]: event_cb: 2 read=0
gsd-rfkill[2062]: event_cb: 2 source->read_buf->len=8
gsd-rfkill[2062]: event_cb: g_list_length=1
gsd-rfkill[2062]: Removed Bluetooth rfkill with ID 127
gsd-rfkill[2062]: event_cb: 1 g_io_channel_read_chars
gsd-rfkill[2062]: event_cb: 1 read=0T
gsd-rfkill[2062]: event_cb: 1 source->read_buf->len=16
gsd-rfkill[2062]: event_cb: g_list_length=0

ethan.hsieh (ethan.hsieh) wrote :
ethan.hsieh (ethan.hsieh) wrote :

Have sent a merge request to GitLab and wait for approval.
https://gitlab.gnome.org/GNOME/gnome-settings-daemon/merge_requests/57

Sebastien Bacher (seb128) wrote :

Thanks, don't forget to subscribe ubuntu-sponsors when you have a patch that needs to be reviewed/sponsored, I'm subscribing that team for you now

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for your work

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

Upload to cosmic, it would probably be a good candidate for a bionic SRU which I guess the oem team is going to want? If so could someone adapt the description to be SRU compliant (https://wiki.ubuntu.com/StableReleaseUpdates) with impact/test case/regression potential sections.
The description has details but lack an user visible description of the error (is it that e.g bluetooth or wifi fails to be restored after resume?)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.30.1.2-1ubuntu2

---------------
gnome-settings-daemon (3.30.1.2-1ubuntu2) cosmic; urgency=medium

  * debian/patches/git_binary_encoding.patch:
    - backport fix from upstream to resolve suspend/resume rfk issues
      (lp: #1797322)

 -- Sebastien Bacher <email address hidden> Thu, 11 Oct 2018 16:27:17 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
ethan.hsieh (ethan.hsieh) wrote :

Thanks for your reminder. Bug description has been updated.

description: updated
description: updated
Changed in oem-priority:
status: New → Confirmed
ethan.hsieh (ethan.hsieh) wrote :

@Sebastien

The patch has been merged. Could you help to land it to bionic? Thanks~

commit a5514ae097e5881df3ef26c63f4f4652b3f77811
Author: Ethan Hsieh <email address hidden>
Date: Tue Oct 9 10:28:31 2018 +0800

    rfkill: set encoding as NULL

    The default encoding for GIOChannel is UTF-8, but rfkill event is binary
    data. If the value is invalid UTF-8, gsd-rfkill-manager will fail to
    receive rfkill event.

Sebastien Bacher (seb128) wrote :

uploaded to the bionic SRU queue now

tags: added: somerville
Changed in oem-priority:
importance: Undecided → High

Hello ethan.hsieh, or anyone else affected,

Accepted gnome-settings-daemon into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.28.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-settings-daemon (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
ethan.hsieh (ethan.hsieh) wrote :

@Brian
The issue is gone after upgrading gnome-settings-daemon to 3.28.1-0ubuntu1.1.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gnome-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.28.1-0ubuntu1.1

---------------
gnome-settings-daemon (3.28.1-0ubuntu1.1) bionic; urgency=medium

  * debian/patches/git_binary_encoding.patch:
    - backport fix from upstream to resolve suspend/resume rfk issues
      (lp: #1797322)

 -- Sebastien Bacher <email address hidden> Tue, 23 Oct 2018 17:11:07 +0200

Changed in gnome-settings-daemon (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers