changing keyborad brightness doesn't work

Bug #1788021 reported by Vilgot Fredenberg on 2018-08-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

Checking 'journalctl' I get this error message:
<date> <hostname> gsd-power[1924]: gsd_power_backlight_abs_to_percentage: assertion 'max > min' failed
Running on an Asus UX490UA (7th-gen Intel CPU), and before upgrading to 18.10 everything worked fine

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: gnome-settings-daemon 3.29.90.1-1~ubuntu1
ProcVersionSignature: Ubuntu 4.17.0-7.8-generic 4.17.12
Uname: Linux 4.17.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Aug 20 21:22:13 2018
InstallationDate: Installed on 2018-08-15 (5 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to cosmic on 2018-08-20 (0 days ago)

Vilgot Fredenberg (nicememe123) wrote :
information type: Public → Public Security
information type: Public Security → Public

Same problem on an Asus UX331U. In Ubuntu 18.04 setting kbd backlight worked, it's broken in Ubuntu 18.10.

Oct 1 17:43:19 avis gsd-power[2143]: gsd_power_backlight_abs_to_percentage: assertion 'max > min' failed

i am able to manually control the backlight on the shell using
sudo tee /sys/class/leds/asus\:\:kbd_backlight/brightness <<< 3

(replace 3 with [0..3] for brightness levels)

-----------------------------------

rephlex@avis:[/proc]: ls /sys/class/leds/
asus::kbd_backlight asus::lightbar asus-wireless::airplane input4::capslock input4::numlock input4::scrolllock phy0-led

-----------------------------------
root@avis:/sys/class/backlight# ls -la /sys/class/backlight/intel_backlight
lrwxrwxrwx 1 root root 0 Okt 1 17:44 /sys/class/backlight/intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

root@avis:/sys/class/backlight# ls -la /sys/class/backlight/
insgesamt 0
drwxr-xr-x 2 root root 0 Okt 1 17:44 .
drwxr-xr-x 70 root root 0 Okt 1 17:40 ..
lrwxrwxrwx 1 root root 0 Okt 1 17:44 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight
------------------------------------

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed

Using Mainline Kernel 4.19.0 or above, it works. So it's a bug in the Ubuntu 18.10 Kernel Version.

Maybe it's this 4.19 patch.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=61c4fc1eaf736344904767d201b0d4f7a2ebaf79

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers