17.10: No input method for CJK languages

Bug #1719938 reported by Jean-Baptiste Lallement on 2017-09-27
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
gnome-initial-setup (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned
Artful
High
Unassigned

Bug Description

After an installation in Chinese there is no input method activated and no way to enter Chinese characters.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Sep 27 11:29:53 2017
InstallationDate: Installed on 2013-09-03 (1484 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Jeremy Bicha (jbicha) on 2017-09-27
summary: - No input method for CJK languages
+ 17.10: No input method for CJK languages
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1719938

tags: added: iso-testing
Will Cooke (willcooke) on 2017-09-27
Changed in ubiquity (Ubuntu Artful):
assignee: nobody → Sebastien Bacher (seb128)
tags: removed: rls-aa-incoming
Gunnar Hjalmarsson (gunnarhj) wrote :

I could reproduce this with the 2017-09-26 ISO.

$ cat /etc/default/keyboard
XKBLAYOUT=se
BACKSPACE=guess
$ gsettings get org.gnome.desktop.input-sources sources
[('xkb', 'se')]

However, IBus was up and running (as it should be for all users) and the necessary input methods had been installed. Hence I could go to "Region & Language", add the "Chinese (SunPinyin)" input source, switch to it, and instantly start typing Chinese characters.

But I suppose the idea is that some Chinese input method should be enabled to start with...

Sebastien Bacher (seb128) wrote :

@Gunnar, here on an updated artful system only "chinese" is listed in the gnome-control-center interface, not "chinese (sunpinyin)" (after installing the chinese support from language-selector). The shell UI lists "chinese zh" but selecting it doesn't give access to ibus input method nor the completion UI and typing just gives a qwerty layout

ibus-sunpinyin is installed but in ibus-setup the input tab only lists french so it looks like ibus didn't get correctly setup by GNOME when selected

Gunnar Hjalmarsson (gunnarhj) wrote :

@Sebastien: What if you click "Chinese" in the input source GUI, then doesn't it expand to the actual input methods available? (That's what happened for me.)

Gunnar Hjalmarsson (gunnarhj) wrote :

Btw, I think you need to relogin (or possibly reboot) after having installed the Chinese language support, if those packages were not installed by the installer.

Jean-Baptiste Lallement (jibel) wrote :

I verified on 16.04 both on the live session and an installed system there is an indicator to select the method of input when I select simplified Chinese in the list of languages. There is no input method selected by default but it's trivial to click on the indicator and select the one I want.

Sebastien Bacher (seb128) wrote :

Right, so the current behaviour is not an Ubuntu bug but how current GNOME behaves. They believe it's not possible to "guess" what input method an user for a defined locale is going to need and don't want to have a cluttered menu with a bunch of options which the user is not going to need.

The recommended way to set it up on the installed system is to use gnome-initial-setup on first login (which we don't do in Ubuntu), that wouldn't resolve the installer/live cd cases though where the user is just going to need to use the settings to configure it.

That's not a simple fix but something we need to give more consideration to next cycle, I'm lowering the importance and unassigning, it's not likely we change anything for artful now.

Changed in ubiquity (Ubuntu Artful):
importance: Critical → High
assignee: Sebastien Bacher (seb128) → nobody
Gunnar Hjalmarsson (gunnarhj) wrote :

@Jean-Baptiste: Can you please show us the output of these commands on a 16.04 Chinese install:

cat /etc/default/keyboard

gsettings get org.gnome.desktop.input-sources sources

cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="cn"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

gsettings get org.gnome.desktop.input-sources sources
[('xkb', 'cn'), ('xkb', 'us'), ('fcitx', 'pinyin')]

Mitsuya Shibata (cosmos-door) wrote :

Before artful, unity-settings-daemon (based on gnome-settings-daemon) setup input sources by locale.
http://bazaar.launchpad.net/~unity-settings-daemon-team/unity-settings-daemon/trunk/view/head:/plugins/keyboard/gsd-keyboard-manager.c#L505

However already commented, this code in gnome-settings-daemon are replaced by gnome-initial-setup.
https://github.com/GNOME/gnome-settings-daemon/commit/912c41a1b729d635d3b335c87653141781e9be9e

If Ubuntu doesn't use gnome-intial-setup, should be engine_from_locale() reindroduced?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-initial-setup (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Reverting that change for artful makes sense yes

affects: ubiquity (Ubuntu Artful) → gnome-settings-daemon (Ubuntu Artful)
Mitsuya Shibata (cosmos-door) wrote :

I created patch. This patch will fix but #1514544 too.
Building patched package is completed successfully. I'll test the package after tomorrow.

The attachment "initial-setup-input-sources.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

Hi Mitsuya, thank you for your great work.

gnome-settings-daemon 3.26.1-0ubuntu2 was released with similar patch.
This issue was almost fixed.
"almost" means I find an issue and file a bug as #1722681.

Mitsuya Shibata (cosmos-door) wrote :

> gnome-settings-daemon 3.26.1-0ubuntu2 was released with similar patch.

Thank you for your information.
I confirmed it and close this ticket.

Thanks!

Changed in ubuntu-translations:
status: New → Invalid
Changed in gnome-initial-setup (Ubuntu Artful):
status: Confirmed → Invalid
Changed in gnome-settings-daemon (Ubuntu Artful):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers