GDM login doesn't scale on Hi-DPI display

Bug #1685035 reported by jefferson on 2017-04-20
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
Ubuntu GNOME
Medium
Unassigned
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

Impact
------
GDM's login screen was being start with no gnome-settings-daemons plugins. In particular, this broke Hi-DPI support in the login screen

Test Case
---------
- Install the update on a computer running Ubuntu GNOME 17.04 with a Hi-DPI display (ideally one that worked well with Ubuntu GNOME 16.10).
- Restart your computer.
- The login screen should automatically show at the right scale.

Regression Potential
--------------------
See the other 3.24.2 bugs but this commit is a simple typo fix.

Original Bug Report
-------------------
Ubuntu gnome 17.04, gnome 3.24. On high resolution display, 3200x1800, login screen is too tiny to read. GDM login screen doesn't reflect changes to org.gnome.desktop.interface scaling-factor or text-scaling-factor.

Eg:
xhost +SI:localuser:gdm
sudo su gdm -s /bin/bash
gsettings set org.gnome.desktop.interface scaling-factor 2
gsettings set org.gnome.desktop.interface text-scaling-factor 2.0

no effect.

Creating a gdm user under /etc/dconf and running dconf update has no effect either. Scaling-factor seems to scale the mouse cursor, but nothing else.

jefferson (jefferson9) on 2017-04-20
description: updated
Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: gdm (Ubuntu) → gdm3 (Ubuntu)
Jeremy Bicha (jbicha) on 2017-04-21
Changed in gdm3 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-gnome:
importance: Undecided → Medium
status: New → Triaged
affects: gdm3 (Ubuntu) → gnome-settings-daemon (Ubuntu)
affects: gdm → gnome-settings-daemon
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Confirmed
Jeremy Bicha (jbicha) on 2017-04-22
Changed in gnome-settings-daemon (Ubuntu Zesty):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-settings-daemon:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.24.1-0ubuntu2

---------------
gnome-settings-daemon (3.24.1-0ubuntu2) artful; urgency=medium

  * Add git_fix-gdm-plugins.patch:
    - Fix gdm starting with no plugins which broke Hi-DPI support
      on the login screen (LP: #1685035)

 -- Jeremy Bicha <email address hidden> Sat, 22 Apr 2017 09:22:33 -0400

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
jefferson (jefferson9) wrote :

OP here, I installed the 4 packages here: https://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.24.1-0ubuntu2/+build/12460693 (change log has that patch)

However the issue still persists. On startup, everything is still tiny. Large text button still does nothing.

Jeremy Bicha (jbicha) wrote :

jefferson9, please don't install packages built for artful (Ubuntu 17.10) on your zesty (Ubuntu 17.04) install. Here's how I recommend getting back to the zesty packages. The gnome-settings-daemon-dev and gnome-settings-daemon-dbgsym packages are not in the default install and aren't needed by most people (but it's fine to keep them installed if you think you want them).

sudo apt remove gnome-settings-daemon-dev gnome-settings-daemon-dbgsym
sudo apt install gnome-settings-daemon/zesty gnome-settings-daemon-schemas/zesty

There was a mistake in the artful upload so I uploaded a new version now.

This week, there is another gnome-settings-daemon Stable Release Update (LP: #1682132) that was already accepted into zesty-proposed for testing before the fix for this bug was pushed into gnome-settings-daemon's git repository. After that previous fix is verified and pushed into zesty-updates, we can work on getting this bug fixed into zesty too.

jefferson (jefferson9) wrote :

Okay, before reverting out of curiousity I did try the recently updates packages and can confirm the issue is resolved, and everything seems stable, no regressions.

Jeremy Bicha (jbicha) on 2017-05-09
description: updated
Changed in gnome-settings-daemon (Ubuntu Zesty):
status: Triaged → In Progress

Hello jefferson, or anyone else affected,

Accepted gnome-settings-daemon into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.24.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-settings-daemon (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed

installed v3.24.2 in 17.04 proposed today and it works fine, Thank you :)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.24.2-0ubuntu0.1

---------------
gnome-settings-daemon (3.24.2-0ubuntu0.1) zesty; urgency=medium

  * New upstream release (LP: #1689610)
    - Fix gdm starting with no plugins which broke Hi-DPI support
      on the login screen (LP: #1685035)
    - Fix brightness control in some dual-GPU computers (LP: #1683445)
    - Own the D-Bus name that the API documentation tells users of the
      multimedia keys API they should use (org.gnome.SettingsDaemon.MediaKeys),
      in addition to the D-Bus name that they actually use in practice
      (org.gnome.SettingsDaemon). (LP: #1686077)
  * Add revert-disable-rfkill-keys-handling.patch:
    - Revert commit that disabled GNOME's rfkill handling. Although
      this fixes problems for some users, it makes things worse for
      other people.

 -- Jeremy Bicha <email address hidden> Tue, 09 May 2017 14:05:29 -0400

Changed in gnome-settings-daemon (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-settings-daemon has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

William Maddler (news-maddler) wrote :

I think this is still happening on 17.10 with 3.26.1-3ubuntu1.
I'm on a Lenovo Thinkpad T470p laptop with Intel video card.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.