no need to call 'gnome-update-wallpaper-cache' anymore

Bug #1318621 reported by Tim Lunn on 2014-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
High
Unassigned
ubiquity (Ubuntu)
High
Unassigned
unity-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

These days, g-s-d/u-s-d are running in the installer session, so we don't need to call a binary that forces a redraw of the background just so we can copy the cache across.

Once these calls are dropped from ubiquity we can also drop the corresponding binary from g-s-d and u-s-d.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity 2.18.8
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.2-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon May 12 21:53:03 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationDate: Installed on 2012-09-23 (596 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tim Lunn (darkxst) wrote :
Adolfo Jayme (fitojb) on 2014-07-29
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.2

---------------
ubiquity (2.21.2) vivid; urgency=medium

  [ Dimitri John Ledkov ]
  * Add --quiet option to dmidecode calls, in the future release that will
    prevent dmidecode from printing error banner if a newer than dmidecode
    smbios version has happened to be in use. LP: #1353580.
  * Add "support" for Gauja laptops and self-builts - that is do not use
    "To be filled by O.E.M." as a valid model name.
  * Remove setting translated placeholder text in the usersetup
    plugin. (LP: #1283047)
  * Drop translation messages from ubiquity.templates.

  [ Unit 193 ]
  * Enable the ubiquity panel in xfwm4 now since it is functional.

  [ Tim Lunn ]
  * scripts/plugininstall.py: Remove obsolete code to generate wallpaper
    cache, unity-settings-daemon/gnome-settings-daemon now run in install
    mode (LP: #1318621)

  [ Martin Wimpress ]
  * Improve support for Mate desktop.

  [ Shih-Yuan Lee (FourDollars) ]
  * Fix the usage of effective uid/gid and the HOME environment variable.

  [ Dimitri John Ledkov ]
  * Automatic update of included source packages: clock-setup
    0.121ubuntu1, console-setup 1.70ubuntu11, partman-basicfilesystems
    108ubuntu1, partman-crypto 78ubuntu1, partman-jfs 45, partman-lvm
    102, partman-xfs 55.
 -- Dimitri John Ledkov <email address hidden> Sun, 21 Dec 2014 06:46:46 +0000

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers