Activity log for bug #1236752

Date Who What changed Old value New value Message
2013-10-08 09:01:44 Bernhard bug added bug
2013-10-08 09:01:44 Bernhard attachment added xorg.conf https://bugs.launchpad.net/bugs/1236752/+attachment/3865970/+files/xorg.conf
2013-10-08 19:20:21 Launchpad Janitor gnome-settings-daemon (Ubuntu): status New Confirmed
2013-10-08 19:20:29 Jason Conti bug added subscriber Jason Conti
2013-10-14 18:30:10 Bernhard tags amd64 apport-bug precise amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise
2013-10-15 01:17:11 Shih-Yuan Lee bug added subscriber Shih-Yuan Lee
2013-10-15 19:51:55 Iain Lane nominated for series Ubuntu Precise
2013-10-15 19:51:55 Iain Lane bug task added gnome-settings-daemon (Ubuntu Precise)
2013-10-15 19:52:21 Iain Lane gnome-settings-daemon (Ubuntu): status Confirmed Fix Released
2013-10-15 19:52:24 Iain Lane gnome-settings-daemon (Ubuntu Precise): status New Triaged
2013-10-15 19:52:28 Iain Lane gnome-settings-daemon (Ubuntu Precise): importance Undecided Critical
2013-10-15 19:55:06 Iain Lane description Hello, I use Kubuntu 12.04.x with lightdm as login-manager to KDE and the nvidia binary driver with 2 monitors (DVI, TwinView). My Multi-Monitor config: right monitor: MAIN monitor left monitor: second monitor as extension: with mode left of Main Monitor This config is setup with nvidia-settings, which stores in xorg.conf and in .nvidia-settings in home-dir. In KDE the config is also stored with krandr as default config. After upgrading from package gnome-settings-daemon (3.4.2-0ubuntu0.6.2) to gnome-settings-daemon (3.4.2-0ubuntu0.6.3), the xorg.conf settings are ignored/misinterpreted as well as the KDE krandr settings. When lightdm is started, the second monitor is on the right side, and when logging-in to KDE either clone mode on both monitors is started or the second monitor is on the right side (mirrored). => I have to set my desired settings manually again and at the next reboot the problem persists. I have downgraded to gnome-settings-daemon-3.4.1-0ubuntu1, and the problem is gone. All fine again. I didn't find the previous version 3.4.2-0ubuntu0.6.2. How can I get this package version? Faulty package/patch: gnome-settings-daemon (3.4.2-0ubuntu0.6.3) precise; urgency=low * debain/patches/follow-lid.patch: - external/internal monitors mirrored on boot when laptop lid is closed (lp: #1065979) -- Ritesh Khadgaray <email address hidden> Tue, 13 Aug 2013 11:29:20 +0530 1065979 external/internal monitors mirrored on boot when laptop lid is closed I use this PC at my workplace, so it is important for me to solve this problem. Thank you for your help! Best regards, Bernhard lsb_release -rd Description: Ubuntu 12.04.3 LTS Release: 12.04 ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: gnome-settings-daemon 3.4.1-0ubuntu1 ProcVersionSignature: Ubuntu 3.2.0-54.82-generic 3.2.50 Uname: Linux 3.2.0-54-generic x86_64 NonfreeKernelModules: nvidia ApportVersion: 2.0.1-0ubuntu17.5 Architecture: amd64 Date: Tue Oct 8 10:29:18 2013 EcryptfsInUse: Yes InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423) MarkForUpload: True ProcEnviron: LANGUAGE=de_AT TERM=xterm PATH=(custom, no user) LANG=de_AT.UTF-8 SHELL=/bin/bash SourcePackage: gnome-settings-daemon UpgradeStatus: No upgrade log present (probably fresh install) [ Description ] The fix for bug #1065979 regresses multi-monitor behaviour for some users. [ Fix ] Revert it. [ Regression potential ] This will undo any fix for bug #1065979. But we promise that we won't *introduce* bugs in stable release updates, so this has to take priority. The contributor of the fix to that bug can try again if desired, but probably with an extended ageing period in -proposed. [ Original report ] Hello, I use Kubuntu 12.04.x with lightdm as login-manager to KDE and the nvidia binary driver with 2 monitors (DVI, TwinView). My Multi-Monitor config: right monitor: MAIN monitor left monitor: second monitor as extension: with mode left of Main Monitor This config is setup with nvidia-settings, which stores in xorg.conf and in .nvidia-settings in home-dir. In KDE the config is also stored with krandr as default config. After upgrading from package gnome-settings-daemon (3.4.2-0ubuntu0.6.2) to gnome-settings-daemon (3.4.2-0ubuntu0.6.3), the xorg.conf settings are ignored/misinterpreted as well as the KDE krandr settings. When lightdm is started, the second monitor is on the right side, and when logging-in to KDE either clone mode on both monitors is started or the second monitor is on the right side (mirrored). => I have to set my desired settings manually again and at the next reboot the problem persists. I have downgraded to gnome-settings-daemon-3.4.1-0ubuntu1, and the problem is gone. All fine again. I didn't find the previous version 3.4.2-0ubuntu0.6.2. How can I get this package version? Faulty package/patch:   gnome-settings-daemon (3.4.2-0ubuntu0.6.3) precise; urgency=low   * debain/patches/follow-lid.patch:     - external/internal monitors mirrored on boot when laptop lid is closed       (lp: #1065979)  -- Ritesh Khadgaray <email address hidden> Tue, 13 Aug 2013 11:29:20 +0530 1065979 external/internal monitors mirrored on boot when laptop lid is closed I use this PC at my workplace, so it is important for me to solve this problem. Thank you for your help! Best regards, Bernhard lsb_release -rd Description: Ubuntu 12.04.3 LTS Release: 12.04 ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: gnome-settings-daemon 3.4.1-0ubuntu1 ProcVersionSignature: Ubuntu 3.2.0-54.82-generic 3.2.50 Uname: Linux 3.2.0-54-generic x86_64 NonfreeKernelModules: nvidia ApportVersion: 2.0.1-0ubuntu17.5 Architecture: amd64 Date: Tue Oct 8 10:29:18 2013 EcryptfsInUse: Yes InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423) MarkForUpload: True ProcEnviron:  LANGUAGE=de_AT  TERM=xterm  PATH=(custom, no user)  LANG=de_AT.UTF-8  SHELL=/bin/bash SourcePackage: gnome-settings-daemon UpgradeStatus: No upgrade log present (probably fresh install)
2013-10-15 19:55:57 Iain Lane tags amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise regression-update
2013-10-15 22:06:57 Brian Murray gnome-settings-daemon (Ubuntu Precise): status Triaged Fix Committed
2013-10-15 22:06:59 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2013-10-15 22:07:02 Brian Murray bug added subscriber SRU Verification
2013-10-15 22:07:13 Brian Murray tags amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise regression-update amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise regression-update verification-needed
2013-10-16 08:22:52 Bernhard tags amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise regression-update verification-needed amd64 apport-bug gnome-settings-daemon kubuntu lightdm monitor multi-monitor nvidia precise regression-update verification-done
2013-10-16 13:38:09 Simon Déziel bug added subscriber Simon Déziel
2013-10-16 16:31:27 Launchpad Janitor gnome-settings-daemon (Ubuntu Precise): status Fix Committed Fix Released
2013-10-16 16:31:31 Brian Murray removed subscriber Ubuntu Stable Release Updates Team