gnome-settings-daemon input "hotplug-command" not working in 13.10

Bug #1231947 reported by bwat47
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Tim Lunn

Bug Description

I have always used this method in ubuntu to enable 3-finger tap on my synaptics touchpad (and by the way, 3-finger tap works out of the box in every non-ubuntu distro /rant):

create a file called
chmod +x
gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command "/home/brandon/"

This way 3 finger tap is working and gnome always respects the setting and doesn't reset it on suspend/resume. This worked perfectly in 12.04, 12.10, and 13.04. In 13.10 it just does not work. I double checked, made sure I had the right path to the file, and that the file was executable. If I manually execute it works, but when I boot my computer it just does not seem to run the hotplug command, and if I manually run the script and then suspend/resume, gnome disables the 3 finger tap upon resume, again not respecting the hotplug-command.

This is a big issue, this is the only way to get 3 finger tap working on a touchpad in ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-settings-daemon 3.8.5-0ubuntu4
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Fri Sep 27 07:37:54 2013
InstallationDate: Installed on 2013-09-27 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130925.1)
MarkForUpload: True
 PATH=(custom, no user)
SourcePackage: gnome-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.xdg.autostart.gnome.fallback.mount.helper.desktop: [modified]
modified.conffile..etc.xdg.autostart.gnome.settings.daemon.desktop: [modified]
mtime.conffile..etc.xdg.autostart.gnome.fallback.mount.helper.desktop: 2013-09-27T07:35:28.871725
mtime.conffile..etc.xdg.autostart.gnome.settings.daemon.desktop: 2013-09-27T07:35:28.875723

Revision history for this message
bwat47 (bwat47) wrote :
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Tim (darkxst)
importance: Undecided → Low
Revision history for this message
Tim Lunn (darkxst) wrote :

Perhaps this is related to this change?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Revision history for this message
b_b (brunobergot) wrote :

Got exactly the same bug, i've tried to add exit 0 on last line of my script as it seems recommended on page linked by Time (thanks form him) but it doesn't fix the bug (exit 0 doesn't fix ti too).

Revision history for this message
Tim Lunn (darkxst) wrote :

b_b, please attach ~/.cache/upstart/gnome-settings-daemon.log

Revision history for this message
b_b (brunobergot) wrote :

Here we go :)

Revision history for this message
dimovnike (dimovnike) wrote :

any idea of a workaround?

Revision history for this message
b_b (brunobergot) wrote :

It works for me now (i've place an exit 1 at the end of my script). I can't tell if it's an update that fixed the bug, maybe...

Revision history for this message
Quinn Strahl (qstrahl) wrote :

Also affected by this issue, on 14.04. Very irksome. =S

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.