gnome-settings-daemon doesn't detect Anthy(Japanese Input Method) automatically.

Bug #1230265 reported by Ikuya Awashiro on 2013-09-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

On Ubuntu 13.10, gnome-settings-daemon doesn't detect Anthy automatically.
I checked gnome-settings-daemon's debian/channgelog and found the issue.
http://bazaar.launchpad.net/~ubuntu-desktop/gnome-settings-daemon/ubuntu/revision/417
Please remove this patch. Hard-code is necessary on GNOME 3.8. Because We don't have gnome-initial-setup in repository.

Removing git_revert_hardcoded_input_methods.patch, it looks good to me.

Hi Jeremy, please take a look.

I was wrong. We (Ubuntu) doesn't have gnome-initial-setup.
https://bugs.launchpad.net/ubuntu/+bug/1161583

summary: - Anthy doesn't look up automatically.
+ gnome-settings-daemon doesn't detect Anthy(Japanese Input Method)
+ automatically.
description: updated

Here is the debdiff for removing git_revert_hardcoded_input_methods.patch.

Hi Sebastien who is latest uploader of gnome-settings-daemon, could you please take a look at this issue? We don't have much time.

The attachment "remove-git_revert_hardcoded_input_methods.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks, dropping that patch makes sense to me since it indeed same to have been made on the assumption that users should be using that new tool, that we don't have.

I'm still going to try to get input from people in the team knowing more than me about input methods, before uploading

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.8.5-0ubuntu7

---------------
gnome-settings-daemon (3.8.5-0ubuntu7) saucy; urgency=low

  [ Ikuya Awashiro ]
  * debian/patches/series:
    - removed git_revert_hardcoded_input_methods.patch.
     - Hard coded input methods required for some language. (lp: #1230265)

  [ Tim ]
  * debian/patches/fix_media_keys_on_unity.patch: Revise patch to load
    legacy keygrabber for all non-gnome-shell sessions (LP: #1235625)

  [ Iain Lane ]
  * Rename on_unity_appeared in the above patch.
 -- Iain Lane <email address hidden> Mon, 07 Oct 2013 17:06:51 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

Causes a regression -
(lp: #1237564

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers