No icons next to buttons/menu items

Bug #1228886 reported by Matthieu Baerts on 2013-09-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

Hello,

With gnome-settings-daemon 3.8.5-0ubuntu4, we no longer have icon next to buttons/menu items even if "menus-have-icons" and "buttons-have-icons" options are enabled.

It seems it's due to this new patch: git_hardcode_deprecated_gtk_settings.patch
This patch has been added to fix the bug #1227537 but is it maybe possible to fix this bug and still use these settings?

Note that this patch has been added to fix a bug only for users of gnome3-team ppa. Is it not better to only include this patch in this ppa?

PS: Will these options ("menus-have-icons" and "buttons-have-icons") be dropped in Ubuntu when GTK 3.10 will be used? I know that Gnome devs/designers have decided to drop stock icons and icons next to menu items/buttons but these icons can be very useful to quickly find a menu item. We will have to read items instead of just find the right icon.
It's also a problem for Applications Menus or files browsers made with a GtkMenu to quickly browse files, etc. (it's still possible to have these icons if devs force it but it will no longer be possible with GTK 4).

And it's also much more easier to indicate to children that they have to click on this icon than on this label (if they are still not able to read the label).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.8.5-0ubuntu5

---------------
gnome-settings-daemon (3.8.5-0ubuntu5) saucy; urgency=low

  * debian/patches/git_hardcode_deprecated_gtk_settings.patch:
    - revert previous change, it's buggy (lp: #1228886). GNOME/GTK upstream
      decided to drop support for some of their settings in 3.10, but:
      - those settings are still there and working in saucy
      - they shouldn't have been dropped without discussion
      - the fix is to workaround issues with a ppa, which can be solved by
        simply adding those gsettings key to the schemas in the ppa version
 -- Sebastien Bacher <email address hidden> Fri, 27 Sep 2013 16:46:04 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers