Ubuntu

Can't change wallpaper unless /org/gnome/desktop/background/show-desktop-icons is true.

Reported by Robert Bruce Park on 2013-02-05
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

When I logged into my computer today, Unity wasn't showing my wallpaper. The first thing I tried was to go into the Appearance settings and change the wallpaper. At first, I was not able to make any changes to the wallpaper. Then I started tinkering around with dconf, just to see if I could find any settings that might interfere with the wallpaper.

What I found was that /org/gnome/desktop/background/show-desktop-icons was set to false, but if I set it to true, then the regular Appearance settings panel was able to change the wallpaper. and again, if I set it back to false, then I was no longer able to change what wallpaper is used.

Steps to reproduce:

1. Using dconf, set /org/gnome/desktop/background/show-desktop-icons to false

2. Using Gear menu -> System Settings -> Appearance, try to change the wallpaper. You can't.

3. Set show-desktop-icons back to true.

4. Change the wallpaper now -- it works.

So, this is quite strange to me -- turning on show-desktop-icons doesn't actually render any icons on my desktop. It only enables the wallpaper switching to work. My best guess as to what is happening here is that "show-desktop-icons" really just means "make nautilus render root window", and somehow I've stumbled onto a bug by which g-s-d can no longer render the wallpaper for itself, so turning on show-desktop-icons forces nautilus to take over, where it is successful in rendering the wallpaper.

Let me know if there's any additional information I can provide, and I will happily cooperate in troubleshooting ;-)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-settings-daemon 3.6.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-4.8-generic 3.8.0-rc6
Uname: Linux 3.8.0-4-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Mon Feb 4 19:56:37 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-09-14 (143 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to raring on 2012-11-14 (82 days ago)

Robert Bruce Park (robru) wrote :
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
Nicholas J. Alonge (njalonge) wrote :

I couldn't replicate the problem of not being able to change the wallpaper, but toggling that setting causes problems with the fade animation of changing the wallpaper.

I opened dconf-editor, and it looks like the box was unchecked by default (even though in gnome-tweak-tool, "have file manager handle the desktop" is on). I checked it to enable it (org.gnome.desktop.background.show-desktop-icons) then changed the wallpaper and it worked as expected. When I toggled that setting off again I was still able to change the wallpaper but it didn't fade in between wallpapers, it was an abrupt change. It also disabled nautilus handling the desktop.

Sebastien Bacher (seb128) wrote :

Thanks for the bug reports, it's not a bug though, it's a side effect of the change in https://launchpad.net/ubuntu/+source/ubuntu-settings/12.10.7

We optimized for the default installation, nautilus is rendering the background on Ubuntu so we don't need to activate the g-s-d plugin to do that (even if it does check what nautilus is doing and skip the rendering it's still code loaded in memory and some cycles wasted for 99% of users who will never change that settings)

The rational was also that users who are technical enough to go tweak their "show icons on the desktop" gsettings key can also tweak the g-s-d one to re-enable the background rendering.

Sorry that it did bite you though, you seem to be in a that small group of people who do tweak their config to not use nautilus...

Changed in gnome-settings-daemon (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
status: New → Invalid
importance: Undecided → Low
Robert Bruce Park (robru) wrote :

Yes, ok, I've tinkered with this further, and what I've discovered is that once I enabled org.gnome.settings-daemon.plugins.background.active, then I was able to change desktop wallpapers with show-desktop-icons set to false. And, as you say, the background changing only has the nice fade when show-desktop-icons is true.

So, I guess the real question is, how did org.gnome.settings-daemon.plugins.background.active get set to false? Did some update do this to me? Or did I just forget about setting some weird setting somewhere? (I have used both gnome-tweak-tool and unity-tweak-tool in the past so it's not impossible that I inadvertently disabled this without realizing)

Junior (correojunior) wrote :

I have same issue with Gnome Ubuntu 13.04 beta, but I don't need to change background, just by switching show icons background shows back

Danny Verbeek (dverbeek84) wrote :

I have also got the same issue with Gnome-shell ubunut 13.04 beta 2. I also only have to set show-desktop-icons to true.

But i use gnome-tweak-tools and i alwasy disable "Have fiel manager handle the desktop" becouse it slows down nautilus the first time you open it. This option sets show-desktop-icons to false. But i also used gnome-tweak-tools in ubuntu 12.04 in the same way. But this did not effect my background.

I am running Ubuntu 13.04 (daily build) and with

'org.gnome.settings-daemon.plugins.background' set to active, and
'Hvae file manager handle the desktop' set to false

LightDM background reverts to default.

Kay (dtc-kay) wrote :

I had the same problem after upgrade from 12.10 to 13.04. Thanks for the tip to enable desktop icons.

Marius Hofert (marius-hofert) wrote :

Just for the sake of completeness: Both https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1165256 and https://bugs.launchpad.net/ubuntu/+bug/1173834 seem to be 'follow-up' bugs of this one.

Marius Hofert (marius-hofert) wrote :

Given the importance/effects of this bug with respect to the bugs I pointed out in #9, I would suggest that the importance of this bug is raised.

Marius Hofert (marius-hofert) wrote :

I filed this as a new bug report for Unity Tweak Tool: https://bugs.launchpad.net/ubuntu/+bug/1181982

I would like to support the request to make this more important. You can't ship something out like this to normal customers. Changing the wallpaper is pretty basic and must work.

Changed in gnome-settings-daemon (Ubuntu):
status: Invalid → Confirmed
Robert Bruce Park (robru) wrote :

The point is that by default, changing the wallpaper does work. You have to deliberately install a tweak tool and break it yourself in order for it to be broken.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid

I did a bunch of steps but the solution mentioned in the first part of the page seemed to work for me

http://www.jobnix.in/fix-ubuntu-13-04-background-is-white-and-no-wallpaper/

Randy Bass (randybass) wrote :

"It's not a bug, it's a feature." Yeah, right. Who's idea was it to say this isn't a bug? And then you need to install some other app to override it? I tried the recommended operations above, and it still didn't work for me. This is totally bogus.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers