org.gnome.settings-daemon.plugins.power button-power ignores shutdown

Bug #1084374 reported by jwsheff on 2012-11-29
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

System Settings - Power is set to "Shutdown" for "When the power button is pressed:". It should go through a automatic shut down process with out any additional response from me. However it brings up a dialog box asking me what I want to do. That should be the response when the option is set to: "Ask me". As it is now they both act the same.

ProblemType: Bug
DistroRelease: elementary OS 0.2
Package: elementary-desktop 1.284-0~355~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-33.52-generic-pae 3.2.31
Uname: Linux 3.2.0-33-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu15+elementary3~precise1
Architecture: i386
CrashDB: elementary_meta
Date: Wed Nov 28 20:17:32 2012
InstallationMedia: elementary OS 0.2 "Luna" - Beta 1 i386 (20121114)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

jwsheff (jsheffield40) wrote :
Cody Garver (codygarver) on 2012-11-29
affects: elementaryos → switchboard-plug-power
Julien Spautz (julien-spautz) wrote :

Setting org.gnome.settings-daemon.plugins.power button-power to "shutdown" does the same as setting it to "interactive", so this is not the plugs fault, but rather a bug in gnome-settings-daemon. Similarly, settings button-sleep to "shutdown" makes it suspend. It seems like "shutdown" is simply ignored, and the keys use their default action instead. Again, this seems to be an upstream bug.

Cody Garver (codygarver) on 2013-02-15
Changed in switchboard-plug-power:
status: New → Incomplete
summary: - Power setting for power button not correct
+ org.gnome.settings-daemon.plugins.power button-power ignores shutdown
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
jwsheff (jsheffield40) wrote :

I have entered this bug with GNOME Bugzilla as requested. The bug number is: Bug 698733

Sebastien Bacher (seb128) wrote :

thanks

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Incomplete
Changed in gnome-control-center:
status: Incomplete → New
Changed in gnome-control-center:
status: New → Fix Released
Daniel Fore (danrabbit) on 2015-05-02
no longer affects: switchboard-plug-power
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.