Screen doesn’t lock on lid close

Bug #1048420 reported by Anders Kaseorg on 2012-09-10
272
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

As of gnome-shell 3.5.91-0ubuntu1, closing my laptop lid no longer causes the screen to lock.

This is distinct from bug 1042907 because it persists even when using GDM as the display manager.

Anders Kaseorg (andersk) on 2012-09-10
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Anders Kaseorg (andersk) on 2012-09-18
tags: added: quantal regression-release
description: updated
Jeremy Bicha (jbicha) wrote :

Do you have the same problem when running a different desktop, like Unity?

If so, this isn't a gnome-shell bug, but maybe a kernel bug or maybe a gnome-settings-daemon bug.

Anders Kaseorg (andersk) wrote :

No, the screen correctly locks on suspend under both Unity and GNOME classic. (I tested all three desktops with a freshly created account.)

Anders Kaseorg (andersk) wrote :

Okay, as of gnome-shell 3.5.92-0ubuntu1, a lid close locks the screen when the display manager is LightDM. But it still doesn’t when the display manager is GDM.

Tim Barkley (tim-barkley) wrote :

Same issues as above in gnome-shell 3.6.0-0ubuntu1. ctrl+alt+L works fine, but screen is automatically unlocked when resuming from suspend.

Jeremy Bicha (jbicha) wrote :

Thanks Tim Lunn for troubleshooting; it looks like this has already been fixed upstream.

affects: gnome-shell (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu14

---------------
gnome-settings-daemon (3.4.2-0ubuntu14) quantal; urgency=low

  * debian/patches/git_power_dbus_path.patch:
    - Fix screen not locking when lid is closed while running
      GNOME Shell on GDM (LP: #1048420)
 -- Jeremy Bicha <email address hidden> Fri, 28 Sep 2012 21:04:37 -0400

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.