xrandr; explicitly set clone state variable when generating monitor configs

Bug #1014533 reported by Hsin-Yi, Chen (hychen) on 2012-06-18
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Oneiric
High
Unassigned
Precise
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

SRU Justification
=================

[Impact]

when the user try to use the hot key (depend on the system , some is Fn+F8,and
some is Fn+F4), the xinerama configuration will not show, and sometimes other
display wrong issue will happen.

[Development Fix]

* gnome-settings-daemon 3.4.2-0ubuntu4 does not has the patch

[Stable Fix]

# precise-update

* gnome-settings-daemon 3.4.1-0ubuntu1.1 does not has this patch.

# oneiric-update

* gnome-settings-daemon 3.2.2-0ubuntu2.1 does not has this patch.

[Upstream Fix]

* http://git.gnome.org/browse/gnome-settings-daemon/commit/?id=5f7643800a8bc26bd2835dc9a3df085bf0fab422
* https://bugzilla.gnome.org/show_bug.cgi?id=677472

[Test Case]

Step To Reproduce

1. To connect external monitor by VGA or HDMI.
2. To install Ubuntu
3. login to unity

Excepted Result:

xinerama is enabled. the screen displays in 2 monitor(extend mode).

Actual Result:

xinerama is not enabled.

[Regression Potential]

The patch is accepted in gnome-settings-daemon upstream.
thie mofification is minal, it just clone flag as false in the xinerama case.

Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
Changed in oem-priority:
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu Precise):
importance: Undecided → High
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

thanks, I've uploaded a SRU with that fix included, it will be in quantal as well with the next upload (the patch is coming from upstream git so it will be in their next tarball)

Anthony Wong (anthonywong) wrote :

Hi Sebastien, we also need to fix Oneiric for oem projects too, thanks.

Sebastien Bacher (seb128) wrote :

Uploaded for oneiric as well

Changed in gnome-settings-daemon (Ubuntu Oneiric):
importance: Undecided → High
status: New → Fix Committed

Hello Hsin-Yi, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: blocks-hwcert-enablement

1. verified gnoem-settings.daemon 3.4.2-0ubuntu0.2 in precise-proposed and use hotkey to cycling the X configurations, all works.

2. wait to test oneiric proposed package

Anthony Wong (anthonywong) wrote :

May I know when the oneiric-proposed package will be ready for verification?

Changed in oem-priority:
status: New → Fix Committed
Chris Van Hoof (vanhoof) wrote :

Heya Sebastien -- I'm not seeing this in oneiric-proposed but do see it in precise-proposed:

http://people.canonical.com/~ubuntu-archive/pending-sru.html

--chris

Adam Conrad (adconrad) wrote :

Hello Hsin-Yi, or anyone else affected,

Accepted gnome-settings-daemon into oneiric-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
Sebastien Bacher (seb128) wrote :

settings verification-done for precise based on comment #6, I will reset to verification-needed for oneiric once the precise SRU is copied to -updates

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu0.2

---------------
gnome-settings-daemon (3.4.2-0ubuntu0.2) precise-proposed; urgency=low

  * Upload to precise-proposed

  [ Chris Coulson ]
  * debian/patches/10_smaller_syndaemon_timeout.patch: Update to increase
    the size of the stack allocated array for the extra argument passed to
    syndaemon. This fixes a crash in the PLT due to a corrupt %ebx register
    (which holds the GOT base address on i386), which was caused in an earlier
    function by writing zero in to the location on the stack where the value of
    %ebx is saved. Thanks to Sebastien Bacher for spotting the buggy patch!
    (fixes LP: #1007588)

  [ Hsin-Yi, Chen (hychen) ]
  * debian/patches/git_xrandr_explicitly_set_clone_state.patch:
    - "xrandr; explicitly set clone state variable when generating monitor
       configs" (LP: #1014533)
 -- Sebastien Bacher <email address hidden> Mon, 18 Jun 2012 12:32:40 +0200

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Fix Committed → Fix Released

confirm gnome-settings-daemon 3.2.2-0ubuntu2.2 in oneiric-proposed fix this bug

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.2.2-0ubuntu2.2

---------------
gnome-settings-daemon (3.2.2-0ubuntu2.2) oneiric-proposed; urgency=low

  [ Hsin-Yi, Chen (hychen) ]
  * debian/patches/git_xrandr_explicitly_set_clone_state.patch:
    - "xrandr; explicitly set clone state variable when generating monitor
       configs" (LP: #1014533)
 -- Sebastien Bacher <email address hidden> Mon, 18 Jun 2012 12:32:40 +0200

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu9

---------------
gnome-settings-daemon (3.4.2-0ubuntu9) quantal-proposed; urgency=low

  [ Sebastien Bacher ]
  * debian/control.in:
    - don't build-depends on gconf
    - updated gnome-control-center breaks version for gsettings
  * debian/patches/revert_git_a11y_gsettings.patch,
    debian/patches/revert_git_stop_using_gconf.patch,
    debian/patches/revert_git_use_gsetting_keybindings.patch:
    - drop the gconf to gsettings migration reverts (LP: #1035261)

  [ Keng-Yu Lin ]
  * debian/patches/git-mask-out-virtual-modifiers.patch
    - patch from upstream git, fix the grabbing issue of the
      keyboard shortcut with virtual (Super, Hyper, Meta) modifier.
      (lp: #950160)

  [ Edward Donovan ]
  * debian/source_gnome-settings-daemon.py: Fix for Python 3. (LP: #1013171)

  [ Hsin-Yi, Chen (hychen) ]
  * debian/patches/git_xrandr_explicitly_set_clone_state.patch:
    - "xrandr; explicitly set clone state variable when generating monitor
      configs" (LP: #1014533)

  [ Michael Terry ]
  * debian/patches/git-smartcard-crash.patch:
    - Don't crash on login with a smartcard (LP: #1031034)
 -- Sebastien Bacher <email address hidden> Thu, 23 Aug 2012 17:04:16 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers